^^ crow help: general (connectivity, device q's, ecosystem)

Okay I figured it out I think… For whatever reason crow -> JF -> W/ wasn’t working. Connecting W/ directly to crow seems to establish the connection.

1 Like

Trying to upgrade firmware to 1.0.1. I put my crow into crow dfu bootloader, double clock on window-firmware_update.dat and get a cannot open device. Ask dfu to list devices and it say cannot open device. Thanks for help.
image

Fixed. Windows people need to update USB driver. Instructions on GitHub here

Is it possible to update Crow from a Raspberry Pi / Norns connected to Crow ?

Sorry if it’s been asked before, I haven’t read the whole thread… :confused:

I don’t have access to a computer running at least OS X 10.10 at the moment (I only have an old MacBook and 10.7 is the max) therefore I can’t install the latest Python, Druid etc.

NB: I can install DFU utils on RPI but I don’t know how and if I can run Druid on RPI in order to put Crow in Bootloader mode. Do you know if it’s possible ?

1 Like

Did you get an error running pip3 install monome-druid and then druid? I would expect this to work, if the Linux update instructions fail on RPi specifically it would be good to know. Edit: on my RPi pip puts the binary in ~/.local/bin, which was not on my PATH by default, you may need to add this for the druid command to be found.

I would also expect this to work, homebrew might not officially support 10.7 anymore but it should be possible to get Python >= 3.5 installed.

1 Like

Thanks for your reply. No I didn’t get an error because I didn’t know it was possible to install Druid on RPi, I might have missed that in the docs, is Python pre-installed on Stretch or do I I need to install it before installing Druid ? I will try again tomorrow. And about the Mac, I’ve tried to install Homebrew on this old machine but without success, I’ll try with an older version :slight_smile:

Edit
You’re right, on Raspbian I need to run Druid with ~/.local/bin/druid

This is the install process I used, in case it’s useful for anyone:

Python 2.7 and 3.5 come both pre-installed on Raspbian Stretch, however by default it will use 2.7, so:

sudo nano ~/.bashrc and add the following line at the end of the file.

alias python='/usr/bin/python3'

save and reboot

Now python --version returns Python 3.5.3

sudo apt-get install python3-prompt-toolkit

sudo apt-get install python3-pip
pip3 install --upgrade setuptools
pip3 install monome-druid

Run Druid ~/.local/bin/druid

Aliasing one program to another is probably not the best thing to do. Any python2 specific script or application will probably fail after aliasing python to python3. Better to just leave it as is and use pip3 to invoke Python3’s pip specifically.

If you are going to run druid from you user’s local bin directory (which I don’t understand how that would work with the pip install command you posted, unless pip is somehow patched by debian to always install to your user’s home instead of systemwide) it’s easier to just use pip3 install --user monome-druid.
You’d still need pip for python3 installed of course if that’s not the case by default.
The setuptools upgrade should no longer be necessary.

1 Like

Ah ok, if it’s better I will do that, thanks.

I don’t know either but it worked… it wasn’t working with only druid so I haven’t looked any further :slight_smile:

1 Like

Kind of offtopic, but I wanted to know :stuck_out_tongue:
Debian is using a patch which makes pip default to using --user https://sources.debian.org/src/python-pip/18.1-5/debian/patches/set_user_default.patch/

P.S. If you add ~/.local/bin to PATH you can just run druid using druid instead of using the full path every time. See for some docs about this for example https://wiki.archlinux.org/index.php/Environment_variables#Per_user

1 Like

Thanks for the info :+1: I’m not really familiar with Debian so I generally copy and paste commands found here and there but I’ll use this when I do the next Crow upgrade :wink:

1 Like

Is it possible to use JF as a 6voice poly synth with crow? most examples I’ve heard are always arpeggiated.

Yes, up to 6 notes at a time.

4 Likes

This makes me think. Has anyone had the idea of building some sort of norns script that sequences chords to just friends? Could be fun.

1 Like

Could be a cool project. Thinking about it could even be a bit generalized, because with Ansible you get 4 extra cv/gate outs, and i2c support with the er301 could also mean chords there.

1 Like

Very true! Speaking of Ansible… how are people using it via i2c with crow and just friends at the same time?

1 Like

I’ve been modding a few of the norms scripts with clock out to use the ansible tr instead so I can run ornithopters/M4l stuff on crow. Also been thinking about how to set up more registers in ornithopters to address the ansible outs.

1 Like

Hi, I’m just trying out my crow for the first time and am having some problems. I patched it up as recommended for first and no output. I tried connecting it to my updated norns and no recognition. I then tried druid, which does find it. Druid says that crows is running first.lua. If i try doing u clockdiv.lua or r first.lua or anything similar I get a [string “eval”]:1: syntax error near ‘clockdiv’ (or similar). One thing I can do in druid and that works is output[1].volts = 1. I can also do print(input[1].volts) having something plugged into input one on the crow and I will get appropriate readings of the voltage. On the norns under System>Devices I see MIDI GRID ARC HID which are all empty. I have norns version 191016. Please help!

Can you run ^^v in druid to find out what firmware version crow has? Before 1.0.1 some users had problems triggering First with triggers from some modules, because the trigger threshold on crow was set to 0.5V and some modules output 0.7V or so for a “low” voltage.

This usually indicates that no clockdiv.lua or first.lua file was found in the directory you ran druid from, so druid passed your input to crow to try to run as Lua (in case you wanted to evaluate something like u = 5).

^^v indicates 1.0.0 I will try flashing the latest release on crow. Still not sure why my norns doesn’t recognize it though.

Ok, navigated to correct folder and uploaded clockdiv.lua and instead of the response that the https://monome.org/docs/crow/scripting/ page indicates I should get I get the following. It also seems not to be working, even with an LFO.

55%20PM