Cut Glove (xbox controller-based live sampling patch) beta

I does.
On loadup it checks for the original tattiebogle driver (, as well as the current driver (and wireless driver). I don’t know what it shows up in windows though, so I’d have to add that too at some point, since there’s no user access to the hi object in the patch.

By “checks for the driver” I mean, it polls the hi object for the name that the diff drivers assign to it, ie “Controller” or “Wireless Xbox Controller” etc…

I just ordered a wireless USB hub for a controller I borrowed from a friend
I imagine I’ll end up buying my own controller though
eagerly anticipating playing with this

nice, i chose a wired controller which just arrived

until now i’ve been using the midi learn to map clusters of pots on a midi controller to pos/ win/ pitch and other parameters

had a blast so far and the app already feels like home…cant wait to try the controller it was designed for!

oooh, you’ll have to let me know how it feels

i definitely will @Rodrigo

before i dive in again
i have to admit that i was quite skeptical about not needing the screen for this

but you are right…even with my crippled custom scheme the best results came on sunday when i had warmed up and knew the landscape well enough to look away/close my eyes and just LISTEN

:+1: kudos for deliberately encouraging that with this tool


is there a way to clear the karmas’ buffer?

By starting to record a new one. Just hit ‘record’ while in a stopped state, and it will automatically clear the buffer (while starting to write to it again).
There’s no ‘clear’ message or anything.

i’m on 10.6 as well
grabbed the tattiebogle dmg, installed, & rebooted

when i plug in the controller the led flashes but i’m not sure if the driver is working…

You should see the on screen controls moving too (if you press buttons on the controller, you should see the buttons light up in the mini controller display.

yeah I just got my wireless USB adapter and it doesn’t seem like any of the drivers are working on 10.6.8

Shit, not even the tattiebogle?

It doesn’t show up in the system preferences either?

the device pane shows up in my system preferences but the controller won’t connect
tattiebogle is just the driver right? I may have installed a version that doesn’t work on 10.6.8 first perhaps I need to use an uninstaller before trying the older drivers.
I’ve got to get a new computer sometime soon anyway

You can drag the xbox controller preference pane right off the system preferences window.

maybe try the 0.08 version of the driver? From snow leopard era:

ok so .8 does not work but .9 is
I used a new computer macbook still 10.6.8
both .7 and .8 did not install
I’m going to look for that uninstaller thing I saw floating around earlier and see if that will work on my main computer
I have not tried cutglove yet I will once I get my main computer figured out

these are the two threads I used to help uninstall the previous 360 preferences it ended up working because my main computer is now connecting both to the computer and to cutglove

very fun stuff I played around with it for just a moment but for now I need to get some donkey kong going :slight_smile:
I’ll do some more exploring in the morning

1 Like

Oh jeez, didn’t realize it was so tricky to uninstall. So you have the gamepad working finally?

yes the gamepad does work now

i went through and deleted all the individual bits and pieces manually it wasn’t really too bad

anytime I tried to install an older version without having erased all those bits and pieces the installer would not allow me to move forward because there was already a newer version on my system

I’m also still running max 6 and cutglove itself seems to be working fine

I am inspired by the depth of controls

What a great instrument! I got back from vacation last night, and my controller had arrived. Thanks, Rodrigo.

Glad you guys dig it!

It’s worth redownloading the latest version from the link at the top. I found a small bug the other day which I fixed.