Different MIDI in/out devices Norns

Trying to send clock from ableton to norns via midi>usb and then also send midi notes triggers etc out thru one of the other USB outs. In particular with the Awake script. When I select "clock to “external midi” the sequence just stops, and doesn’t seem like I can choose which midi device I’m getting clock from… Am I missing something? blesssssss

ps my very first question on lines after sleuthing for months :slight_smile:

1 Like

As a potential clock answer, there has been a new update to the global clock structure of norns. Many scripts, including Awake have been updated for this. The benefit of this new global clock is it works with Ableton Link! If you have Ableton, you can sync your norns to your clock with the magic of WiFi.

As for the midi notes, you have a few options;

  1. have a device that would work as a midi passthrough receiving from a host. I haven’t had much luck with these.

  2. search on this forum for a midi host to host system. There was one produced by a user of this forum, but I am unsure if he is still producing them. Another is from a Spanish company and will connect two MIDI his programs. This works well for passing notes! I have had a hit or miss time with the clock (that was before the new global clock system, so this could have been greatly improved:

  3. finally, for notes is as system I have had hit or miss experience with as well, but basically use OSC information, which is generated on the norns. You can translate the OSC to midi on some of your devices. This gets much more complicated and is a script by script thing. Not to mention, host by host thing as well.

So, if you potentially have Ableton (or bitwig or any other Link based program) as the global clock leader, the neweat update of norns as well as the newest update of Awake are you best choices. As for notes; well, you’re in a different can of worms at that point.

What you describe will work…the transport in ableton needs to be in play mode and you have to go in the ableton midi preferences to set the midi device you want to send clock as enabling sync on the out

this sounds like you might be on awake 2.3 / might not have yet updated your norns to 200424? that external: midi phrasing was removed with the new global clock :slight_smile:

1 Like

Hey, i’m struggling to find any concise info/ guides on clocking nords via midi. tempo / start / stop, basic midi sync globally. Norns would be slave.
Is it possible?
Best way to feed midi data from a midi cable into norns, ‘do i need a midi to usb’? Can one that works be recommended?
Whats the best way to set it up?
i’ll be using a cirklon sequencer to be specific which acts as my studio midi master due to its insanely good timing, but i imagine would be the same setup for any midi based sequencer

hey hey! this is a great reminder for me to update the PLAY docs. thank you!

(@Alistair, heads up, moved your question to this relevant Questions thread)

it’s definitely possible to clock norns through midi.

if you have 5-pin DIN gear, i suggest this: Norns and Roland UM-One MKII USB MIDI Interface. works a treat for me!

otherwise, there’s a friends of norns thread where you can ask specific x-gear-to-norns questions. here’s a search for the word midi inside of that thread: https://llllllll.co/search?q=midi%20topic%3A17150

generally, the new clock system makes it dead simple to pass clock from an external source to a norns script, provided the script has been updated to use the new clock system (and that your norns has been updated to 200424)

go to PARAMETERS > EDIT:
2-1589411611

down to CLOCK:
blagh

set it to MIDI:
2-1589411533

you might need to go to SYSTEM > DEVICES > MIDI to select your MIDI device:
1-1589411853

let us know how it goes!

Hey Dan,

Thanks for the info i’ll try it out, yes I saw that clock section but couldn’t find much in the docs, so didn’t want to purchasing things / plugging things in, getting that info in the docs would be really handy,

Thanks

Ok cool,i think my interface just one i had laying around unused works its one of these…

Another question is it possible to pick globally which midi channel’s the norns responds to? I noticed it didn’t work when i used the thru port on one of my synths although this could be poor midi implementation on the synth itself. Also do you know a good app / script that works, preferably one that makes sound itself?

Thanks

if you want a cheap one, this one works great. been using it since i built my fates. I have two now. works with all my gear: octatrack, digitone, launchpad pro,pedals, circuit mono station, 0-coast, iphone midi (with usb/lightning adapter). i recently got a midi solutions merger too but that’s not necessary

$13.99 and i think they are even cheaper elsewhere like ebay. amazon has a few different versions, but all the ones that look like this work the same way


https://www.amazon.com/SANOXY-Cable-Converter-Keyboard-Window/dp/B0017H4EBG

2 Likes

glad to hear you had something on hand!

midi channel is handled per script – two good places to start with this are Molly the Poly and Passersby from @markeats. they each have entries for MIDI Device (which corresponds to where your device sits in the DEVICES > MIDI list) and MIDI Channel.

1 Like

Ahhh great thanks for that… I’m noticing that when I tell the circklon to send clock it breaks/ stops the Norns from receiving notes, is this normal behaviour, not quite sure which device is doing this. Does this mean I may have to send clock on one midi cable and notes down another?
Thanks

sorry for the delay, just saw this. definitely odd, so could i snag a few repro notes?

  • which script?
  • could you supply a bit more detail about what is happening to norns?
  • any other details (what happens if you stop sending clock? can you send notes without sending clock? etc)

Hey yeah sure… app I was using was molly the polly.
Basically in the cirklon you have to tell the midi port to send clock , once I activate the clock Norns doesn’t reapind to notes sent which is odd as this does work for other devices .
If the clock is off the notes do work.
Also every time I change the clock parameter on the cirklon off/on I have to restart the Norns for the parameter update to take effect,
Hope this makes sense, just a give me a shout if not. So basically if I’m sending clock no notes are recieved but clock seems to work,