Difficulty working Monome Sum or Flin directly

Hi,
I’m running into difficulty running Flin(or any of the sum apps actually) with my new grid. I installed serialOSC on my Mac(10.10.4) as per these instructions(http://monome.org/docs/setup/) and have verified that the serialOSC daemon is running. My grid is successfully detected by both Party Van and Mark Eats but when I load up Flin either directly from the Max package or via Sums nothing happens. Flin even allows me to select my grid, but nothing lights up.

Edit: I am running Max 7.

The only warningI am seeing is “js: too many lines (more than 10000) were posted to the Max window at once”.

Unfortunately, i’m not sure how to view the contents of the Max console in a project instead of a normal patch. :confused:

push apple-M to open the max window-- what does it say? something is busted.

hey tehn,
Thanks for responding. hitting apple-M doesn’t seem to open up the Max console in sums -i assume because it’s not a regular patch-, so I quickly throw one up. I’m seeing js print out a lot of ‘1’ and i’m seeing the grid send an absolute shitton of OSC commands. The text in the screenshot is essentially repeated over and over again until Max eventually becomes unresponsive.

Yeah, sorry, I figured out how to get the max console in flin. I had to select ‘max menus’ first. Anyway, i was able to verified that we see ‘js: 1’ over and over and over again.

well, i’ve never seen that before.

are you using the newest max 7?

download this: https://github.com/monome/serialosc.maxpat

and put the files inside your Max 7 app:

/Max.app/Contents/Resources/C74/packages/BEAP/patchers/

then restart

Yep, I’m using Max 7.3.1. I think I upgraded a couple of days ago actually.

So, i I replaced the serialosc files embedded within the Max.app with the HEAD of the git repo you pointed to and witnessed the same behaviour.

> diff /Applications/Max.app/Contents/Resources/C74/packages/BEAP/patchers/serialosc.js patchers/serialosc.js 
37c37
< 		
---
> 	
90d89
< 		rescan();

``
I briefly scanned the flin.js code and so no post statements, so I assume the offending code must be inside of sum itself?  Does anything here look suspicious ?

https://github.com/monome/monome_sum/search?utf8=%E2%9C%93&q=post&type=Code



Maybe this?

  function varib(x){
 	vb=x; // grab variable brightness state
	post(vb);
	post();
}

at this point i cannot explain what’s going on.

we had a lot of trouble with OS 10.10.4, also. strange business with having to install different versions of the FTDI drivers. is there a reason you’re not upgrading? 10.12 is working these days.

Upgrading to 10.12 would necessitate that I upgrade to Cubase 9 which is $200 expense. Technically, I only need to upgrade to Cubase 8.5 for sierra compatibility but, of course, it is no longer available for sale.

It’s something I’ll have to do eventually but I was hoping to postpone it. If I was sure this would fix the problem, I might consider it but given that every other app I have tried works correctly, I’m not sure it is reasonable to suspect the FTDI drivers.

I appreciate your help. Let me ask your one more question while I still have you on the line…When I initially open up grid studies all the OSC messages seem to go to /monome/* and everything works correctly.

When I then open up sum and select my grid, I see that sum is trying to communicate under /manager/. If I then reopen up the grid-howto patch, it no longer works. BUT if then change all mentions of '/monome/’ to ‘/manager/*’, it suddenly is able to talk to my grid again. Is this normal? Why was the root of the OSC address changed from ‘monome’ to ‘manager’ when I opened up sum?

Again thanks for your help. :slight_smile:

understood!

can you re-confirm that markeats works perfectly fine?

regarding your OSC issues-- what you’re dealing with are prefix issues. prefixes are a sort of outdated way of working with multiple patches at once.

send a message /sys/prefix /monome to set the prefix to /monome instead of /manager. sum should really just work and you shouldn’t have to do anything.

do the grid-howto patches work? when you get-info on a serialosc.maxpat the argument is the prefix. if left blank it should be /monome

I run some more experiments and report any unusual findings here. Please just let me know if I find anything worth investigating.

Grid Studies 2-
Rows and Columns in grid studies seemed to swapped. If I press all 4 corner buttons 2 of them generate ‘matrixtrl: cell coordinate out of range errors’. The offending OSC messages are: ‘/monome/grid/key 0 15 1’ and ‘/monome/grid/key 0 7 1’. The complaining matrixctl object correctly has 16 columns and 8 rows.

From the webpage(http://monome.org/docs/grid-studies/max/): “Note here that x,y position is ‘zero referenced’ so 0,0 is the upper-left key and 15,7 is the lower-right.”

0,0 is bottom left or top right depending on how i hold my grid.

Probably for another thread but I’m still having issues with 10.12.2. As its my first foray into max/monome grid I don’t have a clue what I’m doing (that’s why I have 2 ansibles, a teletype on the way) - I get the longest lag between touching the grid and any feedback on the grid or change in sound…

Ok, here’s some very interesting info.

The rotation of the grid was off. Once I sent it ‘/sys/rotation 0’, I was able to use sums with it. This is good news. The problem was compounded by the fact that sums has some kind of busy loop going on somewhere. I still see the 1’s and if attempt to run it with ‘Overdrive’ on, Max will soon become unresponsive.

If i just run flin.maxpat directly from the monome package, everything just works. No performance problems, no console logs of ‘1’ and lots of fun.

This leaves me in a pretty happy state. I’ll just avoid sums and try to find the patch originals. Thanks for your help, man. I appreciate the patience.

i’m glad you figured it out-- and i can’t figure out how a rotation message got logged. is this your first grid? did you run any other patches that might’ve done some rotation?

@dogma is your OS an upgrade or new install? did you ever install the FTDI driver? (if so it needs to be removed). and you’re not running monomeserial, right?

This my first grid and yes, I’ve been opening all kinds of apps just to play with them. To be completely honest, I purchased the grid primarily for ansible/teletype. I completely understand the burden of software maintenance especially when you do not control the entire stack.

I had been aware of monome for sometime but it was the forward thinkiness of your newer work(WW and beyond) that really caught my attention. Consequently, I would much prefer your time spent on evolving those ideas.

has this issue been fixed? i’m getting it together with the same message ‘too many lines (more than 10000) were posted to the Max Window at once; output truncated.’
when i run sum it is not responsive. i tried several times. one of these times it would respond but extremely slow, the audio is indeed truncated and so are the grid lights (they blink, but as if they were overloaded)

i didn’t really get if you got sum to work. if you did, i would really appreciate if you could help me with it. where should i try to write these codes such as

i am also getting flin to work when i run it by itself with flin.maxpat, but not the other apps. i would really like to get the whole sum to work

thanks

@ptorres, I also just sent over an email, but wanted to post here to close the loop.

Sum was built for Max 7, which can be downloaded from Cycling '74’s site directly. we are working on an update to the core Max + grid experience, but I just confirmed that Sum works great with 7.3.6 :slight_smile:

1 Like