Hey @andrew, I tested it here on both Live 9 and 10 and it seems to be working fine. Really nice effect. Reminds me of the built in Erosion (which I’m a bit fan of).

All these effects you have been posting is gold.
Thanks for sharing all your work.


loving using a max envelope follower to muck with the gravel. here, catching small jumps from 2 through 5:


ugh lovely - it’s crazy every level of gravel has it’s own character. It’s only a few lines of C making the whole effect.

for(int i = 0; i < sampleframes; i++) {
    int index = i - (i % rate);
    int phase3 = index;
    int phase2 = phase3 - (1 * rate);
    int phase1 = phase3 - (2 * rate);
    int phase0 = phase3 - (3 * rate);
    float y0 = phase0;
    float y1 = phase1;
    float y3 = phase3;
    float y2 = phase2;
    int xx = i - index;
    out[i] = hermite(xx, y0, y1, y2, y3);

the knob controls rate and it affects which samples of a 64-frame buffer go into a hermite interpolator. I don’t really know what to call what it’s doing, and I found it by accident.


had a lot of fun controlling the > button with a tempo-synced LFO while modulating gravel and asphault last night. Makes for a fun clicky percussive element.

Your devices have really fun interfaces and parameters! Is there any way to control the graph elements with control devices? Also is width of the square (which I guess is a kind of “q”) able to be changed somehow (manually or otherwise)

is your C code available anywhere? Wondering if it could be transferred to PD.

should be about as easy as softcut !

I went through some name changes so this is (most of) asphalt:

and this is gravel:

asphalt has a couple dependencies from softcut~ (it’s just the same resampling algorithm working on an itty bitty buffer), so you might want to paste into that project, but gravel / colloquial_msp i believe is just one c file. neither include the filter, which is just a bandpass from cascade~. also some ring mod noise stuff I stole from TPV going into asphault.

I don’t think I can expose that but I could always switch to knobs instead of the graph control which I wouldn’t be super opposed to. sounds like it’s more confusing than useful for most.

I think u can like drag the edges of it ? idk. confusing.

1 Like

Nice, nice. TBH I haven’t figured out the softcut port yet. The gravel/colloquial code seems simpler and may be a better thing to attempt, although I’ll have to look at if the max sdk used has anything that is max only dsp.

fair, having a bunch of files gets trickier I imagine. you can prob get away with copying and pasting these

totally up to you. I like how the graphs look, and it’s fun to click the mouse around in there and move things around (not everything needs to be modulatable imo). But I also wouldn’t be opposed to knobs I could get a “handle” on.

1 Like

somehow the colloquial and samplecut (i think) max objects don’t get recognized in this patch which i think is the trouble with no audio passing in wet position and no fx heard.

I’m at a loss for why this is happening for some people and not others, but yea that is the problem. you should be able to download both of these externals and place them in Documents/Max <verion #>/Library I think then they will show up when you open the device. or you can just edit the patch and add them in one you have them.

1 Like

i have downloaded those externals before, moved to various file destinations and tried to put them in. the objects don’t get respected within my max as objects.

maybe it’s a versioning thing? would live 9 suite and max 7 32 bit be trouble? as that is my system current.

I’m betting it’s that “32 bit” hint that is at issue…

1 Like

probably. but would 32 bit preclude the two max objects from even populating in a file destination/recognition sense? my setup acts as if the 2 objects in question are just invalid (oranged out).

yea I believe it would, I didn’t build these 32 bit ready - are you on a 64 bit machine ? maybe you need to do this switch

Go to the Max 7 application icon, right-click on it and choose “Get Info” (or select the icon and hit command+I). Uncheck the “Open in 32-bit mode” option.
This is how Mac apps with both 32 and 64-bit options work.

1 Like

i’ll look into it. seems odd i can get colloquial up in the prior single iteration immediately/without issue.

i’ve avoided moving up to 64 bit ableton hopefully i can get happy results with click of single button. that would cause laughter.

the colloquial device doesn’t have any externals - colloqial_msp is unrelated and named when this was gonna be an iteration on that but then I decided they were separate things and I’m lazy at re-naming stuff

1 Like

i opened in 64 bit version of ableton. i usually only use for video as i don’t use the old plugs for that. worked like a charm! u 2 r wizards! i wonder what other problems i am having based on this issue. will explore.

@andrew it sounds fantastic tyvm

and thank you for patience with getting to the bottom of my issues. i hope to keep digging in to get all these working as intended!

1 Like

! ! nooo problemo ! !

1 Like