Distorted TR output on Teletype?


#1

I’m not sure if I’m seeing a problem with my Teletype or if it is just something I’ve inadvertently misconfigured, but it seems like the output of TR 3 in my Teletype is somehow distorted. The teletype is from the new batch with support for direct powering of a grid, and is running Teletype 3.0 firmware.

I first noticed an issue when I plugged in my grid to the teletype, and TR 3 would seem to trigger the connected module (Peaks) more frequently than it was programmed to do so. Disconnecting the grid would return to normal.

I couldn’t see any difference between the scripts triggering other outputs, but thought it might be a noise issue related to using the grid. I tried a y-cable to power the grid from a separate source, but this didn’t fix the issue with TR 3.

To investigate further, I tried connecting TR 3 to different sound modules. TR 1 going into the trigger input of a B.I.A. drum module gave a fairly normal kick sound, whereas TR 3 gave a much more distorted sound (without changing any other settings on the module).


TR 1 triggering B.I.A.


TR 3 triggering B.I.A.

B.I.A. is a weird module, but I figure it should sound the same for two different trigger sources, so long as they are both the same themselves.

So I figured the trigger source itself must be different on TR 3. To investigate further, I sent TR 1 and TR 3 directly into my MOTU Ultralite and grabbed some comparison shots of TR 1 and TR 3 with a software oscilloscope. TR 1 is on the top, TR 3 is on the bottom - looks like there is some kind of problem with TR 3, but I’ve no idea what it is, or if it’s something I can tune.

For the purpose of the shot, the TR.TIME for both TR 1 and TR 3 is set to 10ms. I also tried with longer settings (100ms) and there is a similar looking pattern (hard to get it all on the screen tho).

So this kind of makes sense as to why the Peaks drum voice I was triggering was generating extra hits, although why this only was occurring when the grid was plugged in I’m not sure. Looking at the oscilloscope with and without the grid I couldn’t really see much difference.

As far as I can tell, all the settings for all the triggers are the same - same polarity, and (when not testing) same time. I tested the other triggers, they gave the same output at TR 1. I also swapped input channels into the MOTU, just to check that it wasn’t an issue with the MOTU, but saw the same distorted pattern for TR 3 on the other input channel.

Has anyone else experienced something this? I’m happy to investigate further or try different settings or eliminate potential contributing factors. I’m super happy with Teletype and figure this is just some kind of minor glitch (and hopefully not something that I’ve done badly wrong during installing it!)

The teletype is installed in a 84 HP skiff with an Ansible and a Just Friends attached via I2C. The other modules in the skiff are a Pam’s New Work Out and a v1 Rene. Power is from a 4MS Row Power 40.


#2

investigating TR 3 now on the new rev


#3

indeed, i just spotted a production error (component swap). waiting for confirmation and will update everyone with a fix/replacement method. i’m very sorry for the trouble.


#4

thanks for the update @tehn -

on the one hand I’m relieved to know it’s not something I’ve messed up, but I definitely appreciate the hassle for you if there’s something systemic.

and let me say how much I appreciate the quick response - I’ve only had time to explore TT and inadvertently discover the issue because I’m on holidays - so I’m sorry if this is disrupting your time off!

happy to be patient with whatever the resolution is - for now I’m using one of the CV outs as a trigger instead, and that’s keeping me moving forward.


#5

Are all the TT from the latest batch affected?


#6

I also noticed something similar last night when working on the first Teletype Study, I was using TR 3 for the strum on my rings and was getting distortion as well


#7

can you guys give me the script so i can test it out too? I have the latest TeleType batch too.


#8

confirmed from boardhouse, all shipped new batch (black pcb) tt’s are affected. easy fix/replace— i’ll take care of everyone. basically TR3 oscillates when it should just be steady, but otherwise these units are perfect.

details for how i’ll work this all out by the end of the week! thanks for your patience.


> teletype: grid # code exchange
#9

all I did was set up a simple Metro script something like

M 500
TR.P 1
TR.P 2
TR.P 3
TR.P 4

I guess you could set up an Init script to ensure all the trigger parameters were the same (duration, polarity).

You could also just do this manually - having the metro script running just meant all triggers were firing at the same rate and I could test the behaviour of different modules by plugging in each respective TR in turn. What you notice will probably depend on what modules you plug it into.

However, from what tehn has just said, all the new batch will have the issue on TR 3, but the fix will be easy, so no need to be too concerned.

In the meantime, I started using CV 3 as a substitute trigger with CV 3 V 2; DEL 10: CV 3 V 0 (I’m not sure if you can put the DEL on the same line - not in front of my TT right now).


#10

Ok I didn’t notice this for weeks as I have been only triggering envelopes from TT and didn’t have the issue with TR3, but today I tried it with Rings trig in and sure enough it isn’t quite right…


#11

#12

Hi Brian, thanks for looking into this and figuring out the fix.

For EU-based folks, I feel it might be too time and cost consuming to send it back to the US for what seems to be a small fix. Would it be possible to have an EU person available to sort out EU-based issues with this? This would definitely help with the costs of shipping and downtime.


#13

Thanks @tehn. really appreciate the quick resolution and the options for both DIY fix and sending it in. I’ve done a little SMD work, but only 0805, so I’ll have a look at the DIY option and get in touch if it seems beyond what I’m set up for.


#14

Wanted to send out some thanks and appreciation here to Pete Crenshaw at TAKAAB here in Thailand for getting one of his engineers to help me sort out the TR3 output issue. Thank goodness its fixed and no shipping needed!!!

In case any other black pcb TTs were sent to Thailand, he could be a possible repair option.


#15

Are the units currently on offer via monome.org fixed?


#16

yes absolutely certainly.