DIY monome compatible grid w/ Adafruit NeoTrellis

Thank you so much for the help. Grid is up and running!

1 Like

Dammit I broke something. The grid doesn’t light up anymore, and I don’t know what happened. Anyway, back to debugging.

The neotrellis boards don’t light up anymore, but the teensy is still recognized by both Norns shield and computer.

I’m a little afraid the neotrellis boards died, they are totally unresponsive. Hopefully I just mucked up the teensy.

I’d check the power to the neotrellis boards and then the i2c connection.

Built this beautiful beast recently (neotrellis_monome_teensy):


It easily looks & feels like the best of all my DIY stuff - awesome. It was a very well documented build, and the addition of the Ponoko enclosure templates was a huge help.

The only change is that I used a mini-USB breakout instead of the micro breakout. Flashing went fine, multitrellis-test runs fine - yay, seems I got the hardware working.

My last monome grid-type thing were dual 40h (using monomeserial, so everything was configured manually), so I feel quite stupid for asking this. But I can’t for the life of me get it to show up in any Max patches, e.g. Monome Home (Max 8, Windows 10 64bit, if that makes a difference).

I found quite old comments that seemed to describe a similar issue, but they seemed to refer to an out-of-date version of serialosc? Using the most recent serialosc-1.4.1a on a rather fresh install.

Any pointers would be very much appreciated!


Hmmmm… I don’t have any experience with serialosc on Windows and not sure what to suggest. It works as expected on MacOS with some occasional prodding (there’s a launchctl unload /Library/LaunchAgents/org.monome.serialosc.plist that is needed to block/un-block or load/unload the serial port. Not sure if there’s some similar kung-fu needed on windows)

Did the mini jack work OK with the cutouts (since it’s a touch larger)? I thought I left enough room there and have a jack, but never actually tested it in place :stuck_out_tongue:

Did you see this post above?

Specifically Trouble Setting up Monome (although its a few years old?)

@ground_state did you go through all that in your testing?

This seems old. I thought it was 1.4.2 everywhere now? Lemme search for the win version - see Arc2 and 128 Connectivity Issues on Windows ??

I tried all the things. The only way I get any joy under Windows is using the Node serialosc thingy, which works flawlessly.

1 Like

Any chance you sldprt files for these? I printed out the stl’s but would like to modify it a bit. I can import the stl but figured I’d ask if you had any other files for it. Also I am all for collaboration to get it to a good state. Solidworks is a large part of my day job and have access to a 3D printer with a large enough bed to print in one piece.

Overall the button spacing seemed good. I think the material inbetween the buttons to prevent bleeding is the right way to go. I was going to look into mounting the pcb’s to the base as I think it would make for a more stable user experience as opposed to the top.

So i guess the big question is “what’s different about the node setup that’s not working normally”?

Sure, I’ll upload to git today. (Don’t know if Fusion can do sldprt).

The PCBs are already screwed to the bottom part though. They’re the two rows of stands in the bottom part (8 screws total). The holes in the top are meant for connecting the two parts together.

1 Like

Yes, worked like a charm! It is protruding sidewise maybe 0,5mm, but that’s not really an issue. I guess it’s the same for the micro?

Thanks for your pointers!

Yes I saw that. That registry key does not exist (cleaned everything up when I set up my machine), so nothing to remove there. Starting serialoscd as a non-service also does not really do anything, but I’m not sure what the expected console output for a connected device should be (if any).

Hmm. I got this from the official pages and the github repo

Tried the version you linked (1.4.2-pre), but it gives the same result (it just installs into the 64bit app folder “Program Files” instead of the x86 folder), and when running serialoscd -v it still gives the 1.4.1a output. But still, I’ll run with this one now in my quest for detecting the neo-monome.

Just to make sure: When I connect the device to USB, one corner briefly blinks. Is that the expected behaviour?

Ah man, this is driving me crazy, having this beautiful thing sit on my desk uselessly…:confused:

Boards are getting 5V. How do I check the i2c connection?

You could start by using a multimeter to check for continuity between the I2c pins of the teensy and the I2c pins of each Neotrellis board. If you have a logic analyzer you could also check the signal on that bus…

1 Like

Continuity is fine. I have a Rigol scope, but not sure if that has a logic analyzer.

IIRC, one of the 4 channel rigol scopes has/can be hacked as a logic analyzer. If power is good, and the connections are good, it sounds like there may be a communication problem. A logic analyzer could help with that. Maybe your I2c addresses are wrong in the firmware. I’d double check that – although if it was working and then suddenly stopped working, that would point to something else being the problem.

Yeah no, it’s the older 2 channel so no luck there. Yeah it worked fine, now no longer. I’ll order another teensy to see if I can get it to work again.

I have this super cheap logic analyzer, which I believe I bought off amazon (it was quite a few years ago). Anyway, it works fine, and has come to the rescue on rare occasions…


Alright so then I hook that up to the i2c connectors to see if messages are being sent out and received? This is slightly beyond my knowledge, see I’m an analog boy, this digital stuff is over my head.

Yes, you can capture a snapshot of the communication (or lack thereof), and display it on your computer screen. The software can do smart stuff to help you interpret the communication (e.g. it can recognize certain sequences of pulses as start/read/write/address, and so on). You can see if the teensy is talking and the Neotrellis is responding/or not…

1 Like

How are you testing?

Have you tried going back to the multitrellis test sketch/hex?