DIY monome compatible grid w/ Adafruit NeoTrellis

No problem! If you’re interested in 3d modeling it’s a good exercise to make your own design. I figured after giving away the fates case for free I might try and make some money on this one, although I don’t expect it’ll be very much.


Github here:

Untested, but free to use. There’s standoffs, and construction details inside. Even a cradle for the Teensy, but again I don’t really know if it will work. Once I get a 3d printer will test everything (soon… very sooon). This should be juuust printable on a Prusa, but not both sides at once.

Obviously open to constructive criticism as this is only my second Fusion 360 design (also have a Norns Shield case).


So I got my Mouser shipment today and have been tinkering to get this working. First of all thank you for the wonderful work on this project!

I was wondering whether or not I should wire up the USB breakout for the Teensy 3.2? The pictures for the case file in the Git repo do not show the breakout installed, which got me wondering. Is there a place for the breakout in the latest case revision?

I need to update the photos on github - they’re out of date for
using the breakout. Will need to check case designs that are up there as well.

DM me if you have questions.

PSA: I foolishly ordered after the cutoff date, and even though my order was not part of the essential orders I just received a shipping confirmation from Adafruit.

What’s the latest on the power wiring? I saw some discussion up topic about directly powering the grid from the micro usb to reduce the risk of brown-out, but I can’t find the current best practice in github…

Also, as a doublecheck, there don’t seem to be holes on top for the d+ and d- connections right? Just the pads on the bottom?

Yeah this is out of date on GitHub. I’ll try to do some updates tonight

That is correct - for teensy 3.2. Also the Teensy 4 won’t work because it’s D+- pads are for host mode only.

1 Like

However, in the Teensy 3.6 and Teensy 4 the current limiting fuse was moved after the VUSB pin. So you should be able to power the Trellis directly from the VUSB on the Teensy 4 without brownout issues (if you use a suitable power source). This is what I do with the Teensy 3.6 and I haven’t had any problems with brownout.

@jorgen83 I’ve updated github with more recent enclosure information.

Need to add another picture or two, but it’s more up to date


Well that worked.


New problem. When connecting to Windows, I get the monome in my device manager under USB devices, but it doesn’t get recognised by serialosc. Max patches don’t work as a result.

Hopefully the Norns shield will work (when I finally get the missing screen header).

I don’t have a windows box so can’t troubleshoot

Maybe @Gerald_Stevens could offer suggestions/tips?

Wish I could help. I fought for a day to get the grid to work with Max 4 live. Failed, and gave up.

1 Like

Ahaaa, this is what’s giving me issues. Without it it works (but no Neotrellis grid recognition), but with it apps don’t load.

Is there anything i can do to make the fates recognize the grid more reliable ? Sometimes i have to reconnect it 5 to 10 times to get it working.


Try another USB cable?

1 Like

Figures. I used to have the original 40h, before the eurorack modules existed and norns, and I hated the setup with windows and sold it. When it worked it was so much fun though, so hopefully I can get a more stable and userfriendly experience with the norns shield.

Check this thread and read from there to the bottom and there’s some various things to try SerialOSC installation Windows 10 64bit

And Trouble Setting up Monome

1 Like

node-serialoscd (link posted by me above on 2020-01-29 LOL) works beautifully here with Win 10.

I’ve had no success with any “real” serialosc - no amount of hacking around in the grid’s firmware (e.g. to present serialosc with the strings it expects to see) has made any difference - serialosc doesn’t fail, or offer any output, it simply doesn’t do anything.

[1] Argh searching frantically but can’t find a link. I’ll update once I do.

1 Like

i tried three different cables… same problem. I will open up the case and check if there are any bad solderjoints or if the usb breakout is somehow broken