DIY monome compatible grid w/ Adafruit NeoTrellis

OK weird. But what version norns is showing on your display?

Still the same problem.
I’m on 191201 shall i update tomorow and check again?

yeah - prob best to run the updater to start clean and get your version file updated.

do update via these instructions

After that re-run the device_fix and hopefully you’ll be good

Video of neotrellis board joining with pin headers

And then free wiring the teensy/breakout for my new case layout.
image image image


After updating and reruning the fix script again it worked. Thx for your help:)
One last small question is there a way to flip the grid so that the usb is on the other side?

One way – maybe not the most practical or efficient – would be to modify the code you flashed to your teensy to put 7-row and 15-col wherever the grid row and col are referenced in the code.

Thanks for all the work and effort, @okyeron! Looking forward to giving this project a go soon. First time to come up with some fun enclosure designs.

The code supports the rotation command. If you’re norns-ing, global rotation is supposed to be coming to a menu preference soon.

Or just build it with the jack on the other side? :laughing:

(Teensy doesn’t fit as tidy on the opposite side tho)

My grid stopped showing up in the fates menu, I’ve tried the fix, but still doesn’t work(boot light works when plugging in). Will try to git pull from norns dir and fix again. But I could have sworn it worked after the last update.

I had the same problem yesterday after disconnecting and reconnecting the NeoGrid. Looking at the dmesg output in a console window I saw USB error messages when the NeoGrid was plugged in: “Device not responding to setup address”. I found that if I unplugged my FastLane-USB Midi interface and then plugged the NeoGrid in it was recognized and reappeared in the device menu. I could then plug the Midi interface back in and have it recognized as well. Tested it a few times and it fails every time if the Midi interface is already plugged in, but works every time if the NeoGrid is the first device plugged into the Fates. I think it may have something to do with the power draw on the USB ports?

1 Like

Looking at the Maiden REPL when you plug/unplug can be helpful.

the error: libmonome: error in write: Resource temporarily unavailable is pretty normal and might show up 10-20 times in quick succession.

Just now I tried with mine and got that plus

error: couldn't open monome device at /dev/ttyACM0
dev_list_add: error allocating device data

unplugging/plug-in again and it registered.

libmonome: error in write: Resource temporarily unavailable
grid added:	2	neo-monome m4676055	m4676055

unplugging/plug-in again and it would not register (multiple times) :thinking:

Last thing - which seems like a fix for now - is do ;restart from maiden while the neo-grid is plugged in and it should get recognized on startup and then be available in the GRID menu.

1 Like

@okyeron; So, I’ve soldered up the USB passthrough thingy. The Teensy still works (thankfully), and the so-far 4x4 grid I’ve already soldered up works nicely with the multitrellis “basic” sketch - but only with the USB connected to my lappy via the Teensy connector.

Continuity is good, I’m metering 5v/3v where appropriate, and I don’t seem to have any crossed connections (though I did have a GND-5v bridge - classic rookie error LOL); I even get the red power light… but the lappy doesn’t see the Teensy.

Image follows:

Any thoughts? Any obvious troubleshooting I’m missing? Any non-obvious troubleshooting I could try?

TIA, and thanks as well for all of the amazing work you do!

really weird, but as soon as I came back home, and monitored through Maiden, it worked. so yay!

Well shit. Teensy 4 may not work with the breakout. The D+, D- on the back are usb HOST not the usb in.

Gonna poke around the schematics/Pin assignment guides later but at first glance, the T4 may not need the breakout (the fuse which limits current is in a diff place on 4)

1 Like

LOL! I just noticed that on the screenprint (cue sample of an English mad scientist from the 40s saying “What the devil?!”).

Regardless, it works beautifully with norns, even plugged in directly. Now I need a case, and a clue on how to make it do with Windows :slight_smile:

P.S. What kind of test(s) would I do to determine whether or not the breakout is necessary?

Turn all the leds on full brightness and see if they brown-out/glitch. I have been testing that from the test-grid maxpat

Probably installing serialosc

Sorry, should’ve been less flippant/more informative. I have the latest serialosc installed (never had one installed before); I have Bonjour installed (for other reasons), but I understand it’s not required any more? Regardless, I get absolutely not a peep from any Max patch, in Max or in Live. Running the serialosc-* manually from a terminal gets me nothing… There’s no lsusb or what have you on Windows, so I’m kind of lost as to how to proceed.

1 Like

I have spent hours trying to get it working on windows 10. Serialosc hasn’t been updated in a while, maybe it isn’t working with the latest win10. My grid shows up as serial COM3, not as a USB device with a name.

Mine as well, when running the arduino IDE thingy, but it shows up as COM4 when seriaosc is running.

This persists after a reboot, without the arduino IDE running, and oddly, Windows Device Manager shows no COM3, but if I try to customize the Teensy port, Windows shows that COM3 is in use.

Either way, I’m pretty sure that it’s not going to show up as a USB device - that’s what serialoscd is for.

This help?