DIY : tsnm (Touch Sensing Note Memory) by Doboz


#142

Do everything how the build guide suggests.

I had that problem too. I snipped it one off. You need to cut one off and put it on the end as you suggested - be careful cutting them, you can damage one side pretty easily; that plastic isn’t very durable. Then use a spare female socket to hold them in place. I’d recommend super-glueing it for security. Solder will do most of the work, but better to be more secure. Removing the faceplate does put a goodly bit of force on those pins.


#143

I got everything soldered up. I need to load the app on to my teensy. I got the PJRC for the Mac. It launches, I see the LED flashing on the Teensy, I press the button and it stops flashing, I can choos the tsnm hex file, PJRC shows 74%, but the load button is enabled. So I can’t load the file on to the Teensy. I’m not sure what’s going on. I’m wondering if the USB port is being recognized or not?


#144

The app is called Teensy, right? And looks thusly:


#145

Yep that’s it. The program button is disabled.


#146

I’m combing the Teensy forum. Seems like I need to install Teensy Arduino first and run it once.

I downloaded this and ran it, it asks for the location of the Arduino folder but doesn’t accept it when choose the folder. There is next button that is disabled even when I choose what I think is the correct folder.


#147

When you:

  1. Open Firmware
  2. Plug in Teensy, see the flashing light
  3. Press the button, and then the app should respond by clearing the button press image above.

Does that happen?

Also, did you cut the power trace? Are you, for sure, only prividing one source of power? (Just trying to think of places for potential weirdness.)


#148

Hey! for the J3 sockets, what exactly goes there? I’m confused on how I use the headers exactly. I can’t find any help online anywhere, so I’d really appreciate some haha


#149

am I missing a part? I bought the full kit from the modular addicts website and it seems like I have all the other components


#150

The squarish taller sockets go on the back of the PCB. The shorter roundish socket goes on the face of the PCB.

The male header soldered to the Teensy and MPR121 board, cut 3 pins and solder that to j3.


#151

Here is a better photo of J3. I guess this is for some sort of jumper.


#152

thanks a-lot! I just spent all day soldering this (as I was excited for my first SMD project) and I thought I lost a part ;-; thanks for your help haha


#153

I finally got Teensyduino installed. I had update Arduino to a compatible version.

Now I’ve got Teensy loader 1.44, Arduino 1.8.7. I’m using a Teensy 3.2 board. If I verify a Teensy Sketch in Arduino it launches Teensy Loader 1.44. If I try and upload the sketch I get:

No Teensy boards were found on any USB ports of your computer.
Please press the PROGRAM MODE BUTTON on your Teensy to upload your sketch.
An error occurred while uploading the sketch

The LED flashes when powering up the Teensy. Pressing the button stops the LED. The sketch will still not load.

If I load the hex file into loader, the program button is still disabled.

The docs seem to suggest that if the LED flashes, and stops when you press the button the USB cable is at fault. I tried two cables. I might have another to test with.


#154

You shouldn’t need Teensy Arduino. You just need the hex file and the Teensy loader. You’ve gone down a misleading rabbithole. See my previous questions.


#155

I have exactly this app, it looks just like the picture you posted. I have cut the the trace. The image on the Teensy app doesn’t change after I press the button, the LED does stop blinking.

I’m powering the module from my modular. I think it would have been easier to program before cutting the trace. I could have programmed the Teensy outside the module powered via usb. Then cut the trace before stalling it.

I saw an error in Arduinio saying Teensy 1.42 or greater was needed for Teensy 3.2. I installed this now it runs when I verify from Arduino.


#156

I got it load. I needed another USB cable. I had been using some random USB cables that were lying around. I dug up one I specifically for Arduino an it worked right off.


#157

Congrats! Welcome to you TSNM! :vulcan_salute:


#158

how do you calibrate this? I have mine running, but the display is only showing a red line on the left side and the V/oct isnt changing tones atall


#159

That sounds more serious than calibration? You might want to check all your solder joints. The calibration proceedure is outlined in the manual, but if the “display” isn’t working, you won’t get that far.


#160

how do I check if my teensy is working properly? all of the parts are soldered correctly, but the LEDs aren’t functioning. its stuck on the highest frequency and I can only get one row to work


#161