Druid -- dfu-util "no similarly named formulae found" [SOLVED]

Tried splitting my I2C bus into two smaller busses (breaking Crow and JF off from Ansible x2, TxB, TT). Upon screwing JF + Crow back in, the init coming off Crow was no longer swapping JF’s mode (confirmed in Sound / Cycle mode, watching the function of the Intone knob). Confused, I tried plugging Crow into my computer. Not recognized. NBD, just gotta start up in bootloader mode and run the erase found over here.

Except new computer, switched from PC to Mac, etc… ok set up homebrew, get DFU-UTIL, then run the erase, load Boids or something similarly innocuous onto Crow, reseat in case with I2C cable attached, u scriptiactuallywant.lua and bam, we’re in business. Except get DFU-UTIL didn’t work out. Here’s the bit from terminal:


william@Williams-MBP ~ % brew install dfu-util
==> Searching for similarly named formulae...
Error: No similarly named formulae found.
Error: No available formula or cask with the name "dfu-util".
==> Searching for a previously deleted formula (in the last month)...
Error: No previously deleted formula found.
==> Searching taps on GitHub...
Error: No formulae found in taps.

Where go wrong, what do now?

sorry if a bit scattered – been awake a lil long.

very odd, as dfu-util is definitely the formulae.

maybe run a brew update before trying to install?

william@Williams-MBP ~ % brew update

error: Not a valid ref: refs/remotes/origin/master

fatal: ambiguous argument 'refs/remotes/origin/master': unknown revision or path not in the working tree.

Quite sure I’m missing something very fundamental.

1 Like

do you have the command line tools for Xcode installed?

Homebrew macOS Requirements

  • A 64-bit Intel CPU or Apple Silicon CPU 1
  • macOS Mojave (10.14) (or higher) 2
  • Command Line Tools (CLT) for Xcode: xcode-select --install, developer.apple.com/downloads or Xcode 3
  • A Bourne-compatible shell for installation (e.g. bash or zsh) 4

eidt: searching for the error led me to this github comment from yesterday

it suggests running these commands for a fix

rm -fr $(brew --repo homebrew/core)
brew tap homebrew/core

[…2 hrs later]

all systems operational, captain! thank you thank you! The last bit (your edit!) was the key!

Concerned it may have been something inside my script that caused the crash to begin with. anything here look… crash-causing? I’d thought of this as a pretty simple / straightforward thing to do that would be easy enough to expand on later…

--- JF Control
-- in1: trigger
-- in2: pitch
-- JF notes

function init()
 input[1].mode('change', 1.0, 0.1, 'rising')
 ii.jf.mode(1)
end
input[1].change = function(state)
  ii.jf.play_note(input[2].volts, 4 * math.random())
  ii.jf.transpose(-2.018)
end
1 Like

glad you got it sorted! your code looks fine to me, don’t see anything that would cause problems :smiley:

1 Like

u a g don’t ever change :green_heart::green_heart::green_heart::green_heart:

1 Like