Earthsea CV Calibration?

Hello all,

This is my first post here, but I know a few of you from twitter/disquiet junto. :grinning:

I’ve been troubleshooting something and I’m out of ideas… recently got an Earthsea from Control Voltage and getting strange behavior with the POS (pitch) CV out. I measured the voltage with a multimeter and it reads 0.09 for the lowest note, 1.10 for 1 octave, and 2.10 for the second octave, etc. The volts are all off by .10

The case I’m using is a Synthrotek skiff and the power supply should be fine: +12V @ 2A; -12V @ 500mA; +5V @ 1.5A

I’ve tried:

  • Disconnecting other modules
  • Trying a different power cable
  • Updating the firmware
  • Made sure that slew/etc were not activated
  • Checked and compared Ansible with my grid and digital multimeter and it reads correctly at 0v, 1v, 2v, etc.

I didn’t see any trimmers on the module or anything on this forum/the web, so I’m not sure what to do. Any ideas? The other weird thing is that when I plug in my Alesis Q25, it doesn’t work properly as a MIDI controller - the LEDs stay lit…this same controller works just fine with my Ansible module.

1 Like

wish I could help but this is out of my wheelhouse

hope somebody chimes in soon
just want to say welcome!

Regarding the Alesia Q25 - after looking at the specs I would it expect it to work. Do you know if the module is running the latest firmware?

I would recommend flashing it with the latest since the MIDI functionality was added well after the initial release so it could just be older firmware…

Much of the MIDI code is common between earthsea and ansible so if it works with ansible then it should work with earthsea as well.


Regarding the voltage values… I don’t know enough about the hardware to say whether that is within the expected error range or not. Based on your comment it sounds like at least the .10V offset is consistent per octave so at least a VCO will track once tuned.

@ngwese - yes, I downloaded the latest firmware and run the update script successfully - I had done the same thing for Ansible.

The strange part about the MIDI keyboard plugged into the Earthsea module is that the edge output led stays lit, as does pos and output 3. I’ve measured strange voltages from there - once it read 9.42v and then it read 5v.

I noticed in the pictures that the Q25 can be powered with a wall wart (instead of via USB). If you had a power adaptor handy I’d be curious if the behavior changes when the controller is externally powered.

Is the module new or second hand?

The behavior you are describing could possibly be power related - not your skiff power supply but the ability for the module to deliver the enough current when the controller is initially connected. The earthsea and ansible modules differ in how they supply 5V for USB devices.

How close are you to the limits of your Synthrotek supply?

I have power supply for the keyboard, so I tried it and the behavior was the same.

Also, I unplugged a bunch of modules to test with lower power draw and that didn’t change anything either. With modules plugged in, I am usually around 800-900 mA 12v and 280-300 mA -12, and only the Earthsea pulling from the 5v.

Well that is frustrating.

Outside of spending time staring at the code I’m not sure what to suggest. There have been various tweaks and improvements to the MIDI code as part of ansible development so it’s possible that the latest earthsea firmware (available for download) does not incorporate some fix that went in later…

@ngwese sent me a build of Earthsea firmware built against the latest version of some of the MIDI related code common to Earthsea/Ansible and my MIDI keyboard works now! The CV tracking is accurate too and reads within .01 volts. Sadly however, the CV tracking when using the grid is still off by .10 volts. Very strange, but perhaps it will lead to a solution?

1 Like

bottom note may be off by one semitone. quite likely a firmware bug if the midi mode corrected the issue.

i’ll check it out.

IIRC the Earthsea firmware calculates 0V to be in the bottom left corner, even though that column is used for settings and functions.

Thanks for checking into it.

Maybe this will also assist troubleshooting: this morning, I set up the development toolchain, then did a clone and build from the latest code. That also fixed the MIDI issue (not sure if this is the same as what @ngwese gave me) . The latest release from March is what I was using before, with MIDI not working. For me, the all pitches seem to off by about 27 cents, based on a Mutable Instruments module that I calibrated using 1v and 3v, following the directions provided on the Mutable site.

Just to follow up. The firmware I sent @Jonny was simply the earthsea code base compiled against the latest version of libavr32. My running theory at this point is that the Q25 is triggering overcurrent conditions when it initially connects. I believe VBUS max is set to 300 mA in the currently released earthsea firmware while the latest ansible firmware has VBUS max set to 500ma.

1 Like

That doesn’t seem right. The first column is reserved for the special function keys.

So, I’ve tried some old firmwares I could find (1.4), thinking that maybe something happened along the way during development – still seeing the same results. Perplexed why the current build with the newest MIDI code is working and producing correct pitches on my unit with my MIDI controller but not with my grid… It doesn’t seem to be that the grid is drawing too much power because I tried unplugging it after recording a pattern, measured again and got the same results. I’m wondering what is different in the MIDI code vs the grid code for cv pitch.

Can anybody else measure the voltage coming out of their Earthsea?

@sam is correct. A fix is forthcoming.

Awesome - great to hear. @sam - My apologies – what you said would explain the some of the strange cv behavior if 0 is supposed to be the very bottom left corner.

2 Likes

Hi Brian - I tested my Earthsea and it’s fixed. Thank you so much for taking a look and turning it around so quickly!

1 Like