Earthsea freezing frequently

lastest release 1.9.0

sometimes ES just goes unresponsive. lately it happens when i hit the preset save/load button.

other times i’ll boot the whole system and ES will be off. no lights on grid. if i disconnect usb and cv/gate from the module it will usually boot up. not sure if this is actually doing anything or if it’s just coincidence.

but then other times ES runs fine for hours on end??

upside is i haven’t experienced the slow downs!

I have similar moments sometimes, where with ES the grid wouldn’t light up. reattaching usb does the trick for me. didn’t update the firmware in many months. it run for a long time in the same case without issues.

haven’t tested it in isolation, but I’m pretty sure these are power related issues.

hmm. i’ll try rearranging things as i’m getting close to the upper limits of my psu.



the freezing has become much more frequent. tried moving earthsea to a separate power supply and the problem persisted. i was already using switch, so i’m not sure power was an issue in the fist place.

re-flashed many times and the problem always came back. i rolled back to version 1.8 and so far (knock on wood) the freezing issue hasn’t returned. had my case on a lot this weekend. so far so good.

thanks for the report. i’ll get back into this investigation soon.

so much for 1.9 solving the problems reported in 1.8.

and again, i’m not able to reliably reproduce any issues from my end, so this has been a particularly problematic debugging.

1 Like

any point in me sending my ES module your way for testing?

i’m not sure there’s a module-to-module difference at this point. the issue surely is in the code.

Hi, I should have posted something about this a while ago, but since starting a new job I haven’t had time to really dig into it properly like I had wanted to, so some of this might be inaccurate.

I found that at some point my Earthsea would start to freeze up either on boot or later, and since I had a debug header hooked up and working for testing MIDI stuff (thanks @ngwese!) I was able to do some debugging. It seems like interrupt B08 will sometimes start firing rapidly for no reason. I could be wrong, but it appears that the corresponding pin is not actually hooked up to anything at all.

I think the reason that freezing started happening is due to this change: - The change added posting the pin’s value to the events system, and on my Earthsea this happens too fast and causes the event queue to blow up sometimes, causing freezing.

My solution was to disable hooking up interrupt B08 (and B09 since the event handler seems unused on Earthsea) in the first place. Perhaps a flag on register_interrupts() in init_trilogy.c that Earthsea’s main() can set would work here.

Now, there might also be a separate freezing issue if the problem started in 1.8 as that change came into Earthsea in the commit right after the one tagged 1.8.


i can report that after a few days of constant use (and a show) version 1.8 was waaaay more stable than 1.9…

left i2c disconnected so i can’t comment on that.

you’ve potentially discovered the breakthrough bug!

i’ll investigate.

1 Like

ok-- 1.9.1 fixes bug identified by @Ycros and i haven’t seen any freezing. no promises but please test and post back!


will test!!! 3rd time’s the charm, eh?

installed with crossed fingers.

I’ve been running this all morning, no sign of any issues.


so far so good!

much more stable than 1.9.0 :slight_smile:

haven’t tried i2c com yet

@tehn I just updated to the new firmware.

It still gives a hickup when hot plugging the grid (powered by switch) and occasionally scips remote commands from teletype. I had the first freeze when switching back and forth from ansible (MP) after about 5 trials.


…and II ES.TRANS X fries earthsea and teletype when the ES pattern exceeds the upper edge of the grid.

OK, let’s try to stay on topic with the bugs, because everything is not related to the same issues.

without hotplugging, and regardless of the known ES.TRANS bug that i’ll get fixed, do you see crashes?

Sorry for mixing things up - no crashes without hotplugging by now.

@leverkusen that’s good to hear.

now for the hotplugging. i can replicate a crash only if a pattern is running. can you confirm this as well? if it’s just sitting idle, i can’t get it to crash. just did 100 rapid toggles or so.