Error trying to load scripts though maiden repl (SOLVED)

I am trying to load color wheel script through maiden. This is the first time i have done it this way so I did a bit of searching and found these instructions:

docs

maiden

But it seems i am unable to load any scripts this way. I am getting the following error:

;install https://github.com/yams7457/colorwheel

norns.script.load("code/untitled.lua")
# script load: /home/we/dust/code/untitled.lua
# cleanup
# script clear
### SCRIPT ERROR: load fail
/home/we/dust/code/untitled.lua:1: syntax error near 'https'
stack traceback:
	/home/we/norns/lua/core/norns.lua:144: in function </home/we/norns/lua/core/norns.lua:144>
	[C]: in function 'dofile'
	/home/we/norns/lua/core/script.lua:186: in function </home/we/norns/lua/core/script.lua:186>
	[C]: in function 'xpcall'
	/home/we/norns/lua/core/norns.lua:145: in field 'try'
	/home/we/norns/lua/core/script.lua:186: in function 'core/script.load'
	(...tail calls...)
# script clear
<ok>

I dont think i am doing something really obvious wrong but i may well be! Any thoughts much appreciated.

1 Like

By looking at you maiden output I’m assuming you put the install command in a .lua file and ran it.

You should run it directly from the repl (bottom panel in maiden. where >> is). So if you paste this into the repl and press enter it shoud work:

;install https://github.com/yams7457/colorwheel

(made a screenshot but for some strange reason it won’t upload right now…)

2 Likes

haha - i thought i was probably missing something obvious!!!

All good now - thanks!!!

1 Like

Here’s a newbie question about my new Norns shield and downloading from Maiden. Some scripts, such as Loom, fail to load onto my Norns device. Other scripts, such as Acid Bass, have been downloaded flawlessly. So I’m puzzled why a number of these “holdouts” fail to properly download repeatedly and I get an error message instead. I’d love to learn any workaround for this. Thanks!

Could you provide more detail as to how the installation is being attempted and what the error message was?

Is the installation being done via the script catalog? or are you using the ;install command in maiden’s REPL area?

Is it just loom or are there other scripts which exhibit the same behavior? If so which ones?

1 Like

Thanks so much for response. I’m a relative newbie to Norns (my shield arrived last week). So I’ll do my best to answer your questions. I’ve been downloading scripts from the maiden page which displays what’s available and what’s been installed.

Other scripts, such as Showers and Fall, have loaded perfectly. But when I try to download Loom or Fibonacci or Groovecats, along with a number of others, I go through the download/restart sequence and it at first appears that Loom has been downloaded. I can select it from my list of scripts and the support instructions appear, but when I go to start it, I get a message that states the script has failed to load.

Again, it’s not with every script. I love the device. It’s amazing. I just ordered a Grid, in fact, so I can plumb the depths of what Norns is capable of. Thanks again for responding to my question. I

does maiden print any error messages when the script fails to load?

There’s no indication on my computer that it hasn’t loaded. I click on the check icon that instructs me to restart norns, which I do and from all appearances on my Mac screen it seems like it’s successfully loaded.

(Thanks, Mat for responding to my question. I love some of your scripts most all. Showers works really great with my Wingie2!).

thanks for the kind words! after you’ve installed and restarted norns, can you open maiden back up and then try to run the script? it should print out some errors at the bottom of the maiden screen. in this area of maiden:

another thing to check is that your norns is up to date with the latest firmware. press key2 on the main menu screen to check. latest should be 220321

edit: fwiw, i just installed Loom here and it runs fine :cowboy_hat_face:

3 Likes

Followed your advice and I get this error message in maiden: lua: attempt to call a string value stack traceback:

I’m sure this means more to you than it does me at this point. Thanks again.

3 Likes

sorry to hear about the continued trouble!

could we snag a litttle more info?

  • would you be able to copy and paste the entirety of what prints to maiden? you can expand the message section by dragging the horizontal line at the top of it upwards.
    • even a screenshot with more complete info might help identify the particular trouble.
  • you mentioned a few scripts, but each might fail to load because of unique circumstances – which script exactly is causing this error?
    • it might also be best to focus the error reporting to the thread of the specific script, in case the author might have a better idea as to what’s going sideways :slight_smile:
2 Likes

Thanks Dan for reaching out!

Here’s the screen shot from maiden for the loom script, which is pretty much what I already reported.

I will reach out to the authors of the script as you suggested, which is an excellent suggestion.

On another note, could this situation be due to the fact that my Norns is powered by a Raspberry Pi 4?

rad rad, thank you! i’m glad you posted a screenshot :slight_smile:

it looks like you’re only executing the URL of the script’s repository, which doesn’t invoke any special installation. if you’re attempting to download loom onto your norns for the first time, you’ll need to invoke the special ;install command, eg:

;install https://github.com/markwheeler/loom

or you can click the little books icon on the left sidebar to open the maiden project manager and download loom from there without having to execute any commands with text.

after installing, restart norns to make sure all synth engine changes register.

then, to load your installed copy, you can use the norns UI to select it – if it fails to load, it will print the reason why in the text box at the bottom of maiden.

you can also load a script by clicking the paper icon on the left sidebar to toggle the file viewer – in your screenshot, it’s toggled away, so you aren’t seeing all of your installed scripts. expand the loom folder, then click on loom.lua and you’ll see the script’s code load into the text editor section. and you can hit the play button in the right sidebar to load it.

hope this helps! please let us know if you run into startup errors with loading loom after you’ve installed. also, no worries re: Pi4 – if you’ve installed the correct base image for your hardware combination, then that won’t be causing any trouble (you technically can’t get to this point if you’ve installed the wrong base image, so no worries!)

1 Like

@dan_derks

Doh! Of course, install.

I just tried it with the install command as you suggested. On maiden it indicated it was installed, but when I tried to access on my Norns shield, I got the message error: load fail.

Any further ideas? I did update the firmware to the latest version and I did restart before I tried it, just as I did with all the scripts I successfully loaded. (I also reached out to the author of the script, as you wisely suggested)

Thanks again. I guess I’m the hank of hair that won’t stay down.

1 Like

happy to help!

this is where the information printed to maiden will be super helpful – it’ll outline the failure point :slight_smile:

Maiden indicates it’s installed (see screen shot below). Perhaps this is an engine issue? If so, how do I find out which engine I need and then, equally important, where do I find the engine? This might be the problem with the other scripts that to load. Is there a general repository of engines?

rad, so this means loom is successfully installing!

after this step:

  • on norns, navigate to SYSTEM > RESTART and press K3 twice to restart
  • once norns reboots, connect to maiden again and run loom from norns via SELECT > LOOM and K3
  • in maiden, you will see the errors populate as norns reports error: load fail on its screen, eg:
within that text, the errors will be reported (expand to see my forced errors)
# script clear
# script load: /home/we/dust/code/loom/loom.lua
### SCRIPT ERROR: load fail
/home/we/dust/code/loom/loom.lua:32: module 'molly_the_poly/lib/molly_the_poly_engine' not found:
	no field package.preload['molly_the_poly/lib/molly_the_poly_engine']
	no file '/home/we/norns/lua/molly_the_poly/lib/molly_the_poly_engine.lua'
	no file '/home/we/norns/lua/core/molly_the_poly/lib/molly_the_poly_engine.lua'
	no file '/home/we/norns/lua/engine/molly_the_poly/lib/molly_the_poly_engine.lua'
	no file '/home/we/norns/lua/core/params/molly_the_poly/lib/molly_the_poly_engine.lua'
	no file '/home/we/norns/lua/lib/molly_the_poly/lib/molly_the_poly_engine.lua'
	no file '/home/we/norns/lua/softcut/molly_the_poly/lib/molly_the_poly_engine.lua'
	no file '/home/we/dust/code/molly_the_poly/lib/molly_the_poly_engine.lua'
	no file '/usr/local/share/lua/5.3/molly_the_poly/lib/molly_the_poly_engine.lua'
	no file '/usr/local/share/lua/5.3/molly_the_poly/lib/molly_the_poly_engine/init.lua'
	no file '/usr/local/lib/lua/5.3/molly_the_poly/lib/molly_the_poly_engine.lua'
	no file '/usr/local/lib/lua/5.3/molly_the_poly/lib/molly_the_poly_engine/init.lua'
	no file '/usr/share/lua/5.3/molly_the_poly/lib/molly_the_poly_engine.lua'
	no file '/usr/share/lua/5.3/molly_the_poly/lib/molly_the_poly_engine/init.lua'
	no file './molly_the_poly/lib/molly_the_poly_engine.lua'
	no file './molly_the_poly/lib/molly_the_poly_engine/init.lua'
	no file '/usr/local/lib/lua/5.3/molly_the_poly/lib/molly_the_poly_engine.so'
	no file '/usr/lib/arm-linux-gnueabihf/lua/5.3/molly_the_poly/lib/molly_the_poly_engine.so'
	no file '/usr/lib/lua/5.3/molly_the_poly/lib/molly_the_poly_engine.so'
	no file '/usr/local/lib/lua/5.3/loadall.so'
	no file './molly_the_poly/lib/molly_the_poly_engine.so'
stack traceback:
	/home/we/norns/lua/core/norns.lua:146: in function </home/we/norns/lua/core/norns.lua:146>
	[C]: in function 'require'
	/home/we/dust/code/loom/loom.lua:32: in main chunk
	[C]: in function 'dofile'
	/home/we/norns/lua/core/script.lua:192: in function </home/we/norns/lua/core/script.lua:192>
	[C]: in function 'xpcall'
	/home/we/norns/lua/core/norns.lua:147: in field 'try'
	/home/we/norns/lua/core/script.lua:192: in function 'core/script.load'
	/home/we/norns/lua/core/menu/preview.lua:23: in function 'core/menu/preview.key'
	/home/we/norns/lua/core/menu.lua:143: in function </home/we/norns/lua/core/menu.lua:120>
# script clear
lua: /home/we/norns/lua/core/clock.lua:59: bad argument #1 to 'resume' (thread expected)
stack traceback:
	[C]: in function 'coroutine.resume'
	/home/we/norns/lua/core/clock.lua:59: in function 'core/clock.resume'

loom does require the molly_the_polly engine to be installed, which it will report in the maiden error logs – from above:

### SCRIPT ERROR: load fail
/home/we/dust/code/loom/loom.lua:32: module 'molly_the_poly/lib/molly_the_poly_engine' not found:

under the project manager’s available tab, you can search for the missing engine:

any time you install an engine, remember to SYSTEM > RESTART to register it :slight_smile:

please lmk if anything’s still murky / erroring!

As you were typing, my wife came in the room and figured it all out. We figured out we needed Molly the Poly and that led us to where we can find the engines for other scripts as well. The info about error log is really great for future reference!

Thanks again for all your time and good cheer. Despite this little glitch, I love this thing. Can’t for my grid, which is mailing next week. Have a great weekend!

2 Likes