ES debugging (back to it)

please post here with your recipe to achieve the “slowdown” bug with earthsea. please let me know which grid you have and if you’re II connected to TT.

Just to start with I am posting my steps I listed in the other thread:

Here is what I did:
• turned the unit on after update
• recorded a simple pattern
• "linearized" it = arp mode
• accelerated the speed a little
• activated transposition, and
• transposed it to a few random locations
• left it playing the pattern for few minutes

The only things that I see different from what you described when testing are: I have done nothing with shapes. And I always experience the slowdowns when playing a linearized pattern (as described above). It always takes a while for it to unravel, and I just let it sit… unfortunaletly it does not ALWAYS happen, but I have seen it at least several times now.

Should I try to capture this on video?

not necessary, i totally believe you! i’ll try the linearize.

Slowdown bug made another appearance (usually seems to be after powering up the case for the first time, after creating a pattern, linearizing, and letting it loop for about 10 min.). This time I actually saw the slow-down in the process (rather than complete freezing of thr grid). The process looked like the grid being unable to refresh itself and displaying only partial information (e.g. play bar on top row cycling from left to right but only some leds lighting).

@laborcamp It may be difficult to replicate the slowdown, but I may have been able to stop it (rather than just waiting). I first tried turning each CV knob, then removing the edge cable, then the pos cable, then the CV 1 cable, then the CV 2 cable (each time pressing grid buttons and reinserting the cables back in). Nothing. Finally, I pulled out the CV 3 cable and the grid returned back to it’s normal state fairly quickly. Now, this could be just a coincidence, but maybe it’s related?

@tehn Don’t know whether sharing these “shot-in-the-dark” experiences is helpful or just creates more confusion?

Possibly another clue: I’ve also noticed that after recovering from a slowdown episode, I can no longer activate the half-speed or double-speed runes (or any runes/shapes for that matter). I am able to do everything else.

thanks for the tips. can you remind me what grid you’re using? and i recall you’re not using TT, correct?

@tehn no problem, I’m using a brand new grid purchased from Control, Brooklyn (and yes, no TT just ES).

I have a suspicion that the issue might be electrical after all…
@greenanother is your case maxed out power-wise? Or close to it?

@laborcamp Maxed out? Not at all. I’m running one Tiptop uzeus studio buspowered with a cincon power brick on the top rail and one on the bottom (possibly even overkill on a 6u case). Not to mention that the only modules running in the entire case atm are a Metropolis, Switch and Earthsea. So feels like a power consumption issue when you see that slow down though; doesn’t it? Sad, because earthsea is my first monome module and I just bought it and the grid last week. It’s glorious when it works though…

@greenanother can i assume that your tests have been using Switch inline for connecting the grid?

Yes, @tehn. I have only been using switch to power the grid. The maximum the studio powerbus puts out on the 5V+ rail is 300mA, so I wouldn’t even try powering the grid without it.

I’ve not had a chance to update my firmware or do any testing, but will try to set aside some time in the next couple of days and report results.

FWIW I’m using switch and have a beefy power solution too, and have experienced the slowdown at least twice.

which grid are you using?

@tehn A brand new aluminium 128.

I just picked up a Mysteron, and have been distracted by that, so haven’t done any further ES testing yet. So many toys!

Well, I updated all the trinity modules today with the latest firmwares (I don’t have a TT) and …

… of course there’s no hangs with the ES. Jammed for about an hour, doing what I normally do with the ES, and it worked perfectly.

I didn’t try the precise steps listed above, but I’ll give that a crack tomorrow.

Another successful session last night, no crashes or hangs. Used the ES solidly for around 30 minutes, using pretty much every feature, and all good.

I haven’t noticed a consistent slowdown with ES (latest firmware), also in connection with TT. However I realized several times that ES is skipping a number of events when II clocked, after a minute or so of playing same pattern. It just doesnt respond to a few ES.CLOCKs , then resumes normal tempo. This does not occur at a specific time or action, as far as I can tell. I’ll report if I discover something more specific.
I am using the assembled grid kit powered through switch.

i suspect ES needs some fine tuning with regard to its internal timers. i’ll try to reproduce some II skips.

I realize this doesn’t give one much to go on but after several sessions without problem I just ran into weird ES behavior. The sequence:

== ES firmware 1.5 (I think)

  • turn on case with trilogy and II fully connected
  • ES starts playing a stored sequence on power up w/ arp on
  • TT starts with (EARTHSEA REMOTE) script (no other connections)
  • stop the playback, start manually playing keys
  • notice grid led lag
  • then ~10sec later ES locks up

== then I powered down and reflashed the ES with firmware 1.7

  • power everything back up, play keys for ~ 1 minute then lockup
  • power down, wait 5 sec, power up
  • play one key; then ES locks up
  • power down, wait 5 sec, power up
  • ES unresponsive
  • power down

== unplug II cable from ES, power up and everything is okay.

All this is driven by 4ms row power 40 with a 2013 era 128.

Was Teletype running fine during all this?
When ES “locks up” does TT continue running or does it also lock up?