Fates - a DIY norns DAC board for Raspberry Pi

Hey @jimi23!

I asked in a comment to your PR adding the STLs to the fates3d_case repo, but I’ll ask here as well:

Can you please upload your Fusion 360 files that have the usbc port and the 4th encoder hole?

Thank you!

It’s alive! I was terribly nervous as this was my first serious electronics diy project, and on my first go I soldered both headers on the wrong side of the board, but it all seems to work. Woohoo!

7 Likes

Has anyone ran into these:

  • error: load fail when loading ash/playfair, moln, step

  • error: missing ZSines when loading we/test/fonts

Cheers!

playfair requires Ack to be installed.
Moln requires ‘r’
Step requires Ack, but gets stuck on loading screen? Expects a grid?

And not sure why the font test requires an Sc engine… Norns big?

1 Like

pushed a fix for this. (answer: b/c it used to be that all scripts required one, but indeed ZSins is an extremely arbitrary choice)

1 Like

For some reason fates does not accept this diy arc and shield sees it as a Grid.

Running Orca on a WW works without a problem…

What could I test?

The diy arc project is here

GitHub

Another thing is I would like to know if there is any information when the image for a rpi4 will be available for the shield. On fates it is available and working fine.

from the github:

Please note: if you encounter a problem, please do not post on the monome forums ! Tehn will surely help you, but I don’t want my clone to cause them trouble and work. I’m very happy that they make their protocols open and I would like them to continue to do so in the spirit of openness.

but i’m going to contradict this— i can’t help— i actually have no idea how the DIY arc works and i don’t have time to go figure it out— i am focused on the core ecosystem which benefits everyone.

elsewhere, yes, please read the thread. it’s not a huge priority for us because we’re never planning to design anything that leverages the extra CPU power of the pi4, as the actual norns hardware uses a CM3.


please remember that most new features on norns are a product of volunteer effort.

2 Likes

The one I built worked absolutely fine with Fates and Ansible, with no modifications to either. Have you confirmed it working elsewhere, i.e. Max? Did you follow the instructions for assigning the serial number and made sure it was the proper length and format?

Yes, step by step.
I don’t know where to search atm. Now I can’t access the FTDI chip because i think when you program the serial it’s blocked. Maybe make another USB board and check if all is OK. So stupid i sold my original arc 4 and that 3 years ago. Then I could compare…

The fates disk image is built from the stock raspbian Buster release (which supports pi4), while the norns images are built from monomes own custom linux branch. That Monome branch is meant for maximum compatibility with the norns hardware first and then the new shield.

Pi4 requires a different set of compile instructions than pi3 due to the different processors used.

If I had more time available I’d try to recompile the various linux sources for pi4 + shield, but life is a little too busy for that right now.

I respect everybody who is working on these fine products like norns / Fates / Shield and fully understand.

Many thanks for the joy of playing with these

1 Like

UPDATE WARNING

Update 200121 has been released

Once again, do not run the on-device SYSTEM>UPDATE - it’s not compatible with Fates at the moment.

I will post an updater with modified script later today (January 21, 2020).

EDIT:
UPDATER HERE:
https://github.com/okyeron/fates/releases

21 Likes

You are awesome, sir.

2 Likes

I updated my fates using the latest firmware posted about. I used cyber duck to drop it into the update folder. Then I removed the wifi dongle and went to system/update where it found the file. Updated and it got to completed, then blank screen. After a few minutes of blank screen I powered off, then back on. Still blank. The led in the front is lit though. What did I do wrong? How can I fix it? Thanks!

Can you be more specific? Which firmware? The one from monomes GitHub or the one from my link above (the fates GitHub page)?

If the former, you’re hosed and will need to reinstall from disk image :frowning:

FWIW - I’ve not tried the method you described to update.

1 Like

The one just posted in this thread. Retracing my steps, I may have been confused by the update instructions. Was it drop it in the update folder, then follow the instructions after the ssh version?
Version 200221

The update should be done via SSH. Instructions on the update release page above. If the directions are confusing please let me know how I can make it better.

Not sure what to suggest. I can try to help troubleshoot in DM in about 30 mins.

Gotcha. I misread the instructions as sftp or ssh. Not sftp then ssh. Will try to reinstall the disk image. Thanks. Sorry for my poor comprehension.
Update. All fixed. Reinstalled and updated as per instructions. Thanks again.

Hello ! how can i get a pcb for this project ?

Check the first post, info there.