Fates - a DIY norns DAC board for Raspberry Pi

It is a 2gb model…

Have you tried plugging in the pi alone with the fates image flashed to SD into a display via hdmi? See if you get a prompt?

It gives me the same error even when not attached to the main board.

Haven’t tried yet to connect it to an external monitor as I need to buy a miniHDMI to HDMI cable… It’s next on the list tho.

Finally up and running. Was difficult to get the old switches out but it all works now! Any advice on what memory card size to use? 32gb seems to small. Is 64gb enough so I can have orac and side kick and pd? Im currently am using a 3+ pi

2 Likes

64gb will be more than enough. 32gb too honestly. 99% of that space would only be needed for samples and such.

1 Like

Update 201023 now available

If you are on 200218 or later
use SYSTEM > UPDATE while connected to the internet.
(please report back if you have problems with this)


If you are running a version prior to 200218, DO NOT USE SYSTEM > UPDATE .
You must update manually via SSH. Instructions are on the release page: https://github.com/fates-project/norns/releases/tag/2.4.3


See Norns: update 201023 for change log. NOTE - disk images on that post are for factory norns and norns shield ONLY.

New disk image for pi4 is being worked on.

12 Likes

Worked for me (SYSTEM -> UPGRADE). Thanks, as always.

1 Like

Did system>update and now get no audio out. I get this in maiden when i run Awake

"pitch_in_l
pitch_in_r

script init

starting halfsecond
pset >> read: /home/we/dust/data/awake/awake-01.pset
pset :: /home/we/dust/data/awake/awake-01.pset not read.
ERROR (i2c/hp) failed to write"

and this in SC
"
FAILURE IN SERVER /s_new Group 1254 not found
FAILURE IN SERVER /s_new Group 1254 not found"

try a RESET maybe? (and check your levels on the MIX page)

is your Awake up to date?

Rebooted multiple times. Nothing makes sound and the few scripts I tried all gave me the same i2c/hp error.

With awake, have you checked that it is set to output audio and not set to crow or jf output? I had this problem and it took me way too long to find it.

I’ll double check, but it shouldn’t be. I’ve never hooked my fates up to my Crow. The first thing that actually sent me looking was I was trying out the Otis update and everything was completely blow out, even if I turned the levels down my input was still totally blown out, just quiet. And it didn’t seem like the Otis was doing anything. That’s wear I first saw said error. Then I tried OOOOOO and it was also blowing out the input. Then I just tried Awake, same thing error. Also tried something else with now sound produced.

Tried the audio I was feeding in, into my factory Norns and it was fine.

Did you do a SYSTEM>RESET from the main menu?

The i2c/hp error is normal.

It might be worth trying the update again. Delete version.txt from the norns directory, then try SYSTEM>UPDATE again while you are connected via Maiden. The maiden REPL will show update messages, errors etc.

What does this mean? I’m confused.

Yup.

Did a manual update but didn’t delete version.txt can try that.

Blown out, distorting, clipping, at any level, even if I turned the input down at the source.

I haven’t used my fates a lot, but I did use it prior to updating and didn’t have any issues.

reran update after deleting version.txt

running update…
Already up to date.
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:3 http://archive.raspberrypi.org/debian buster InRelease
Hit:4 https://package.monome.org stretch InRelease
Hit:5 http://ppa.launchpad.net/artfwo/monome/ubuntu bionic InRelease
Get:2 http://apt.blokas.io rpi InRelease [3,922 B]
Reading package lists…
E
: Repository ‘http://apt.blokas.io rpi InRelease’ changed its ‘Origin’ value from ‘pisbtnw7 rpi’ to ‘main rpi’
E: Repository ‘http://apt.blokas.io rpi InRelease’ changed its ‘Label’ value from ‘pisbtnw7 rpi’ to ‘main rpi’
Reading package lists…
Building dependency tree…
Reading state information…
samba is already the newest version (2:4.9.5+dfsg-5+deb10u1+rpi1).
samba-common-bin is already the newest version (2:4.9.5+dfsg-5+deb10u1+rpi1).
The following packages were automatically installed and are no longer required:
libgudev-1.0-0 libmbim-glib4 libmbim-proxy libqmi-glib5 libqmi-proxy
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 162 not upgraded.
sudo
:
/etc/init.d/samba: command not found
Reading package lists…
Building dependency tree…
Reading state information…
Package ‘modemmanager’ is not installed, so not removed
The following packages were automatically installed and are no longer required:
libgudev-1.0-0 libmbim-glib4 libmbim-proxy libqmi-glib5 libqmi-proxy
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 162 not upgraded.
‘/home/we/maiden/dist/sources/base.json’ -> ‘/home/we/dust/data/sources/base.json’
‘/home/we/maiden/dist/sources/community.json’ -> ‘/home/we/dust/data/sources/community.json’
cp: cannot stat ‘/home/we/maiden/dist/catalogs/*.json’
: No such file or directory
ln:
failed to create symbolic link ‘/home/we/bin/maiden’
: File exists
ln:
failed to create symbolic link ‘/home/we/bin/maiden-repl’
: File exists
update complete.

Really not sure what could be going wrong on your device. Both my units (pi3/pi4) updated OK with no issues.

You could try the manual update process to go back a version or two:

https://github.com/fates-project/norns/releases/tag/2.4.2.5
https://github.com/fates-project/norns/releases/tag/2.4.2

For either of these you’d want to delete version.txt and then do the manual update process as listed from the command line via SSH.

If that does not change anything I would suspect a bad settings file somewhere in your ~/dust/data directories. Or something else entirely? If so, then maybe you’d need to backup your dust folder and then reinstall from disk image.

i’ll try that tonight. It’s definitely weird, I haven’t really used it at all yet. Certainly haven’t done any programming or anything. Barely installed any scripts yet.

Update 201029 now available

If you are on 200218 or later
use SYSTEM > UPDATE while connected to the internet.
(please report back if you have problems with this)

If you are running a version prior to 200218, DO NOT USE SYSTEM > UPDATE .
You must update manually via SSH. Instructions are on the release page: https://github.com/fates-project/norns/releases/tag/2.4.4

This release changes some things with regards to MIDI devices - if you run into anything weird with MIDI devices, please get in touch.


If you’re on a newish pi4 and having trouble - please get in touch via DM - I have a new disk image for testing. Looks like there’s some minor hardware changes on the Rev 1.2 boards along with some changes on the 8GB model.

9 Likes

No problems while updating. Thanks for your work!

I’m not sure if this is the right place but I’m hoping someone can help me

I cannot record to tape - I’m not sure what the problem is, I’ve been through every tutorial I can and nothing is working - bar a total re-install

I can play audio that’s already on fates but it’s showing .json files for each .was file on fates

I’d sure appreciate a little help, I’ve burned hours and hours on this

I’ve been using the tape heavily so it’s something I’ve done recently - I think I copied some MI engines and I’ve removed them but no dice and I’m not sure I even did it correctly