Fates - a DIY norns DAC board for Raspberry Pi

I bought a Fates with a loose power socket (usb c), but otherwise working great. Hasn’t been a huge issue, but not ideal when it switches off in the middle of a session because I bump into the cable!

I was thinking of reflowing it to see if that helps. I just wanted to check here if there is anything to be especially careful with when opening/soldering, as I am totally unfamiliar with this build :slight_smile: Grateful for any advice!

Was this a board purchased from me, or done by a third-party?

See the Build Guide for info and some pictures of the USB-C jack and soldering.

Seems odd to me that the jack would be loose unless it was poorly soldered to begin with. Pictures would probably be helpful.

Not sure as I haven’t opened the case yet - just realised my toolbox isn’t here in quarantine with me. So I will report back later :sweat_smile:

Update 200323

(If you are currently running 200218)
use SYSTEM > UPDATE while connected to the internet.

If you are on a version prior to 200218, DO NOT USE SYSTEM > UPDATE.
You must update manually via SSH. Instructions are on the release page: https://github.com/fates-project/norns/releases/tag/2.3.0

See the norns update 200323 page for discussion, but ask questions here if you think something is Fates specific.


I just came here looking for this. Thanks!

Hey - I asked the mods to move this to the Fates thread to keep support over here.

Can you give me a rundown of what you did? (with as much detail as possible)

What version were you previously running? What disk image did you flash from? Did you update after that?

on Backups - The dust folder is mostly what you’d need to backup for norns. For ORAC, there’s other stuff, but that’s probably questions for the Sidekick/Orac thread or the norns mother threads (since they are all a bit different)

Just updated worked perfectly. Thank you so much.

1 Like

SYSTEM > UPDATE worked perfctly. Thank you!


hmm still can’t get OTIS to work on this version

Check in on the OTIS thread?

Errors? Is Maiden telling you anything? Need more details to be able to help.

Updated from 200218 using the update in the drop down. Everything went as expected but I’m standing still on the shutting down… screen. It’s been there for about 5 minutes. Does it power off on its own or are we safe to power off on this screen?

Power off should be safe… lemme check the script…

last steps are

    print("shutting down.")
    m.message = "shutting down."
    os.execute("sleep 0.5; sudo shutdown now")

So that should be a graceful shutdown. Depends on which pi you have if the screen will blank or not.

You could verify if its still running by trying to SSH (or see if the connection drops if you’re already ssh’d in)

but yeah - should be fine to pull power and restart.

Awesome. Powered off and it booted up fine. Thanks for the quick help!

Trying to get a keyboard to work with Orca, I am using what I have and so far no luck. I have a wireless logitech that hangs the system and an older (2007) Mac keyboard. The Mac board shows up in the HID menu just fine and I can reassign it in the four HID positions, but I don’t get anything when I type in Orca. I’m not opposed to trying to order another keyboard but I feel like the Mac board is close and maybe I’m missing something…?? Help appreciated!

Thanks - i did an ‘update all’ in maiden and now OTIS works.

Perhaps there was something up with the prior norns version, as the error I was seeing reflected that seen by other norns users - either way all good now.

fired it all this morning and it just worked…talk about fate! :upside_down_face: thanks for your reply!

1 Like

Just curious if anybody in this topic has an experience with this, I’ve continued to have odd noise for issues with RPi 4’s in FATES. Nothing with RPi 3+ tho. I have tried 2 FATES boards and two Rpi 4’s. I’m using the 4GB RAM RPi 4. The noise floor is best found when using Cheat Codes because when opening the program, it is tripling the sound in buffer. Very interesting indeed. I plan to just swap everything to RPi 3+‘s but was just wondering if anybody else experienced this.

I’ve got an old white emac keyboard that I use with my Fates. It shows up as three devices in the menu with the same name :confused: , and you have to pick the right one of the three for it to work. I think the extra devices might be the internal USB hub?

1 Like

Did you manage to sort it out?
I looked into mine today, cleaned and reflowed the 3rd encoder joints just in case, also looked for shorts but no luck so far.
It’s still completely unusable :frowning: , I’ll try to order another one (post-coronavirus crisis as I can’t receive any parcel right now) and replace it.
I wonder though if it could come from somewhere else like a cold joint on another component.
@okyeron can you give us an insight about somewhere/something to look on the board related to the 3rd encoder ? Thanks

Hi, yes! Actually I desoldered the 4th encoder to replace the third one and it’s working pretty fine since then. I assume my case was a defect encoder.
Now I have a hole to be filled once I get another encoder hehe

1 Like