fiiiiive: alchemic MIDI sequencer for norns

fiiiiive

Sort of alchemic MIDI sequencer for monome norns, sequencing five by five to escape tonality.
A cryptic way to generate sequences that can be also played in poliphony.

requirements

norns, MIDI in and out

documentation

enc 1 → circles scroll

top circles - serie of intervals / play and tempo signauture

enc2 → select serie step

enc3 → change serie interval

key2 → play and stop

key3 + enc1 → select preset

key3 + key2 → save preset

key2 + enc2 or enc3 → serie range

key3 + enc2 or enc3 → tempo signature numerator and denominator

Other circles

triangles are amplitudes, squares are durations, pentagons are serie selections, and circles of circles are octaves

key2 → circle master step backward

key3 → circle master step forward

enc2 → setting step by cycles step select

enc3 → setting step by cycles step set

key2 + enc2 or enc3 → set master sequence’s loop range

key3 + enc2 or enc3 → set setting sequences’ loop ranges

installation

Install from Matron: ;install GitHub - fivedollarman/fiiiiive: alchemic sequencer for monome norns

48 Likes

@marcocinque

this looks ABSOLUTELY amazing!

ran into a few issues though…

crashed while on ext MIDI clock.
(i always use Ext MIDI Clock)
it was also really sluggish on Ext MIDI clock.

i went ahead and set it to Internal Clock and started it again…

i’m not getting any MIDI out of it.

sending MIDI to the input from an external sequencer…when the external sequencer is running i do see the dots moving around along the bottom of the page one screen.
so i guess it’s receiving.

i even ran the MIDI out into a second norns running MIDI Monitor on it and nothing seems to be coming through.

i quit the script and loaded FLORA as a test for MIDI and the second norns started registering the MIDI.

is there something i’m missing?

1 Like

Hello Spike, for MIDI in and out you have to select your device numbers (the ones you can see in system/devices page whit the usbs plugged) in the edit parameters page, have you tried yet?
The ext clock issue is strange, I’ll do a test and let you know.
I’m adding a pset in repo fo commodity,
best regards

ps. MIDI out channel was locked to channel 1, now you can select it in params edit window, just update the script

1 Like

I haven’t played yet but looks awesome! For some reason your link above wasn’t working for me in matron “not found”

But this did work for me. for anyone else that may have the issue.
paste ;install https://github.com/fivedollarman/fiiiiive

1 Like

finally had a chance to dig back in…
ran the update.
still no luck with MIDI out from the script.
:frowning:

i ran a single MIDI out cable from the Cirklon and split it to the norns input and to another device to make sure MIDI was coming through.

i again see the dots moving around along the bottom of the main screen.

loaded Icarus to see if norns would play notes from MIDI…and that was working.

anything else i could try to get it working?

Hello Spike,
fiiiive it’s a MIDI sequencer, it sends MIDI notes via MIDI out channel. You can run multiple sequencer lines with MIDI in notes. The pixels you see at the bottom are MIDI in notes.
So you have to connect a midi instrument via usb, right?
Check in parameters/edit if the device_out number is correct (it has to be the one assigned to your usb/midi out cable in system/devices), check in parameters/edit the midi out channel.
Let me know!
May be I’ll add an engine, standalone enjoying, in next updates,
best regards

MIDI output works fine for me if i use the default output device number 2, which is where i have an NTS-1. Changing it to device 3 doesn’t send it to my Digitone. What I’m saying is that MIDI is coming out (and oh what strange melodies, I love it and had it running for half a day yesterday!)

I’ll see if I can help in triaging and debugging later today or over the weekend.

Edit: got it, it’s a little typo on lines 269-273 of fiiiiive.lua

those midi_in_device assignments should be midi_out_device. Changing them fixes the issue, now raving with Digitone on croak duty :loud_sound: Would you like a pull request of GitHub, or is this fine?

1 Like

ok…yes…i understand it’s basic function design.

i have the MIDI output from my sequencer going into norns and the output of the MIDI from norns going into an Access Virus B.

my MIDI IN and OUT is via a Mio on device 1.
so…both the MIDI i/O is coming from norns device 1.

the out Channel is also set to one.
as an experiment i placed the Virus B into multi mode which sees all 16 channels at once.
still no luck.

ok…so this looks like a fix of sorts!

1 Like

thank you so much xmacex! You’re right!
I copied pasted and forgot to edit there :scream:
I updated the repo, what a nice community here!

4 Likes

Love this so much! Will be testing it out during the Christmas holidays.

1 Like