Flora (v0.4.9-beta: fixed pitch-shifting arpeggiator and minimal sequencer loader)

Hey, how can I update the script to 0.2.1 ?
I tried updating through maiden, but when loading the script I still see v.0.1.0.
I’m new to norns, so sorry if the question seems silly.

@Denbuter, there are no silly questions here, only silly mistakes I have made. I forgot to update the version number in the flora.lua file. I think I fixed this, so if you update again, you should see 0.2.1 when the script loads. Thanks for bringing this to my attention and please don’t hesitate to reach out if this still seems to be an issue or if you encounter other ones!

3 Likes

helloooo @SPIKE! is this happening with the pset sequencer running? if so, it may be that you saved your psets with different tempos which are getting loaded as the sequencer is running.

if this is happening even when the pset sequencer is not running, then i’m not sure what’s happening and i’ll probably have more questions for ya!

1 Like

i hadn’t set up any psets yet.
i don’t have any psets saved even.

well…i think norns picks up on MIDI clock tempo from the Cirklon whether its running or not.
(i’ll have to double check that)

1 Like

Ok. You might also want to look at your clock ‘source’ setting under PARAMETERS->CLOCK

If you do want me to investigate after you check on the Cirklon just let me know.

1 Like

ok…
i just checked on it.
as usual…i almost always have all of my norns set to MIDI for their clock.

i just did a test and it’s behaving now! :crazy_face:
so…just an FYI…
norns does see whatever i set the BPM on the Cirklon to at all times.
whether its stopped or playing.

i just tested while it was stopped and Flora responded to all of the tempo changes.
then i started the Cirklon and Flora responded to any BPM changes i made and locked right to it!
:partying_face:

update…
so i ran into something else weird.
when trying to save a PSET while MIDI clock was coming in…it would not save.

so i stopped the clock.
tried to save a PSET and it wouldn’t save.
however…i left the PSET page and went back and then BING the name was there!
i saved 4 PSETS with different names and this happened every time.

also…
i guess i am not sure how the PSET thing should work.
i tried to select a PSET number with the “load pset” parameter and it wouldn’t change from the number 1.

so…i quit out of Flora and went back in.
now it’s allowing me to choose more than one PSET under the “load psets” parameter.

i went back into the plant screen…are the plants supposed to revert to their original state?
i was thinking their status was saved with the PSET.
it is loading the different plants that i saved…but they are in their initial state.

should i be seeing the plants change with each PSET change?
or…am i not quite getting the application of the PSET sequencing?
:slight_smile:
thank you for help!

I am super happy to hear Flora is now responding properly to tempo changes triggered by Cirklon! Yay! That said, I’m not sure what changed that caused Flora to start behaving.
¯_(ツ)_/¯

In regards to the other issues:

  1. PSET names do not not immediately appear while MIDI clock is coming in: I’ve confirmed this was introduced with the v0.2.0 release. If CLOCK source is set to ‘link’ then the issue also occurs. I’m not sure why this happens but I’ll look into it.

  2. Selecting PSET with the ‘load pset’ param doesn’t change from the number 1: I couldn’t replicate this but will investigate further.

  3. Changing the PSET with the ‘load pset’ param reverts the plants to their original state: this is expected behavior because right now I’m only allowing the plant’s basic instruction set and angle to be saved. I’ll look into allowing the PSET to save the plant’s state more completely.

@SPIKE, I really appreciate the time you spent reporting on these issues! Thank you!

EDIT: I fixed issue #1. I still haven’t reproduced issue #2 but it is possible this fix for issue #1 also addresses #2, not sure. Issue #3 is still to be done.

3 Likes

This script is amazing. I’ve just has the internal audio going along with a connection to Crow controlling two modular voices. I’m wondering though does modulation of the plow settings effect the sounds coming out the modular or not ?

1 Like

@Glitcher I’m so glad you like it! Thank you!

To answer your question in brief, you just need to use crow outputs 2 and 4 to modulate the sounds of your voices being sequenced by crow outputs 1 and 3.

The longer answer is that modulation of the plow settings changes the shape of the envelopes sent to crow outputs 2 and 4. The envelopes sent to crow are defined with ASL. If you connect crow outputs 2 and 4 to the CV inputs of a VCA on the same the channels handling your audio signals, you should hear the envelopes “plowing” their way through the sound (so to speak).

One caveat is that any curve greater than or less than 0 is just set to ‘exponential’ or ‘logarithmic.’ At some point I’ll revisit this to see if I can better translate the curve shapes into ASL.

I hope that helps, but don’t hesitate to let me know if you have more questions!

Thanks for the detailed answer :slight_smile:

This I did do, so next time I will set up 16n for controlling plow and turn off the built in audio and get more of a feel for it.

I also tried crow ouputs as gates for modular envelopes with interesting results. I was hypnotized by
the sounds of Just friends, plus a mellow sound from Loquelic Iteritas and the inbuilt audio.

After some time I thought Hmm i’m not sure I fully understand the signal flow here haha.

Looking forward to using it with 16n.

1 Like

v0.2.3-beta has been released containing PSET improvements so plant generation and sentence settings may now be saved, addressing the last issue raised by @SPIKE. (Note, one of the issues couldn’t be reproduced: Selecting PSET with the ‘load pset’ param doesn’t change from the number 1.)

I’m thinking the next feature I’ll tackle is improvement to the modify screen so the underlying L-system instruction sets for each plant can be updated through the norns UI.

5 Likes

Hey everybody!

Houston is destroyed by the winter :cold_face: storm!

Rolling blackouts.
No water.
No internet so I’m only connected on the iPhone now that some cell service has been restored.

Investing in a generator last year was one of the best non-musical things I’ve done in a while. Then again…I guess I could get really cool drone out of it.

I hope net will get restored tomorrow so I can try out this update! :stuck_out_tongue_closed_eyes:

Be safe out there!

8 Likes

It’s good to hear you are ok SPIKE.

I lost power for a couple of days here in Portland but was able to temporarily decamp to a cozy bichon frise-friendly hotel.

I hope you and all other folks enduring this difficult weather are and remain safe and secure. :heart:

5 Likes

Hello.
From the last update, it seem there is an issue with the midi.
It’s like there is not note off message…
Have you the same problem ?

1 Like

Same issue here. It doesn’t play sequences anymore via midi. Just getting some random note while changing parameters. Never had this problem with earlier versions :slight_smile:

1 Like

@Mad86 and @vrcvs, I’m really sorry I messed up the midi. :frowning:

I’m in the process of moving houses and I am temporarily separated from my norns device. Please give me a few days to sort this out.

In the meantime, if you want midi to work, you can revert to an earlier version. The prior releases are listed here on github: Releases · jaseknighter/flora · GitHub.

2 Likes

no need to be sorry :slight_smile:
no worries and no rush at all, it was just to warn you about this bug.

thanks for the workaround and for all the amazing job you’re doing!

2 Likes

No problem Man.
Thanks to you for all this fantastic work.
No worries :wink:
@vrcvs say all that I want to say.

Cheers :raised_hands:

2 Likes

A new Flora release (v0.2.4) has been published which I believe will fix the issues reported by @Mad86 and @vrcvs with missing midi note off messages.

My current hypothesis about what was causing the reported issues is that midi note off messages were not occurring because the code to send midi note off messages was missing.

If requested, I’d be happy to conduct a retrospective with myself to try and uncover the deeper root cause(s) of this problem.

9 Likes

I confirm that now everything works flawlessly.
thanks for the support and the amazing work jonathan! :white_heart:

2 Likes