Fourtunes - a 4-track polyphonic step sequencer

This is so neat, thank you so much for this!

1 Like

Awesome sequencer! Had a ton of fun with this, this leads to a lot of happy accidents!

Any plans for Grid support? Using the grid to activate and select steps for triggers would be nice.

4 Likes

Awesome! This is definitely intended to work as a happy accident machine so I’m really happy to hear that.

I have some ideas for how to add Grid support to this, but I don’t have a Grid. One day! One day…

I do have a Midi Fighter Twister and will be adding support for that as soon as I have time. I’m also planning on adding track LFO’s for getting weirder with things like transposition, sequence length, pattern selection, etc.

If you have an iPad, check out TouchOsc it works pretty well as long as you don’t refresh the grid too often. It works, but not as fun as a hardware grid.

Track LFO’s should be fun!

I just got in to Norns development and am also working on a Polyphonic Step Sequencer, also using Molly The Polly for sound until I decide to dive into Supercollider.

3 Likes

Wow! Had some time to experiment. That’s a wonderful sequencer.

At the end of my session I had some problems with midi input (Sensel Morph though recognised by my Fates couldn’t input notes) but this is nothing I can reproduce so I will check again some other time.

Thanks a lot. Besides Cheat Codes this is one of my favorites!

1 Like

Would love to see Crow support and Just Friends.
Can imagine that this would be a killer sequencer with Just Friends!

2 Likes

Thank you! I’m happy to hear that you had fun with it.

As for the MIDI issue, that kind of sounds familiar…did you happen to remove an attached device? I think something like that happened to me while working on it. Pretty sure I switched the MIDI Input device from 1 to and back to 1 again to restore it.

Hmm I’m pretty sure I could get this working with Just Friends without too much trouble? I don’t have a JF module but I did play around with that Exquisite Script exercise and could test with the Imaginary Friends engine.

1 Like

That would be amazing!
Happy to beta test it for you too.
Preferably having JF run in note mode over vox mode although both would be awesome.

Yes, I think it was that kind of situation. I accidentally removed the power plug and had to restart Fates… that’s, I guess, when the midi input did not work anymore. I restarted again and also repeated the midi device assignment serveral times. Finally it worked again but - as far as I remember - not for all tracks.

Somehow weird and nothing I could report on in a systematic way. I will check again and report back.

By the way: I also like the Fourtunes interface very much! And yes, as I have a grid, grid support would be ace!

1 Like

hi, the interface lags a bit and i do not get some tones out. midi in works and i can hear the internal synth but if i recorded some notes, after pressing play nothing happend :confused:

but i like the idea of this script, perfekt for a digitone for exmapl (4 channels)

1 Like

Uh-oh that doesn’t sound good! Were you experiencing interface lag on a particular page, or all pages?

As for recorded notes not playing back, could this have been caused by the track output(s) being set to MIDI? I just noticed that if the track output is set to MIDI, you’ll still hear the internal synth while playing MIDI in, but the synth won’t be triggered on playback. I can see how that might be confusing and I’ll take steps to correct that.

Either way, thank you (and everyone else) for pointing these issues out! I appreciate the feedback. :heart:

hey thanks, now midi out works like expected i just restartet norns several times.
lag on all pages dont know why sorry.

Could your midi controller be sending excessive messages? Or routing midi out back in?

hi, this could be the reason, yes :=) i use the rk005 with norns and the pyramid with a lot of other stuff… :wink:
i will have a loook, thanks for the hint!

Updated script to version 1.01. Minor bug fixes:

  • Fixed K2 param (up) behavior.
  • MIDI input now only echoes to selected track output.
  • Turning Encoder 1 in any of the “All tracks” page modes no longer changes the current track selection.
2 Likes

Hi @unicity,

maybe it is my setup but I have difficulties to input midi notes. I use a Sensel Morph as midi controller. It works well as I can see using the internal Molly the Polly. Notes will get accepted only sporadically, sometimes even a few in a row, but often I can play for a while and none of these midi information will be recorded (the fact that sometimes I can input notes, tells me that my midi configuration basically must be correct, right?). This happens regardless of the record mode.

Any idea what I could try of do find out, what is going on?

PS.: This is happening with the recent update I installed half an hour ago.

1 Like

Hmm off the top of my head I’m not sure what might be causing that. I wanted to clarify one thing though - is the recent update you’re referring to a Norns update, or the update of the script itself? I’m assuming the latter but wanted to double-check.

If it’s the script update you’re referring to, did this behavior only start after the update?

Either way, thanks for bringing this up. I’ll try to sort it out.

Thanks very much for the immediate feedback!

Yes. I saw your note on version 1.01 and updated the script itself.

By the way: I run this on a Fates with the latest update.

I think I saw this input problem also before. But I did blame that on a faulty midi connection.

Let me know if I can help in a more productive way …

It might be helpful to test with my Midi Monitor script to confirm if your external device is sending everything it should be sending.

In Fourtunes it might be good to keep an eye on the Maiden REPL to see if there are any errors being thrown, or if something is streaming there.

3 Likes