Fourtunes - a 4-track polyphonic step sequencer

hey thanks, now midi out works like expected i just restartet norns several times.
lag on all pages dont know why sorry.

Could your midi controller be sending excessive messages? Or routing midi out back in?

hi, this could be the reason, yes :=) i use the rk005 with norns and the pyramid with a lot of other stuff… :wink:
i will have a loook, thanks for the hint!

Updated script to version 1.01. Minor bug fixes:

  • Fixed K2 param (up) behavior.
  • MIDI input now only echoes to selected track output.
  • Turning Encoder 1 in any of the “All tracks” page modes no longer changes the current track selection.
2 Likes

Hi @unicity,

maybe it is my setup but I have difficulties to input midi notes. I use a Sensel Morph as midi controller. It works well as I can see using the internal Molly the Polly. Notes will get accepted only sporadically, sometimes even a few in a row, but often I can play for a while and none of these midi information will be recorded (the fact that sometimes I can input notes, tells me that my midi configuration basically must be correct, right?). This happens regardless of the record mode.

Any idea what I could try of do find out, what is going on?

PS.: This is happening with the recent update I installed half an hour ago.

1 Like

Hmm off the top of my head I’m not sure what might be causing that. I wanted to clarify one thing though - is the recent update you’re referring to a Norns update, or the update of the script itself? I’m assuming the latter but wanted to double-check.

If it’s the script update you’re referring to, did this behavior only start after the update?

Either way, thanks for bringing this up. I’ll try to sort it out.

Thanks very much for the immediate feedback!

Yes. I saw your note on version 1.01 and updated the script itself.

By the way: I run this on a Fates with the latest update.

I think I saw this input problem also before. But I did blame that on a faulty midi connection.

Let me know if I can help in a more productive way …

It might be helpful to test with my Midi Monitor script to confirm if your external device is sending everything it should be sending.

In Fourtunes it might be good to keep an eye on the Maiden REPL to see if there are any errors being thrown, or if something is streaming there.

3 Likes

Oh yes, good ideas. I’ll do this at the next test run…

Though I was pretty sure everything is reaching the Fates because I could hear the feedback.

But… you are definitely right.

Hi,

yesterday evening I sat down to play with Fourtunes and I still noticed some unexpected effects while recording midi. When I played some midi notes like ‘c, f, g b’ flat the f was repeatedly ignored and instead Fourtunes played back an ‘e’. I have checked with Midi Monitor but so far my midi controller sends correct values. There were some other unexpected results while recording but those I will have to investigate further.

Does anyone else encounter some strange behaviour with Fourtunes or is it more likely that this is a local problem (maybe my midi controller, which is a Sensel Morph?).

Hi! This might just be down to the way the scale quantization is currently set up - incoming MIDI notes are not subject to quantization before being echoed to the output, but they will be scaled/quantized on playback (I plan on fixing this when I get the time as it can be confusing).

So your issue might be caused by whatever scale and root you have selected in the params menu. You might want to check the scale parameter - set the scale to chromatic and then see if the issue is still occurring.

1 Like

Quick 0-Coast patch additionally sequenced with Fourtunes. Opens up loads of ways to explore this further…

2 Likes

i’m having some trouble with the clock in fourtunes.
first of all, it simply won’t allow me to select “clock” in the parameters menu. scrolling through the option always halts a bit when i get down to “compressor” and then it jumps instantly down to midi settings. very weird.
i can record notes fine, but after pressing “rec off” it just shows me a “-” in the rec/play page and won’t play through the steps. also, in the edit step page “play step” doesn’t work. midi is routed fine.
here’s an error maiden gives me:

/home/we/norns/lua/core/clock.lua:82: /home/we/norns/lua/lib/musicutil.lua:301: attempt to get length of a nil value (local 'snap_array')    
stack traceback:
[C]: in function 'error'
/home/we/norns/lua/core/clock.lua:82: in function 'core/clock.resume'
/home/we/norns/lua/core/clock.lua:31: in function 'core/clock.run'
/home/we/dust/code/Fourtunes/fourtunes.lua:381: in global 'play'
/home/we/dust/code/Fourtunes/fourtunes.lua:681: in function 'key'
/home/we/norns/lua/core/menu.lua:139: in function </home/we/norns/lua/core/menu.lua:116>

and

stack traceback:
	[C]: in field 'screen_text_extents'
	/home/we/norns/lua/core/screen.lua:231: in field 'screen_text_right'
	/home/we/norns/lua/core/screen.lua:166: in function 'core/screen.text_right'
	/home/we/norns/lua/core/menu/params.lua:436: in function 'core/menu/params.redraw'
	/home/we/norns/lua/core/menu/params.lua:608: in field 'event'
	/home/we/norns/lua/core/metro.lua:169: in function </home/we/norns/lua/core/metro.lua:166>

Hey! I’m sorry to hear you’re having troubles. Is it just Fourtunes that’s giving you this clock issue?

I’ve never encountered these issues before so I’m a bit stumped at the moment. I did just notice that I’m not at the latest version (it’s been a busy few weeks) so I’ll update to 201202 and see if I can replicate the issue. I can see from your error that it’s dying at the line that calls clock.run().

Hello again! Updated to 201202 and tried once more. Still can’t recreate those issues and/or errors.

I know that I made use of screen_text_extents in a few places, but I’ve never encountered any issues with it like this.

Sorry I’m not much help here. :frowning:

In the edit step page, are the steps playing when you turn encoder 3? They should.

I have the same problem as 2197,
no steps playing when I turn encoder 3,
thanks for help

1 Like

Strange things are afoot…

Thanks for letting me know @Erwin_Lindemann. I’ll try and take a look later tonight if I have time. Currently juggling homeschooling my daughter while working from home so my free time is pretty limited.

2 Likes

Thank you very much, I understand your situation very well.
If I can help with further information or tests let me know.

1 Like

thanks @unicity! whenever you have the time : )
weird thing is, it worked for me a week ago. then I was going to show the script to a friend, and that’s when it suddenly gave me all those errors. i experience no problem with the clock in other scripts. i’ll try reinstalling the norns image and see if that does it.

1 Like

Hello!

I’ve spent some time looking into this (thanks to a lot of help from @2197 :heart: ) and it seems that Fourtunes is kinda broken with system version 201202. Here’s what I’ve found so far…

I last worked on Fourtunes with system version 201029 and all was well. When @2197 first raised this issue, I updated to 201202 and Fourtunes was still working fine for me.

BUT…in trying to recreate this issue, I decided to flash and do a fresh install of 201202 and now I’m seeing the exact same behavior (weird issue with the params menu and complaints from musicutil).

I’ll try and sort this out ASAP. Sorry about this!

2 Likes