Fyi: embedded raspberry pi, monome, gate inputs – sequencer – tutorial :)

I haven’t found the right combination yet, I did checkout and compile the commit you suggested
still trying, tips apreciated, keep hitting the segfault

this little toy :slight_smile:
https://getchip.com/pages/pocketchip

are you booting into serialosc(d)? i started thinking that using some pauses in the bootscript before launching it helps – may have been imagination, how ever :slight_smile:

this looks pretty neat! – am i understanding you right that you’re connecting the grid to it?

yes, it has a USB port, and I got output while pressing monomebuttons while running “cat /dev/ttyUSB0” so it’s possible :slight_smile:
it runs some kind of Debian, lot’s of RPi packages also work for it (like the pd-l20rk arm7 version)

Thanks for this tutorial, it’s been really helpful !
However, the Purr-Data part is a little bit problematic for me.

I’m trying to instal p2-2lork on Raspbian Stretch, at the moment there’s an issue with the dependencies (pd-l2ork : Depends: libgsl0ldbl (>= 1.9) but it is not installable).

I think there’s no release compiled for Stretch & Arm7 yet. I’ve tried to compile the program but this generates some errors and I can’t get a correct .deb

Anyway, it almost works with pd-l2ork-2.4.6-debian_jessie-armv7l.zip if I avoid the sudo apt-get -f install and to install some dependencies manually.

sudo apt-get -f install simply removes the pd-2lork package . I’m new to Linux, Debian and Raspberry Pi, so that was a surprise, it took me a few trials before I realize what’s going on.

Correcting dependencies… Done
The following packages will be REMOVED:
pd-l2ork

:open_mouth:

Do you know where I can post issues and ask questions about this software ? Is there a dedicated forum ? Or do you know how to make a clean install of pd-2lork on a pi3 with Raspbian Stretch ?

(I’ve tried PureData vanilla on Stretch, it works but it doesn’t seem to load Cyclone…)

apt-get isn’t just an installation program, it manages dependencies and tries to resolve conflicts when they occur, while minimizing system breakage. The -f option is for fix

which means sometimes the best way to resolve broken dependencies is to remove the only package needing those.
To install a .deb package downloaded from somewhere (hopefully a trusted source!), you want to use dpkg -i packageName.deb
Did you try the build guide here : https://github.com/agraef/purr-data#linux ?
If the only external library you need is cyclone then i would just install it with deken from within pd vanilla and use that.

edit: well i see that those steps are in the above mentionned tutorial so this post is probably just repeating what you already read :s

Thanks for your reply.
Yes I’ve followed the build guide you mention with a ./tar_em_up.sh -R for Raspberry. I don’t remember what the errors were, I should try again and see what happens.

I would like to use the mrpeach external but it’s not available for Pd Vanilla on Raspberry. For some reason Cyclone was not loading in Pd Vanilla but yes it would be enough maybe. I understand that OSC is now available in Pd Vanilla, it would require to rewrite the Serialosc patch provided in the grid studies

Edit: Yes, I understand that apt-get -f is trying to fix the problems but if it removes the “main program” pd-2lork, I have to find a workaround :slight_smile:

Edit : The solution is to modify the list of dependencies mentioned of Github and install these ones only :

sudo apt-get install bison flex automake qjackctl \
      tcl8.5-dev tk8.5-dev tcl-dev tk-dev libasound2-dev \
      libjack-jackd2-dev libtool libbluetooth-dev libgl1-mesa-dev \
      libglu1-mesa-dev libglew-dev libmagick++-dev libftgl-dev \
      libgmerlin-dev libgmerlin-avdec-dev libavifile-0.7-dev \
      libmpeg3-dev libquicktime-dev libv4l-dev libraw1394-dev \
      libdc1394-22-dev libfftw3-dev libvorbis-dev ladspa-sdk \
      dssi-dev tap-plugins \
      invada-studio-plugins-ladspa blepvco swh-plugins mcp-plugins \
      cmt blop slv2-jack omins rev-plugins \
      libslv2-dev dssi-utils vco-plugins wah-plugins fil-plugins \
      mda-lv2 libmp3lame-dev libspeex-dev libgsl0-dev \
      portaudio19-dev python-dev libsmpeg0 libjpeg62-turbo tkpng flite1-dev \
      libgsm1-dev libfftw3-dev libgtk2.0-dev subversion git libstk0-dev \
      libsndobj-dev libfluidsynth-dev tclxapian fluid-soundfont-gm \
      python-tk byacc

In case someone needs this… Here’s a serialosc abstraction using PD Vanilla objects for OSC, UDPsend, etc. Works with PD Vanilla without Mrpeach

serialosc.pd (3.5 KB)

6 Likes

That’s great, thank you for sharing this!
:slight_smile:

1 Like

(just to let you know – after some more struggles, i’ve updated the walkthrough with all findings we’ve made in the past months: https://docs.google.com/document/d/1X6XEBOFWkDXBDxmBkIWtTUYur-g2f80m3U3KS3RrLB8/

it doesn’t cover the GPIO input section, but it’ll get you a clean version of PD and serialosc up and running! :cat2:)

2 Likes

Thanks for this document ! Yes, in my case it was really easier to work with Pd vanilla than with Pdl2ork (even though it’s totally possible to compile it for Rasp Stretch, using the vanilla objects for OSC work as well ) :slight_smile: