GitHub install - unrecognized operation

Hi, Noob here. I have a fresh install/ Norns running the latest version- norns201202-shield. All is well, I can connect to wifi and load Maiden but trying to install things from GitHub- all fail and I get “unrecognized operation” error. I’m on the Matron tab…

;install https://github.com/miker2049/midigrid => unrecognized operation

What am I doing wrong? Thanks in advance!

happy sunday!
the shield fresh image is an update behind, so give SYSTEM > UPDATE a run and you should be able to upgrade to 210114, which includes the ;install feature
:slight_smile:

1 Like

That did the trick, thanks! Curious, while on topic, how do you install from your local computer if not online?

hi! oh, gosh, i didn’t see this follow-up question, apologies!

here are the steps for a manual/offline update: help - docs

Hi there, recently attempted to install a non-maiden package using and was unsuccessful.

Updated norns to the most recent release, and went through the docs, and

;install https://github.com/tehn/test-update

is returning
;install https://github.com/tehn/test-update => unrecognized operation

;reset works as intended unsure if there’s some sort of ?permissions? issue I’m unaware of.

thank you.

hi! you’ll just need to grab the latest norns software update for this function to work.

SYSTEM > UPDATE while connected to wifi!

SYSTEM > UPDATE on norns shield gives me “up to date.” and ;install still shows as unrecognized in matron

looks like i’m on version
210114

1 Like

thank you for confirming!
hmm – it’s possible that the update might need to be re-run. please try holding K1 while pressing K3 on UPDATE, which should allow you to download and run the update again.

let us know how it goes! :slight_smile:

hi @zaqwithaq

another possible solution is clearing your browser’s cache. recently had a friend with this issue, and this is the solution that worked!

1 Like

oh, YES, that’s actually much likelier – thanks @sademik !

1 Like

Realized I never returned to offer my thanks! Clearing the cache fixed it!

1 Like

Hi folks - I had this same issue with the “unrecognized operation”, realized I needed to run an update on my norns shield, which I did, and then, after it shut down for the update - I can’t seem to turn it on anymore. I plug the power in, the red indicator light comes on, but nothing else… not sure what to do

Hm, I wonder if maybe your pi is turning on fine but something is failing when attempting to start up the norns software. Can you see if you’re able to open maiden, connect to matron, and type ;restart to see if there are any errors being logged?

hello! Hopefully a quick question with a quick answer.

I’m trying to use the ;install + url command in Maiden to install, well I can’t install anything this way, Maiden returns with ‘unrecognized operation’.

To be clear, this command is meant to be placed in the entry field at the bottom of the screen where the flashing insertion point is located. I will, for example, paste the following:

;install GitHub - justmat/massif: norns resonator

And upon hitting enter, Matron says ‘unrecognized operation’.

I’m going to assume user error here, although I can’t imagine how I can be messing up such a simple process…

Thanks in advance!

hi! hope all’s well :slight_smile:

this is likely either due to your norns not being up to date or a browser caching issue. looks like @ioflow merged your post in with this thread, which has information on both solutions above :slight_smile:

please let us know if you run into any further trouble!

1 Like

Hey Dan! I meant to email you yesterday, but I walked into the tattoo studio already booked straight through to closing and never got a chance to reach out. I wanted to let you know what ended up working for me with the issue you assisted me with, and I’ll hopefully be able to do that this afternoon.

And here you are right, of course, I had an update to execute and now the command works perfectly, yay!

thanks again!!

1 Like