Graph.lib Bargraph Styling

I’ve been using the Norns Graph library (which is great!), but had some oddness. Here’s the relevant code from my UI module:

function UI.drawPatternGraph(channel, label, y_max, y_pos, prescale, type)

	-- https://monome.org/docs/norns/api/modules/lib.Graph.html

	local pattern = UI.patternState[channel]["pattern"]
	local step_index = UI.patternState[channel]["step_index"]

	local base_y = 12
	local graph_x = 8
	local label_x = 2
	local label_y = 25

	-- Draw label

	screen.move(label_x, label_y + y_pos)
	screen.font_size(8)
	-- Highlight label on first step of pattern
	if(step_index == 1) then
		screen.level(15)
	else
		screen.level(5)
	end
	screen.text_center(label)
	screen.fill()

	-- Draw pattern graph

	-- new(x_min, x_max, x_warp, y_min, y_max, y_warp, style, show_x_axis, show_y_axis)
	local graph = Graph.new(1, 16, "lin", 1, y_max, "lin", "bar", false, false)

	-- set_position_and_size(x, y, w, h)
	graph:set_position_and_size(graph_x, base_y + y_pos, 61, 13)

	-- Add points to graph
	for i, val in ipairs(pattern) do
		-- Convert bool to int if pattern type is "bool"
		if (type == "bool") then
			graph:add_point(i, (val and 1 or 0) * prescale)
		else
			graph:add_point(i, NornsUtils.round(val) * prescale)
		end
	end

	-- Highlight bar for current step
	graph:highlight_exclusive_point(step_index)

	graph:redraw()

end -- End UI.drawPatternGraph(channel, label, y_max, y_pos, prescale, type)

function UI.redraw(pattern_state, step_state)

	UI.patternState = pattern_state
	UI.stepState = step_state

    screen.clear()
    screen.aa(0)

	-- UI.drawTopBar()

	-- Draw Notes channel graph
	UI.drawPatternGraph("notes", "n", 12, 0, 1, "val")
	UI.drawPatternGraph("octaves", "o", 6, 10, 1, "val")
	UI.drawPatternGraph("accents", "a", 6, 17, 2, "bool")
	UI.drawPatternGraph("slides", "s", 6, 24, 2, "bool")
	UI.drawPatternGraph("rests", "r", 6, 31, 2, "bool")

	screen.update()

end -- End UI.redraw(pattern_state, step_state)

The oddness is that at one point, the bars of the bar-chart were being drawn in a different way, with solid bars, which I preferred over the default styling with “hollow” bars with a dark line down the centre. I can’t now get that styling back, though, unfortunately.

Anyone know how I might get that back? I think the styling changed when I disable screen aa, but now it doesn’t seem to make any difference if anti-aliasing is turned on or off - I still get the hollow bars.

I’m using the latest Norns firmware version on Fates (the Fates-specific version, but I don’t think screen-related stuff differs from the factory Norns/Shield build, does it?).