Grd

grd

8x8 autonomy


i’ve revisited an old supercollider code of mine and rewrote in lua. it can do granular synthesis at rapid iterations or can sound like a music box at gentle speed. in any case it is autonomous to some extent.

documentation

the two parameters can influence the process…

key3 start/stop
key2 page
enc1,2 params

requirements

norns

there’s a custom engine and a supercollider class. follow the steps below for installation.

installation

use maiden and find it from the community library. after installing type ;restart and enter.

or manually, login via ssh then:
cd dust/code
git clone https://github.com/yotamorimoto/norns_grd.git
mv norns_grd grd
cd grd
git submodule init
git submodule update
~/norns/stop.sh
~/norns/start.sh

GRD should now show up on the SELECT menu.
enjoy.

#norns #supercollider

41 Likes

Does this require installing a new engine?

It looks like it includes a new engine and some supporting classes, but at first glance seems self contained (no installation required on Norns, b/c Norns already scans the relevant locations for SC extension classes)

2 Likes

Indeed it does. Thanks for asking. It’s all contained in the github code. I will write in the description.

1 Like

Right. The class is a small multi-sampled instrument. It is contained in the package and norns just compiles it automatically. But for the first time restarting of engine is necessary.

Oooh this is really nice to sit and listen to!

my working install steps from ssh:

git clone git@github.com:yotamorimoto/norns_grd.git

mv norns_grd grd

cd grd

git submodule init

git submodule update

sleep norns then reboot

1 Like

Thanks a lot! The norns side of thing is pretty new to me (though I’m with supercollider 20+ years). So i’m not sure of the standard way of installing but instead of sleep and rebooting I did norns/stop.sh and norns/start.sh (from the ssh). And that also worked fine.

quick method w/o rebooting is SYSTEM, RESTART which just restarts the norns software (including sc) instead of the whole os

2 Likes

thank you. Is it the same as ;restart in maiden? i don’t seem to have RESTART in my system menu. probably running an os behind.

I am getting this when I launch NORNS_GRD/GRD. Any ideas?

### MISSING INCLUDE: grd/sc
### SCRIPT ERROR: load fail
/home/we/dust/code/norns_grd/grd.lua:9: MISSING INCLUDE: grd/sc
stack traceback:
	/home/we/norns/lua/core/norns.lua:136: in function </home/we/norns/lua/core/norns.lua:136>
	[C]: in function 'error'
	/home/we/norns/lua/core/startup.lua:47: in function 'include'
	/home/we/dust/code/norns_grd/grd.lua:9: in main chunk
	[C]: in function 'dofile'
	/home/we/norns/lua/core/script.lua:172: in function </home/we/norns/lua/core/script.lua:172>
	[C]: in function 'xpcall'
	/home/we/norns/lua/core/norns.lua:137: in field 'try'
	/home/we/norns/lua/core/script.lua:172: in function 'core/script.load'
	/home/we/norns/lua/core/menu/preview.lua:21: in function 'core/menu/preview.key'
	/home/we/norns/lua/core/menu.lua:139: in function </home/we/norns/lua/core/menu.lua:116>
# script clear

I’ll check it later today. sorry about that!

2 Likes

ok. i added the steps of installation in my original post above. you’d better delete the previously installed folder. hope this will work!

3 Likes

worked great, thanks!

Maybe that was a typo?

SYSTEM>RESET will restart everything, but it also resets a bunch of system settings to defaults (like MIX levels, some params, etc.)

from maiden you can do ;restart in both the Matron and SC tabs.

I want to give this script a try soon! :grin:

1 Like

Ah, right… thanks for the that. then ;restart is easier. And a BIG thanks for the fates shield. so happy to have it!!

1 Like

this looks cool but im totally lost on how to install it

1 Like

true, using the terminal isn’t the most friendly way, i must admit… i’ll have to check how this can be included in the maiden repository.

1 Like

open a pull request against norns-community, adding your project’s description to community.json. (here’s an example.)

not sure why, but doing the soft reset resulted with a “supercollider error” for me.

pull request sent. did it work?