Grid 128 fail to appear (but is visible in hardware listing)

The connection of my recently purchased Grid 128, comes and goes. I first noticed as I was walking through the featured applications and M4L devices.

The Grid is sometimes not visible in the Serialosc drop-down menu. But it is discovered by my computer and visible in the USB/hardware overview.

I’ve solved it by restarting my system, but would like a more permanent solution.

I’ve never owned a Grid before and have also not tried out or downloaded serialosc drivers for any other reason. Hence - these are a new install and of the latest incarnation. As far as I understand.

I’d very much like any pointers to how I can solve this or tips on what might be my mistake.

Cheers! //Carl Mikael


Screenshots from just now when I decided to go through the Max Grid Studies. Grid does not show in bpatcher serialosc.

i’ve just helped another user debug this-- it’s an issue with the AppleFTDI driver.

if you’re not on 10.11, try upgrading first to 10.11 to see if it works (it should). note that 10.9 and 10.10 have issues with their AppleFTDI driver.

if that doesn’t work, remove the apple driver (open a terminal)

cd /System/Library/Extensions/IOUSBFamily.kext/Contents/Plugins
sudo mv AppleUSBFTDI.kext AppleUSBFTDI.disabled
sudo touch /System/Library/Extensions

and get the official FTDI driver:

http://www.ftdichip.com/Drivers/VCP/MacOSX/FTDIUSBSerialDriver_v2_3.dmg

here’s the full install guide from FTDI:

Thanks @tehn. I’ll get on that right away!

Somewhere - when doing my first install - I read about the FTDI issues. But since I was already on 10.11, I didn’t really take any action. Might there have been some other older stuff disturbing?

http://monome.org/docs/setup

if you upgraded to 10.11 from another version, and previously had the FTDI driver installed, it will cause conflicts. you can remove the old FTDI driver (as described on the docs page) first and see if it works (the built-in AppleFTDI driver).

I misread the original instructions. Thanks for clearing that out.

Cheers!

I think I’m the first user that tehn is talking about, he helped me through this yesterday. I wasn’t’ getting any connectivity and after installing the ftdi drivers (and uninstalling the apple ones) I am having the same intermittent issues. It seems that if you unplug the monome after restart, it won’t be recognized when you plug it back in without restarting. Any ideas?

@tehfizzle same here - it appears to working correctly on both my mac and pc as long as it is plugged in upon boot, but if it gets disconnected it is no longer recognized - did you find an answer for that?

Cheers gang,

Dave

@darve

are you using the FTDI or AppleFTDI driver at this point?

Hey man,

This is with the FTDI driver - I think i’m going to format my system because I have more than likely cocked something up - will report back!

D

Update: I did a clean install of el capitan, installed serialosc and everything works absolutely beautifully.

Thanks for your help boss!

Dave

hi!
I followd the instructions. when i implement the code into termnial to disable the appleFTDI driver it just says

"mv: rename AppleUSBFTDI.kext to AppleUSBFTDI.disabled: No such file or directory
Jacobs-MBP:Plugins jacobwolf$ "

Ive been struggling with this issue with my Gride 128 for a few months now. Ive updated to mac version 10.12.1 and installed the new FTDI driver and i still have no appeareance of my grid. Sorry to be a pain just would love this to work :slight_smile:

This is interesting - I had my hdd fry a couple of weeks back and without boring you senseless had to load Sierra - it’s been, ah, annoying…I wouldn’t usually go near an apple OS for a year or two but he I am.
What’s the ftdi story with Sierra? My grids been intermittently doing weird shit and I haven’t really been back to it as im waiting for my arc, ansible, TT - couldn’t be assed with the computer at all for music.

This was on a fully formatted disk that never had an OS on it

Bump…

I am having this issue, too. I received a monome as a gift (best present ever!!), a grayscale 64, and it shows up in Max after restart, but if I unplug it and plug it back in, it doesn’t come back in the SerialOSC object in max. In addition, another monome device shows up in the device tree.
I attempted to install the most recent FTDI driver, as there wasn’t one listed in the plugins folder as per the instructions…

I do Arduino stuff and I haven’t had any issues there, but I know that when they released the UNO they changed how the chips do their FTDI stuff. So maybe that’s unrelated.

Anybody have ideas what I might be able to do?

Some of my readouts…

MBP Retina 13-in Early 2015
OSX 10.11.6
SSD

cd /System/Library/Extensions/IOUSBFamily.kext/Contents/Plugins
ls
AppleUSBLegacyHub.kext IOUSBHIDDriverPM.kext
AppleUSBMergeNub.kext IOUSBHIDDriverSafeBoot.kext
AppleUSBVideoSupport.kext IOUSBLib.bundle
IOUSBCompositeDriver.kext IOUSBUserClient.kext
IOUSBHIDDriver.kext


kextstat -l | grep -i ftdi
145 0 0xffffff7f80e03000 0x7000 0x7000 com.FTDI.driver.FTDIUSBSerialDriver (2.3) ECC3AF36-431D-370D-86F2-5237785E9CF8 <98 39 5 4 3 1>