Grid Linux Instructions up to date?

I don’t own a grid, so I can’t test them. I’m considering jumping into the Grid / Monome world, linux support is a plus (but not a requirement) for me. Are these instructions still accurate? http://monome.org/docs/linux/

In particular, the Max / Wine portion. I assumed I wouldn’t be able to use Max on Linux. The instructions talk about Max 5, though 7 is the latest. Is Max 5 the last version to run under Wine?

I’m also very interested in the Node version of Grid studies for Linux: http://monome.org/docs/grid-studies/nodejs/ any gotchas I should know about there?

Quick word about my setup, I’m a modular enthusiast (so would like to pick up a Grid and an Ansible when they’re back in stock) but I’m also a programmer-turned-manager (meaning I don’t get to program much at work anymore) who sees the Grid as a path to fun programming music play with my 9 year old. I currently avoid computers for music-making, so I have an old Thinkpad running Ubuntu that I use to record with Audacity. I actually record to a cassette four track and then re-record out to Audacity if I want a digital copy. I have Bitwig on the laptop, so I could see writing Node.js based midi grid toys. The Node part seems pretty doable, but I’m a little excited that I might also be able to run Max based Grid apps in Linux? Is that possible?

So, in short - can I expect the linux grid install instructions, including Max & Wine setup to work well for me? Thanks!

not a linux guy myself… but I would skip the max in wine stuff and just use node (or pd)
that info is very outdated. lots of efforts have been done in the meantime to help people program in various environments: http://monome.org/docs/grid-studies/

I recall people calling those wine instructions crazy :slight_smile: (to be fair, they are from a time when the serialosc.maxpat was the only supported way of interfacing with serialosc)

you should be able to compile serialosc, there are some threads on here that might help.

oh, and welcome!

1 Like

Cool, thanks for the insight

I’m planning on picking up a Grid regardless of Linux support. Once I do, I’ll experiment and suggest changes to the onboard docs if I find anything helpful.

Thanks!

1 Like

The first part of the Linux setup page:

https://monome.org/docs/linux/

recommends using this ppa:

https://launchpad.net/~artfwo/+archive/ubuntu/monome

Once added the repository and updated apt, I could not install libmonome; it didn’t find the library. So I installed serialosc via apt, which caused it to install something called libmonome1. I suspect the documentation should reflect this?

The Linux setup page next says to run serialosc. I restarted Konsole, then I restarted the entire computer, but still my OS can’t find it:

jeff@jeff-inspiron-2017:~$ serialosc
serialosc: command not found
jeff@jeff-inspiron-2017:~$ 

I’m going to uninstall those two apt packages and install from source, then, but I thought I should tell someone about it.

After installing from source I kept getting this error

libmonome.so.1: cannot open shared object file: No such file or directory

so I uninstalled and went back to the apt repo. After digging around a while I discovered that you to add yourself to the dialout group if you’re not in it:

sudo adduser <your-name> dialout

While my machine still has no command installed named serialosc, it does have these:

serialoscd          serialosc-detector  serialosc-device

If I run serialoscd, whether or not the monome is plugged in, nothing happens; I just get a new command-line prompt.

If I run serialosc-detector with the monome plugged in, I get this:

jeff@jeff-inspiron-2017:~$ serialosc-detector 
�x(S�U\P
        /dev/ttyUSB0\P
^C
jeff@jeff-inspiron-2017:~$ 

(The ^C is me killing the program to return to the prompt.) If I run serialosc-detector without a monome plugged in, it just hangs until I press ^C.

So … is it working?

It’s working! Or, at least, I’m able to run the first program here:

https://monome.org/docs/grid-studies/python/

(The edits I’ve suggested above still need to be made, I think. I could make them myself if I had permission.)