Grid Not Connecting To Norns

My Grid is no longer connecting to my Norns.
I’ve written to Help, but since it is a Saturday afternoon, I figure they won’t be around and maybe a smart person here can help.

My new-ish Grid is no longer connecting to my new-ish Norns (both from November 2022).

I was using Meadowphysics with MXsynth. While adjusting the parameters for the synth, Grid froze and became unresponsive. I could still adjust sound parameters on the Norns.

Now the Grid will light up when the Norns is started/restarted, but after that it is non-responsive. It does not show up under Devices. I have even reset each slot to “none.”
I just updated the Norns today as well.
I deleted the MXsynth engine and ACK.
I have tried resetting and restarting several times.
Norns is fully charged and connected to power.
Grid is still unresponsive when Norns is on battery power.
I’ve tried 2 different USB cables.
I’ve disconnected everything but the Grid, but no success.
None of the scripts recognize the Grid.
I had the wi-fi dongle connected at the time.
I also had Crow connected to Norns, but it was powered off.

If anyone has any ideas, please let me know. I have a low key Sunday and would love some Grid+Meadowphysics time.

A couple things you could try:

  • Connect your grid to a computer and use the Max test app to confirm that the grid is working normally.
  • Revert to a previous version of norns if you didn’t have problems before updating (I think this requires some command line pokery, not sure if the steps are written up anywhere.)
1 Like

Check system>devices>grid
Remove your grid and then plug it in again and see if it reconnects
norns | monome/docs.

Thanks. Tried that. Nothing.

1 Like

Are any midi usb devices working or is the Wi-Fi dingle working?

I’ve had this happen frequently for years, or at least something similar. The fix for me has been to attach the grid after startup. It was enough of an irritation that i got a usb hub with switches for the devices.

Thanks everyone. @dan_derks is on the case. Grid isn’t connection to Max or Mark Eats Sequencer, so it might be faulty.