Heavy slow downs with Earthsea


i am fighting with heavy slowdowns with earthsea. (> 3 Seconds)
I know the problem but i thought it was fixed with ver1.7 .
When i received earthsea 2 month ago I had also the issue, but after re-flash ver. 1.7 and swapping the order of MP and ES the problem was apparently solved since today.

I don’t know whats happened, but after a little bit playing with Teletype and ES the problem appears.


Just an idea, but the only change is, in the past i started teletype with no scenes. Now, the problem appears after loading a stored scene,.

Any ideas? To be honest, with this problem ES is just useless because i have to restart the whole system


does it slow down when not connected to the II cable? what case and power supply are you using?

The main power supply is an Mean Well RT-50B. For the grid I use an normal wall wart supply 1A/12V (with Monome Switch)

after some issues at the beginning I never observed the wrong behaviour with the cable. But it I cannot confirm because I run this setup (with connection) the last 2 month without any issue.

Is it possible to implement an Restart Command into Teleteype (eg. II ES.Restart)? Turning On/Off the whole modular System is very annoying, especially in live situations?

Or is it another way to stabilize Earthsea?
I cannot imagine that I am the only user with this kind of problems, any good advices.


@tehn: It is definitely independent from the connection to Teletype. I disconnect the cable and after a couple of minutes (~1-2) without playing, it runs into the issue. :scream:

it was completely frozen and it needs a longer phase of power down (10sec) to heal it. Several short off/on cycles did not help.


again, only a couple people have had this problem. one was fixed by replacing the unit, the other was completely nebulous and seemingly case/power related and replacements didn’t fix the issue. i’ve never myself been able to replicate the issue. e-mail info@monome.org and we’ll do a replacement, see if that fixes it.

just to confirm, this issue showed up after 2 months of normal working functionality?

The problem exists from day one. But after re-flashing the Firmware is was not reproducible anymore. Yesterday I started do play a little bit with TT and ES, but only the connection from ES -Pos. to TT-In. And since then i got heavy problems. I don’t use any II Commands.

Btw: I checked all available Firmware today and with all it run into the slowdown. II Communication is not connected.
Just a feeling, but i think the problem is faster reproducible if i connect ES.Pos to TT.In.


I am not sure if this is the heavy slow down issue but when I clock my earthsea from teletype every now and then it misses a step and occasionally it gets totally out of the step. After a short time it regains its composure.

Sounds like this - in the beginning you hear it stumbling around and then getting back in step. I did not touch anything, just hit record when it occurred.

I just updated to 1.8, teletype is 1.11. It’s just a two line script clocking the ES on a tripper from MP into the TT an giving a pulse as a reference signal that is running on while ES is stumbling - did this to make sure that it is not the TT. It is the first time I am using a II script. They are all sitting in a ⅔ filled make noise shared system case with make noise power.

Don’t know if it related but when I tried out the help screen function, one LED in the lowest row was not to switch of again unless I powered down the whole case.

have you flashed the newest ES firmware? many fixes were made.

The newest firmware is 1.8, isn’t it? I just did the upgrade and I am vaguely under the impression that it got a little better but the above example is recorded shortly after doing the upgrade (when I just was thinking “ah, now it’s good”).

There is a short latency too while playing it freely - short as in you can play it but notice that the sound is a bit off compared to the grid lights.

got it. thanks for checking.

the remote control needs some investigation-- perhaps the ES update had a negative side effect to this feature.

Thank you, Would be great if this could be solved somehow.:slight_smile:

I am wondering if anyone is experiencing this too - maybe I am doing something wrong or there is a problem in my case setup?