Help, monome devices not recognized in max 7

#1

Hello, after several years out of the fold, I’m finally dedicating some time to ye ole grids. Unfortunately I’ve been through a few os upgrades since I last 'nomed and I fear I may have broken everything.

Running OSX 10.10.5
SerialOSC 1.4
Max 7
40h
256
Arc2

The problem so far:
When I run any of the basic monome patches in max (from the package manager) I get “none” from the device dropdown.

Things I’ve done based on similar problems:
Deleted monomeserial
Deleted all old FTDI Drivers before installing serialosc. I assume since the new startup guide says nothing about installing ftdi after osx 10.9 that serialosc takes care of the drivers?

From the max window:

Any ideas? Thank you!

1 Like

#2

Once you start the patch, try unplugging and then plugging the monome back in.

0 Likes

#3

try this, in a terminal, with device attached:

kextstat -l | grep -i ftdi

i’d be curious to see the output

0 Likes

#4

Thanks Toaster, that didn’t do the trick.

0 Likes

#5

Thanks tehn!!

W/ the 40h plugged in, I got:
150 0 0xffffff7f8323f000 0x7000 0x7000 com.apple.driver.AppleUSBFTDI (1.0.1b16) <139 39 5 4 3>

0 Likes

#6

ok, so that’s the correct driver. still not detected? can you confirm serialosc is running in the activity monitor?

0 Likes

#7

In the activity monitor I see serialoscd and serialosc-detector running

0 Likes

#8

Sadly,
my grid and arc are also not recognized on my new laptop…

I checked: no FTDI files on it.
Installed the linked serialosc file (test patch shows it’s running)

Any thoughts/suggestions will be very much appreciated.
p.

0 Likes

#9

@laborcamp how new is the new laptop? try the other usb port?

try this in the command line:

kextstat -l | grep -i ftdi

@dolza is it still not detecting?

0 Likes

#10

see the image for laptop info:

did the

kextstat -l | grep -i ftdi

no effect.
p.

0 Likes

#11

ok, so the apple ftdi driver isn’t working.

try:

ls /System/Library/Extensions/ | grep FTDI

you should see

AppleUSBFTDI.kext
0 Likes

#12

yup:

but arc still not recognized

0 Likes

#13

what about grid?

just to check, the arc works on the other computer?

0 Likes

#14

yes, both work fine on the older laptop.

0 Likes

#15

check system profiler for any action when connected?

this is stupid, but have you confirmed that other usb devices work in these ports?

the driver is there, and if you see the power-blink pattern on plug, it should work. this is crazy.

0 Likes

#16

the USB ports work with other devices (hard drives etc.)

What exactly should I be looking for in the system profile?

0 Likes

#17

…that entry for monome down at the end is what we’re looking for assuming a grid/arc device was attached to your laptop. If you don’t have a grid/arc attached and you see a monome entry then I think that is evidence that some other (older) FTDI driver is installed (somewhere). When I was having problems way back when one or more monome entries would remain in the USB device tree view after I removed my grid/arc.

With no devices attached, open the system profiler and verify there are no monome entries in the USB tree - if you see one reboot you machine and get back to this point.

Next plug in a grid and select “File” > “Refresh Information” (in system profiler). Hopefully you have a monome entry (this means the IOKit saw your device). If it doesn’t show up I’d try disconnecting it, waiting ~5 sec, and then plug it back in to a different USB port on you laptop. Hit “Refresh Information” again. Hopefully now the device appears in system profiler:

With the device still connected try the following commands:

(1) kextstat -l | grep -i ftdi

on my laptop I get:

159 0 0xffffff7f8477b000 0x6000 0x6000 com.apple.driver.AppleUSBFTDI (5.0.0) DA746E19-3830-34FA-A6E8-5F9AF66B7419 <98 15 5 4 3 1>

…if it doesn’t say com.apple.driver.AppleUSBFTDI then you have some other FTDI driver picking up the device (I’ve found using the Apple driver to be most reliable).

(2) launchctl list | grep serialosc

on my laptop I get:

88814 0 org.monome.serialosc

If the first column contains a ‘-’ instead of a number the serialosc daemon is likely not running (for whatever reason). The second column will hopefully be 0 (status code meaning things are okay).

(3) ls -l /dev/tty.usbserial-*

crw-rw-rw- 1 root wheel 20, 12 Feb 10 19:14 /dev/tty.usbserial-m0000938

…if the device is getting detected (by the OS) there should be a device file, the name will vary depending on which device you connect (the above m0000938 is my arc2).


Out of curiosity when moving to you new laptop did you use the Migration Assistant tool to move all your data/applications from you old machine to the new one? …or did you simply start installing stuff fresh?

I don’t know if it could be related or not but I’ve found the Migration Assistant to be both surprisingly thorough about pulling over broken installs from old machines and not perfect (leaving random things behind if permissions are weird).


@tehn for what it is worth things have been working great for me on one of the new 2016 touchbar 15" MBP. I’ve been using the USB to USB-C adaptors and standard USB cables. Serialosc and hotplug seems very reliable (more so than any other machine I have).

2 Likes

#18

Hi @ngwese,

Thank you for your thorough step-by-step instructions.
I followed the steps, but the devices are still not recognized by Max7.

I am enclosing the screenshot of the Terminal with commands and responses you suggested.
If I understand your comments correctly, it seems that I still have some FTDI picking things up.
I searched my mac for FTDI files and found one in a White Whale folder somewhere, and trashed that. Should I be looking for this in some particular spot?

I do believe that Migration Assistant might have been used, as the laptop was set up at my school, with new software build, and migrated my files from older machine.

Again, thank you for your help, and m looking forward to getting this resolved!
p.

0 Likes

#19

Based on the screen shot you provided of the Terminal it seems like your grid/arc isn’t triggering the FTDI driver to be loaded (which is the step before serialosc even comes into the equation).

When you ran those commands was it the first time the grid/arc was attached after a fresh reboot or had you tried attaching them before? (this may be important to know)

0 Likes

#20

@tehn still no luck, my computer is 6 years old and probably has some weird specific conflict… any other troubleshooting rocks to turn over?

0 Likes