Help out: embed tutorial

what about CodePen? let’s find out!!!

(EDIT: for context -


thx, same…worked, not working-chrome on osx, perhaps file size is not accurate on this machine

peace from california
edit, 1.9mb

true, but only if you intend for your works to have free/creative commons licenses. also, FMA is difficult to work with, browsing and admin tasks.

1 Like

Yeah, I really like what both services are up to, but I find their interfaces confusing

GitHub stuff, it’s a bit long, sorry about that.




(there are a few other combinations too, for specific commits)



1 Like

Folks on this thread, could you take a look at the current Junto thread (URL below). People’s Soundcloud links appear to not be auto-embedding. They’re just appearing as links:


soundcloud test:

simply typed on single line, with line break before and after:

1 Like


1 Like

tumblr test:

1 Like

Agreed! We’re trying to make it better – would love to hear your ideas! DM me or hit me up at Thanks!

1 Like

The above links worked for me

1 Like

Instagram for mini videos>


That is gorgeous. Did you use tilt shift to achieve that depth of field effect?

thank you @disquiet,
it’s square digital video with the iphone/cinamatic app
henri cartier-bresson


bandcamp embeds will be cool :slight_smile:

1 Like

onebox seems broken for vimeo videos. i can’t get it to display the embedded player. unlike @jasonw22’s example from above, my vimeo embed turns out like this, despite properly copy/pasting the URL on its own line with the space after it:

right now, onebox just pulls the video’s title card/info with an outdated cover image/cache. it merely creates a link that launches a new tab instead of providing a usable player. at first, it did this with the kria video jason linked above, but as i was typing this report, the incorrect external embed snapped back to the proper onebox player.

similarly, when i browse through the revisions at the top of the post i was trying to make, they display the proper onebox player in the snapshot, but the actual page render has the incorrect version. not sure what’s going on.

i’d guess something changed in the latest discourse 1.7 beta since august.

As I see this tread: On the longer threads which are full of videos as the classical music or the latest listening shares, every now and then (I think when I scroll back and forth on the time line) all previously played videos suddenly start to play simultaneously and have to be stopped one by one again.

This is sometimes a surprising and interesting effect, especially when you don’t notice that there is actually playing more than one due to the nature of the music that is shared. But often it is a bit uncomfortable too an I wondered if I am the only one experiencing this or if I could prevent it somehow.

I am on the latest El Capitan /w Safari 9.13

i think i figured out the onebox player issue. it may have something to do with how long it takes vimeo to get meta and api stuff into each video page, and cached. if the URL is posted soon after uploading the video, then it’s not going to get properly embedded by discourse’s onebox.

i’m not sure if there’s a way to force discourse to update the cached data that it’s scraping to generate the onebox embed, or if it’s necessary to just wait for vimeo to finish transcoding all the various versions, or whatever else it does in the background after a video is uploaded, saved, and “made available.”

at least, that’s my guess as to how it all works. it’s a giant black box to me, on both the vimeo and discourse sides.

case in point: i got my video to show after including vimeo’s iframe embed code, which is not rendered by discourse, along with the http URL in the post and re-saving it. i deleted the useless iframe block, re-saved the post, and the video remained properly oneboxed and playable.

What’s the situation with instagram embeds? I often use them and they seem to work perfectly, but then when I return to threads later the image is broken. This post I’m replying to being an example of that for me.

Usually I find if I edit the post and re-post it then the Instagram embed works again (for a while).

1 Like

yes, idk :slightly_smiling_face:
used to be embedded
now a link, that works here on my phone
cooler if it stayed embedded, imho

1 Like