Help - Problem with grid 128 and Ableton

Hi! I’m having problems with grid 128 and Ableton (9.6.1). I’ve installed the last version of Terms and everything is OK except when I tried to use more than one Terms instance in different channels. It’s like they overlap in grid.

For example, I put Step in one track with an instrument and it works fine. But when I do the same in another track, the two sequences generated by Step run at the same time in the grid, making it unusable.

I owned a grid 64 a couple years ago and didn’d have this problem, I could run Steps or Flinns (etc.)
as much as as I wanted.

Does anyone knows how to solve this?

Thanks!

No, actually. I’ve only successfully used one of each terms app at a time. (Which I got used to and forgot it was a problem.)

Same here. Only one of each at a time.

Same problem here. And I seem to recall reading in the documentation that one should be able to use multiple tracks.

Yeah, sure, actually I used a 64 years ago and it could handle two or more tracks at the same time…

I’ve made an update to 10.11.6 and the problem persist. I’m using Ableton 9.

What’s your setup?

I tried without using the auto-select track but I was unable to do that. Does anyone tried that?

Thanks!