Help running grid + arc in Processing on Ubuntu

Does anyone here use the grid + arc on vanilla Ubuntu? Could anyone help me with some explicit directions on getting things up and running? I tried following the Linux setup doc and downloaded the listed precompiled using the terminal commands listed…but unfortunately I can’t get any further than that. I’m trying to simply use the grid + arc with Processing. Based on what I’m reading in the Linux setup, I guess I am stuck on getting serialosc running and making any necessary communications with the server to establish connections. Thanks to anyone who can help!

Also if anyone has any thoughts/insights/comments on using the grid + arc with Supercollider on Ubuntu I’m interested to hear about that as well!

I dont run linux that often (mostly win10 and osx) but did you look at the grid studies pages?

I use grid and arc with SuperCollider with my own SerialOSCClient is not well tested on Linux but should in theory work.

good infos about sc/linux here:


I’ve been trying to work through the detailed steps instead of simply installing the prebuilt package. I guess this is pretty basic but…I am getting stuck (in the linux setup guide on “Next, plug in your monome and run serialosc from a terminal. You should see something like this:”. When I type ‘serialosc’ I get ‘serialosc: command not found’. Does this indicate something went wrong when I was building serialosc? I tried typing that command in the libmonome directory and the serialosc directory as well as in the first directory (when you initially open the terminal). I’m still new to Linux/Ubuntu, but I know there is usually some kind of prefix command…I’m having trouble figuring out what that may be.

I’ve also switched to linux just a few weeks back.
I’m running Linux Mint Cinnamon atm.

I experienced the same problem, but when I enter

sudo serialoscd

instead of


the monome shows up for me.

Actually, there is no need for sudo.
serialoscd is the actual executable name.
If the monome is not detected while serialoscd is running, make sure your user has access rights to serial devices:

  • type groups to see what groups your user is in, and see if dialout is listed in the output.
  • if not, sudo adduser yourUsername dialout then log out and back in to be added to the group.

Fantastic! Using the combination of ‘serialoscd’ and the dialout add group, I was able to get the grid and arc recognized in Processing and the grid in Supercollider.

Overall as a new Linux user I am both pleased and frustrated (with Linux). I love all the flexibility and the different open-source options available, but these nitty gritty things can be difficult to sort out sometimes, and I just don’t have enough of a background to know things to try (bluntly, if I don’t know the commands exactly I am basically out of luck ha ha)

Thanks again!!!