Help: Teletype outputs semicolon ( ; ) instead of colon ( : )

When I type a colon (e.g. for L 1 4 : CV I 0), TT instead prints a semicolon character ( ; ). I’ve had this happen several times before and random pressing of the Num Lock and Print Screen keys helped fix it. Now it happened again and I can’t get it back to working normally.

I’m using TT with firmware 1.2 and the original keyboard. Unplugging the keyboard in various ways doesn’t help - I’ve tried unplugging during operation, powering the module on without the keyboard, then plugging it in, etc. I don’t have another keyboard here, otherwise I’d try that. Power-cycling the case (which I made sure has enough power) and loading different scenes also don’t get rid of the issue.

Has anybody seen this before and has a reliable fix for this? Am I missing something obvious that’s an easy solution?

I also don’t have a USB A to A cable here to update / reinstall the firmware, but I guess getting one and then trying it would be an option?

Any help would be greatly appreciated!

Perhaps there’s an issue with one of the shift keys? Is the behaviour the same if you hold either left or right shift key?

indeed, i would try the keyboard on a computer first, then try another one. I have seen keyboards do the weirdest stuff over time.

yeah, this kind of behaviour sounds much more like a connection or keyboard issue rather than a firmware issue - i doubt reflashing firmware would make a difference. definitely try what’s suggested above first.

@Galapagoose @ermina @scanner_darkly thanks for the tips, will try these next. I suspect it’s the keyboard as well, perhaps the actual semicolon key - when I hold down shift and then continue to hold the semicolon key it will sometimes give me colons after a while, like so:


I’ll find another wired keyboard and try that.

So I tried the keyboard on my regular computer, where the issue continued at first. I then tried using the right Shift key a couple of times and at some point it went back to working normally again, meaning I can type the colon. After plugging it back into TT it was back to semicolons instead of colons, but I again hit the right Shift key a couple of times and it eventually switched to working again. So I guess the issue persists, but it’s manageable at the moment. Anyway, thank you for everyone’s help!

sounds like a defect keyboard

email for a new one