Help with Fresh Install Verification Failure

Hi All,

I’ve been away from my Norns setup for quite a while - some 2 years and now have time to update and get back into things.

I decided I need to update from 2.4.0 to 2.7.0 the latter requiring a fresh image.

I’m on Windows 10 and tried Balena-Etcher first - that took the 8 minutes or so to install returning and error almost immediately when starting the verification stage. I then tried Imager, same deal this immediately gave an error message on verification … ‘error reading from storage SD card may be broken’.

Suffice to say prior to attempting the update, my Norns appeared to be working fine - connected to the new WiFi setup, still had all my old files, had the low battery message, but all seemed fine.

This is s true Norns updated to the 32gb model.

NOW nothing, the poor ole thing is completely dead - what now!??

1 Like

Did you flip the switch?

Oh yeah switch flipped accordingly

Thought I’d try another img file - so downloaded the last one that WAS in Norns - 200424. And now the PC can’t see Norns at all?
Re- installed rpiboot setup - this time still can’t see Norns

So kind of in a worse position

Just a thought - does the low battery have a part to play in this?

It didn’t seem to be charging very well yesterday - I was on a mains feed the whole time until trying the new intended full re-fresh

The white light comes on and stay on when the switch is flipped prior to installing the image

So what I appear to have is a situation where the PC can’t see the Norns - neither Etcher or Imager.

I’ve recently have access to a Mac Mini - and the MAC via Imager can’t see the Norns either - nothing apperas in the STORGAE section.

So I took the install instructions route - where it says if Etcher / Imager doesn’t work for you - take the command line route. I not super familiar with MAC but can folow instructions. I got as far as here…

mac os

this assumes homebrew is installed.

brew install libusb git clone --depth=1 GitHub - raspberrypi/usbboot: Raspberry Pi USB booting code, moved from tools repository
cd usbboot

I get as far as the cd usbboot but when I enter make I get this error…


cc -Wall -Wextra -g -o bin2c bin2c.c

./bin2c msd/bootcode.bin msd/bootcode.h

./bin2c msd/start.elf msd/start.h

./bin2c msd/bootcode4.bin msd/bootcode4.h

./bin2c msd/start4.elf msd/start4.h

cc -Wall -Wextra -g -o rpiboot main.c pkg-config --cflags --libs libusb-1.0 -DGIT_VER=“"21ba5119"” -DPKG_VER=“"20221215~105525"”

/bin/sh: pkg-config: command not found

main.c:1:10: fatal error: ‘libusb.h’ file not found

#include <libusb.h>


1 error generated.

make: *** [rpiboot] Error 1

rigbyallen@Rigbys-Mac-mini usbboot %


and at this stage can’t run the sudo. ./rpiboot as get this
sudo: ./rpiboot: command not found


What USB cable and where are you plugging it in to the Norns?

email and we’ll get you taken care of

Cheers! Will do thanks

Hi All,

While I was contemplating my next move (many thanks to tehn, really good to know that if all else fails, there is a route to recovery via the factory so to speak) I decided to have another crack at getting the latest image up and running.

The lead… ah! the usb cable. Quite right I was using a 28 swg not a 24 swg, so I corrected that AND then dug out my old Macbook AIR (2014 - BigSur) and ran through the flashing process. I did give the Run/Disk switch a good dozen wiggles to ensure contacts were operating correctly (a hint from somewhere in LINES) and Hey Presto! The Imager worked like a dream flashing away followed by the verification - holding my breath - but all is well.

Now up and running

1 Like