Help with monome grid kit troubleshooting

Hi. I’m not sure if this is where to post issues, but I need some help troubleshooting my new grid kit. Not all buttons on the grid are lighting up. I ran a few apps in monome sum, but only roughly half would light up. I suspect that the issue is probably due to the orientation of the leds, but looking at the led, it is hard to tell the difference in orientation. I’ve put together one of the old kits before which had through hole leds rather than the surface mounts. Those were much easier to assemble. I guess my two questions would be:

  1. How do you tell which way the led should be positioned? (using white leds purchased through monome)

  2. What app will allow me to light up all buttons on the grid? I tried monome_test, but the grid will not light up at all. The app recognizes my device, but will not light up. I was able to light up some of the leds with monome sum.

Any help would be greatly appreciated.

I used the indicated leds by the BOM, if I recall correctly they had a small golden dot indicating the Anode!, a magnifying light is strongly recommended btw
Regarding a patcher for lighting up it’s quite straightforward if you check grid studies, I might have a patcher around

replied via e-mail-- but more than likely the issue is solders or LED orientation. sometimes it’s difficult to identify the orientation.

Thanks for the feedback. I’m about half way done fixing the orientation of the LEDs, but still looking for an app that can test which LEDs work and which do not. I am able to get parc and flin to work, but monome_test will not work for some reason. The application recognizes my device, but will not light up or respond to pushing buttons. Monome sum works sometimes, but often ends with my computer crashing or recognizes the device but will not allow me to select the size of the grid. I’m not sure if these issues are due to solder or LED orientation, but would like to use an app already created to test LED orientation.

If anyone could point me to an app or a solution that will allow me test my monome kit, I would greatly appreciate it.

use max 7. if there is a serialosc.maxpat in the same folder as monome_test, delete it.