How i installed Monome 40h on Windows 10 successfully ... ;)

You know it. Something doesn’t work. You search for a solution in the web and if you’re lucky, parts of all threads you read fits together to a solution.

So, here’s mine to get a Monome 40h (kit) work on Windows 10 (latest 64bit):

  1. Install MonomeDevice Installer (for Windows of course) ->
  2. Install Bonjour ->
  3. Install Max 7 by Cycling 74 ->
  4. By now, the serialsosc service isn’t working correctly in Win 10 as you can read here: SerialOSC installation Windows 10 64bit
  5. So, last step is -> Starting serialosc manually. You can find the serialoscd.exe in C:\Program Files (x86)\Monome\serialosc.
  6. Here we go: Monome is plugged in, start serialoscd.exe (and ignore the mentioned debugger mode ;), starting a maxpatch like Monome Sum (, Choose your monome in the upper left corner and start smiling :wink:
  7. Hotplugging doesn’t work at this time cause the service doesn’t work correctly. Therefor you have to exit max (and sometimes serialosc, too) and start them both again to get the monome 40h work again with another patch.
  8. If you like you can use some patches from the new monome package for Max 7 -> Max 7 package manager (In the package manager, you have to type in “monome” in the search bar and install it … )

Do not install MonomeSerial or a Serialosc Maxpatch. Both are not needed any more! Except you like to use some old patches, which depends on MonomeSerial. If you are interested in them, i found a list of these old patches here: An interesting patch for example is the Brontologik Patch by Pyrolator: But beware: I didn’t tested how to get the monome work with MonomeSerial again on Win 10. That’s another story … ;).

Good Luck!


you can use monomebridge or pages to connect with old monomeserial patches

1 Like

Ok. THX! Didn’t know that …

good catch with brontologik! remember having lots of fun when I had a 256, if not my favourite app for 256 :slight_smile: what a beast! (also when bloating the JVM for 2 minutes while launching :smile:)

1 Like

Your pages-link seems to be offline … ;( Here’s is another link i found for pages:

Yeah thought so … ;). Unfortunately there is no 40h/64 version of it. I tried to get him to do it and he answered very kindly … that he wil not do it … ;(. If i ever get a 256 i’ll give it a try!

Hi There,

I’ve been working from this guide:

to try to get an older grid i got second hand working on a new windows laptop

I’ve managed to get serialOSC running and connecting to ports. however when I connect the grid, the lights all light up at half brightness. and when i run monomeSum, I’m not seeing any responses in the program. I’ve tried a couple of different monome apps but none of them are receiving any input from the grid.

I tried using an older serialOSC max patch in my copy of Max6, but that won’t even find the grid. i’m unsure as to how to proceed?

thanks so much

Sorry to revamp an old thread but I’m having an issue with a 40h old kit from 2009 using it with Windows 10 64bits

I installed serialosc 1.4.1 this is the latest version right?

Using Max patch like mlrv2 or m4l patch like Mark eats clip after some time I still using buttons but leds stops to feedback what happening

Nope, newest is 1.4.2 which specifically fixes that problem. It was posted by @artfwo here at a thread. don’t know if online at the main page. Let me know if you don’t find it, then I would search and post from the pc

parafy, I need to ask for some help related to your post.

I got steps 1 - 8 done and my Monome Grid 64 is not recognized in the SmallBatch of Monome Sum. At least in the window I can not select my monome.

My hardware and software setup is a Thinkpad with Windows 10.

I connected the monome with lights flashing at the beginning and ran serialoscd.

Is there any common mistake or any wrong configuration possible?

Thanks in advance.


PS C:\Program Files\Monome\serialosc> ./serialoscd
[!] running as a non-service
serialosc [m64-0383]: connected, server running on port 19797

seems to be working again.

What I did: uninstall serialosc - reinstall serialosc - restart system (reboot).

The serialosc service is not listed in the services, but can started manually.