How to sync two USB MIDI hosts

i use an irig midi that plugs into the ipad and has midi in out & thru
or you can get an adapter of USB to Apple with a USB UNO which works on everything :slight_smile:

1 Like

Thank you. I figured it had something to do with host/host.

1 Like

Is this true? I am hoping to clock my modular from norns (fates variant) and have the norns be the master clock sending midi over a specific channel to a MI CVPal to do so. So far I’m not having a lot of luck, is this something that is script-specific?

Several times I clocked the modular with less concepts and cvpal set on channel 13 or 14 (before crow landed, that is).

While the norns is capable of sending midi information pertaining to the clock out through midi, it is incumbent on the script to apply that information. Basically, the script needs to take the clock and send the pulses out through a specific channel.

In other words, this idea you have COULD work, as long as the script and your MI CVPal are in agreement of the channel upon which the clock would be.

Try taking a look at the scripting of the less_concepts script and see if you could pull that portion out. Its a pretty complex script and it can be tough to pull these kinds of things out. I am not particularly adept at it yet, but have been learning Lua in an attempt to get better at it.

Might be worth looking in to adding the ability yourself. It’ll take an investment of time, but pay back dividends!

1 Like

at its most basic, it’d be:

local m
local clock_id

function clock_tick()
  while true do
    clock.sync(1/(4*24)) -- 24 ppqn

function start_clock_out()
  m = midi.connect()
  clock_id =

function stop_clock_out()

just drop that in your script, call start_clock_out() when you’d like, and call stop_clock_out when you’d like.

while i’m fairly confident the above works (i pulled it out of my script Cyrene, which is a bit more complex), it’d be cool to not require it. i see that norns’ global clock has a “midi out” option, but it didn’t do quite what i expected when i turned that from “off” to “port 1” or “port 2”. i’ll have to dig around in the code a bit to see what it’s trying to do (or someone else who knows about it could reply here and educate us!)

EDIT: we’re DMing about this – you shouldn’t need any code to get clock out working; while in any script, go to params > clock > and route “midi out” to whichever device you want. that’s not working on my end, but :man_shrugging: it may work for you!

this should just change which MIDI device in the DEVICES > MIDI list gets the clock signal – the ports are the 4 slots. is this not working as expected?

i don’t work with a ton of MIDI gear, but I wonder if some improvements couldn’t be made – at the very least being able to send MIDI clock signals to multiple destinations seems like it’d be helpful?

Hi - I can’t find another thread on this so here goes …

Anyone else with two Norns devices working together?

I’ve a Fates and a Monome Shield I’ve built that I’m hoping to partner with each other.

Audio is straighforward but midi less so. Any thoughts on how to get them speaking midi to each other without meaningful intermediate hardware (like a pc)?

1 Like

Does it have to be MIDI? If so then you need to have some additional hardware to act as a USB MIDI bridge, because norns is a USB host and cannot act as a USB device. If not, maybe you can just use OSC? Pretty much all norns settings and script parameters are accessible via OSC.


some references from up thread:

But as @csboling mentions, you can wirelessly communicate between the 2 devices with OSC. This would likely require some scripting to add to existing scripts.

You can also use Link to sync clock between the two (if the scripts in question use the global clock system)

1 Like

thanks - think i’ll try build a simple single arduino/similar board that can be detected as a midi usb client by norns #1; with midi DIN sockets hooked up to the arduino rx/tx to then connect via a standard USB-DIN midi cable to norns #2

since standard USB-DIN midi cables are kinda cheap, I think you could also just use 2 of those with DIN-to-DIN adapters. Pretty sure that works although I’ve not actually tested it.

1 Like

yes definitely a possibility!
… though i have found not all usb midi din cables are equal quality. some are more usb compatible than others

Any other solutions out there to get norns and mac/ableton to play nicely together?

Link is available now for norns. For me it’s good enough for most applications but it isn’t midi as far as control is considered .

1 Like

some relevant bits on getting MIDI events from Live over to norns via OSC: Norns — receive OSC notes (from Ableton)

I am so confused — any help so appreciated. I bought two reamp boxes and DI to get audio from my interface to Norns and my guitar pedals and back into Ableton for audio. Now I want to coordinate for it to work allowing both MIDI in and MIDI out to/from Ableton.

Example: I want to use Awake to push MIDI notes to a VST synth in Ableton.

Example 2: I want to use MIDI signal from my Komplete Kontrol 49 into Ableton push midi to Norns for any of the synth options available etc.

Hope this makes sense, I am brand new to this.

Since norns is a midi host and your computer is one too you need either two USB-midi interfaces connected back to back or something like okyeron’s 2host (if you search the forum for “norns usb midi host” you’ll find detailed answers).
I use a 2host between my Fates and Ableton or Max and it works perfectly :slight_smile:

Awesome thank you! Do you have any USB to midi interfaces you recommend to do this with? I’m guessing I would need one male and one female right?

I don’t have a Kontrol, but as long as it’s class compliant, you should be able to plug it straight into Norns and then navigate to system>devices>midi. It’s a good idea to assign it to be device #1.

I use an Arturia Keystep in this way, and it works great.

What kind of audio interface?

For what it’s worth, you might try simplifying things by going straight out of your interface into norns. norns accepts line level signals, which is most likely what your interface is spitting out. Same thing going back in- you can probably try without the direct boxes.

Give it a shot. If it works, then try adding some pedals in. That’s where you might hit a signal level issue, but I’d cross that bridge once you’ve conquered the I/O thing.

1 Like