I actually ported something to m4l


#41

@Holl1f3ld,

Hey if it works, good job on hacking it!

If it doesn’t I could take a whack at it. I haven’t messed with any max/m4l edits in quite awhile now.


#42

Anyone got some pointers for porting M4L to a standalone Max patch?
Is it as simple as copy&paste?
Have a few M4L patches that I like and want to move out of Ableton.


#43

also got it working with @elquinto’s small batch and quadrants and it actually works better this way for me. being that raptor only has a 64 version and I prefer to use my 128. The autofocus although cleaned up a bit makes everything very laggy and feel clunky, whereas within batch and quadrants its smooth. :smiley:raptorx auto 2.amxd (1.3 MB)

I always loved this very functional and fluid app by pewt. I attached this version, maybe someone might be able to work out whats up with the autofocus. Possibly @jasonw22 can add this to the repo.


#44

Let me know when things are working as expected. I’ll also mention that anybody can create a Github account for free public repositories.


#45

@myecholalia,

I think it would be pretty simple. Basically copy and paste everything except the m4l midi in stuff and go from there. Might not be that simple but it could be.

@Holl1f3ld,
Good to hear you have a setup that’s working nicely for you!


#46

Hey guys, found the midi_slide.amxd patch really useful but noticed it didn’t have autofocus, so have added it: midi_slide FOCUS.amxd (208.5 KB)

This is super hacky but works for me!

My next job is to add 8 banks of 8 sliders (I’m on 8x8), with a selection row along the top.


#47

Hi there! I just found this really useful app for Monome(the raptorx app) but I have tried the latest version and doesn’t seem to work for me. The problem is that I don’t know how, but the app recognizes another hardware (mk and some numbers) as well as the monome, and when I click on ‘‘connect’’ to the monome 64 doesn’t change the connection. I have tried the @Holl1f3ld version which works, but the loops don’t work properly: they last like 4 beats or less to automatically start to loop (not 8 beats) and they don’t play any sound, just the visual feedback on the monome like it was playing. My serialosc version is 1.2 (for me by now the most stable one for apps).

I would really appreciate some help in the issue, and thank you for your attention.