I2c connected Telexo power connected the wrong way

I finally plugged a module in the wrong way and per @bpcmusic’s request in the TELEXo manual (If you do screw this up, let us all know what happens. In the meantime, we’ll be looking for the swirling vortex in the sky.) I am here to tell the story…
I plugged the telexo in the wrong way. It was connected to the teletype busboard via i2c. A Just friends, ansible, crow and w/ were all connected to the busboard.
Now the busboard seems not to work. The teletype will power on without it but not with it. i2c works for modules connected direct to the teletype except the telexo. When the telexo is connected over i2c the teletype will not power up (with or without the busboard) and hence I cannot be sure if the telexo is working or not.
The question… does the busboard have Reverse power protection? I checked the BOM on github and See the SMD resistors but I thought reverse power protection might be diodes. On visual inspection it looks like the SMD parts are a bit odd looking. Would the Telexo’s power protection also have blown? I can’t see them or can’t see anything unusual.
I appreciate someone’s advice so that I can instruct the repair appropriately and get both repaired if needed.
Edit to add that I realise that W/ is not receiving power either.
Td;Lr So the broader question is can an incorrectly connected module to the power rail cause damage to other modules connected via i2c?

Yes, that could easily damage other I2C modules. The I2C lines are hooked directly to pins on the microcontroller and the only protections will be whatever built-in, current-limiting resistors are present.

The Teletype backpack is a very simple device consisting of a voltage regulator and two pull-up resistors. It sounds like you have fried the regulator.

You could have damaged your PSU but if these are the only modules not responding then you need to unhook the I2C lines and try again. If they are still not powering up then you have some issues… :cry:

2 Likes

Is the Teensy still working ? Is it recognized if you connect it to the Arduino ide (not powered by the eurorack, usb only) Do you have a multimeter for checking voltages on the bus board, on the txo etc ?

Telexo also doesn’t work when it’s connected directly to TT ? If so, there’s another issue on this one too, not only the voltage regulator of the busboard imo.

Yikes! I would look at both the busboard regulator and the Teensy on the TXo. Both are easily replaced. Repairing the Teletype gets more complex, but still doable now that all of the details are open-source. Let us know how it goes. Good Luck! :slight_smile:

Thanks for the responses. I unhooked the i2c lines and w/ is definitely not powering on. I moved it around and tried another power rail but no luck.
As mentioned above Teletype still works but not when the TELEXo is connected via i2c so I can’t send the TELEXo any commands to see if it is working. I’m not able to check if the teensy is working but I have taken it, w/ and the busboard for repair. I took the schematics from github and they will let me know if they know what to do. All other modules seem fine. I emailed Sam at whimsical raps re the w/ repair for some guidance.
Ill let everyone know how it gets on

1 Like

@bpcmusic Brandon, the below is the feedback from the local repairer who has been doing some testing. Would programming the teensy be something that I could do (having no idea at this stage how its done) or something that would require your involvement? I saw this on your website but it appears that it is not available https://store.bpcmusic.com/products/telexo-upgrade?variant=5636161699871 !
"Have found the Arduino Teensy is dead and a part on it if getting hot! See attached circled

Checking the schematics, it’s a LP38691 3.3v Regulator, I removed it and found a short still present on the Teensy board so whole teensy 3.2 board will need replacement and no doubt re-programmed.

I have check parts on the purple board (with all the headers) and it seems to measure normal.

Have not checked the W module

Can you obtain one of these teensy boards?"

Thank you all for helping

I’ll PM you. Should be able to help with the Teensy. :slight_smile:

1 Like

I should say flashing a Teensy is very easy. The binaries are up on my GitHub:

Installation instructions are here:

Step 8 is key.


All you would need is a working 3.2 Teensy with the appropriate headers installed, USB Mini cable, and computer. :slight_smile:

There is something wrong with my telexO. It seems to leak audio when the envelopes are not triggered. The code I am using is:
M
$ 1

I
L 1 4: TO.CV.SET I V 5
L 1 4: TO.ENV.ACt I 1
L 1 4: TO.OSC.N.SET I + 60 rand 12

SCRIPT 1:
Every 2: TO.ENV.TRIG 1 1
Every 4: TO.ENV.TRIG 2 1
Every 8: TO.Env.TRig 3 1
Every 10: TO. ENV.TRIG 4 1

and this is the audio I get.
Anyone any suggestions where to look in soldering or other things? :slight_smile:
Thanks.

try setting the CV offset to zero by executing L 1 4: TO.CV.OFF I 0
also try calibrating it with TO.CV.CALIB op (see the op description in the teletype manual for calibration steps)

Thank you so much it did the job! :slight_smile:

1 Like