I actually really liked the previous delay behaviour (which sounded less like a typical delay when changing delay time, more subtle/weird). I looked at the code changes between versions and it looked like it was quite involved so I don’t suppose it would be easy to add this behaviour back (even locally) ?

Anyway, great script :+1:


yeah @danbond you have some real magic there with navigating the sun :slight_smile: :partly_sunny:

you can pretty easily go back to the old version by just installing an earlier release.

but I think the main code changes for the delay are the following:

  1. old version had this line in the engine:

which, in the current version has changed to


basically I was having trouble making the delay sound smooth, and found that (in the new version) the lag of 0.2 seconds worked better. but in the old version, the lag is shorter and also the range of the delay is shorter, which brings me to…

  1. the old version clamped the delay time to between 0.15 and 0.3 seconds. the new version clamps betwen 0.05 and 0.5 seconds (this line). I used a smaller range previously because I was having trouble with getting the delay smooth…small ranges mean small changes which sounded smoother.

maybe play with those parameters? you can change the range of the delay to be really small and it will give really subtle bumps in frequencies then. and you can play with that line in the engine to do weird things to the delay (add in more randomness / lfos / etc etc). supercollider is really fun in this way to tweak and morph into a particular sound. if you go this route, feel free to ask questions as I’m happy to guide :slight_smile:


Oh wow the new water animation is stellar! I completely tranced out just playing and staring at the sun’s reflection dancing on the waves.

1 Like

:slight_smile: I completely tranced out about updating this thread with the update…



Looks even better!!!

1 Like

This script is amazing! I tried it this morning for the first time and it is glorious ambient goodness. Great work!

I played around a bit again today, brought out the Microgranny to help.


Hey! Love how this sounds, one tiny bug - Low pass filter closes when you turn the knob 2 CW instead of CCW, which is just a little bit unintuitive, would it be possible to swap the direction of values for knob 2?
Thanks a lot!

What a lovely sounding synth!! thanks a lot!!
I just miss some thing, maybe you could consider it for a future realese??:

-Sustain pedal (would be great holdonh the notes with the pedal)
-Mix amount parameter for the delay
-external input (imagine processing noise or other sounds thru filter/delay, mixed with the current synth sound or just using Icarus as an FX)

Thanks for the fun!!!

1 Like

yes! it is possible to change the direction of the knob - just remove the -1 from this line in the code. actually I tried it that way initially but I prefer that CW raises the water level which “washes” out the sound (at least that’s how I think about it). but I totally get that it can be weird to think of CW as closing (vs opening) a filter.

oh these are cool ideas!

the external input is actually really really easy. you can add one line right here with the following:

in = in + SoundIn.ar([0,1]);

that might sound really cool! I haven’t tried it yet.

sustain and delay mixes are good ideas too, but a bit more involved. I have them on my radar though. (I’m trying to feed multiple birds with one scone by implementing this for this synth and future synths so I’m still thinking over a modular way of doing these both).


Thanks!! tried but don´t seem to be working… :frowning:

1 Like

did you restart the norns to re-compile the engine?

also you might want to put it after this line instead, because otherwise it will be enveloped by the note (unless you want that, so you only hear the incoming sound when a note is pressed down…)


ops!! no!! restarted and now its working perfect!! great as an FX!

1 Like

this script has been one of my fav’s since first receiving my Norns
thanks again @infinitedigits

theres a bug im experiencing where the Sun floats all the way to the right and into the water by itself. I can rotate E1 ccw to bring it out and back to the left but it just dives back in after release. im suspicious maybe K1 button or something else is getting sticky somehow? lol
as im typing this I just discovered it will do the same behavior in the opposite direction as well so I dunno…also checked to see if there was any accidental mappings but there aren’t - could having the MIDI channels set to All instead of a specific one be causing this behavior?

also sometimes Icarus requires a reset to recognize properly that MIDI ch 1 is no longer what it used to be (maybe a sensel morph or something else) and now something else (porto 1 from the USB - USB Hub from sevilla) when using ableton to send MIDI into Norns. it just leaves it blank until like I mentioned a reset of the settings

that is pretty much it, everything else is pretty smooth with all my experiences in Icarus land

anyone remember that game on NES called “Kid Icarus”, that shit was tight


Love this script. Thanks for it! I am +1 on the delay mix param.

1 Like

Has anyone used the LFO’s on a Digitakt for this script? I’m totally lost when it comes to MIDI and I’m trying to figure it out on this.

Not exactly what you are asking because I’m using Digitone LFO not Digitakt, but:

I hope you can see the setting on different Digitone MIDI screens. I’ve enabled the first MIDI track, and set it to channel 1. CC1 has a value, and the LFO is set to wiggle it.

Sound is direct from Icarus, Digitone on MIDI duty only.

1 Like

@xmacex That seems straight forward but how do you have Icarus configured, I think that’s where I’m running into trouble. Thanks for taking the time to shoot a video btw, much appreciated.

1 Like

Does this photo from my Parameters help? I used the learning function to set it up. It picks up Sound Controller 1 at CC 70 from Digitone i observe. I find MIDI cc a tad confusing since i usually kind of just to like to work with the CC control numbers directly starting from 0 rather than with the MIDI standard semantics, but yeah learning does it.

(PS the K1+K3 shortcut is gold. Also MIDI Monitor is gold. Loads of gold in norns land! :1st_place_medal:)

Sorry for the delayed response. IVE GOT IT WORKING NOW! I think I was over thinking before. Thanks a million for your help. 8 channels of 2 lfos… time to go nuts…


Actually no. I wrote that message, everything was working fine, I tried some other parameters (one at a time, never at the same time and always with the same CC value) and I lost it. I tried going back to the lpf, still nothing.

1 Like

Hmm ok strange, glad to hear it worked for some time, so you know you’re doing everything right. I’m not sure what could it be… not an unreliable physical connection?