Initenere

Do you mean delete Initenere and reinstall? Or both that and mxsamples? Sorry for dumb question

1 Like

Initenere with mx.samples requires alterations to the code which results in conflicts with the version in Maiden. So if you want to be in line with the ‘official’ version you should delete and re-install. This would probably not help though since the script hasn’t been updated for a long time. Probably better to try and capture the maiden output when it crashes and we can look at what’s going on.

1 Like

Gotcha. I’ll have a play around asap and report back. Thank you!

UPDATE:
Seems to be more stable now. But I’m getting notes that just don’t seem to fit in the scale playing every now and then. Have looked at params and can’t figure out why this is happening.
I have selected F Minor Pentatonic. Sounds great most of the time, but here and there a rogue note (?) Any ideas?

Hey friends,

Getting a missing polysub lib when trying to start up initenere after updating to the latest version of Norns. Guessing this has to do with some of the restructuring of where core engines are packaged in this latest update, but so sad that I can’t run Initenere (a favorite script by far!) right now : ( Is there anything I can do to quick fix this?

@Brett_Gershon, maybe this thread will help: Missing lib folder / Polysub

:heart:

1 Like

If you are running the latest update you’ll need to note that @tehn has depreciated the old WE folder which housed the polysub engine, you need to edit the script.

It’s in line 53 of the script, change

local polysub = include ‘we/lib/polysub’

to

local polysub = require ‘polysub’

Note that WE has been removed from the library in Maiden and you SHOULDN’T install it manually if you have, removed it as per @dan_derks suggestion in the original thread for the update as you’ll get a duplicate engine error.

That will hopefully get you back in action. I’m not in front of my Norns now so can’t check this myself, but think that will do it.

6 Likes

Thanks! Will give a try.

1 Like

Hey. Don’t have a norns anymore. Could someone edit the code and create a PR for this fix. Would be much appreciated! Thanks.

Edit. I could of course edit the code myself but I have no way of testing it afterwards.

1 Like

@vicimity sadly I thought that changing the include might fix things, it didn’t.

Also commented it out and tried one of the other engines, but still get the “error: load fail” when trying to load the script.

EDIT: Ok, deleted the script, reinstalled and edited the polysub line. All working again. Should probably take my own advice :stuck_out_tongue:

1 Like

Oh shoot. It totally fixed things on my end.

2 Likes

just changing line #53 to:

local polysub = require 'polysub'

got things running for me. :man_shrugging:

edit: @vicimity i opened a PR

5 Likes

thank you @Justmat. merged the PR so everyone go ahead and update the script.

3 Likes

im getting a load fail when I try and select Initenere
updated norns
deleted and re installed the script
made sure that line #53 was updated and still no go

this is what it looks like in matron when I try to load it, thoughts?

38

39

40

41

42

43

44

45

46

47

– midi & outputs

– route s1. → s4.

– time routings

– interaction of

– sequencers

– scale & notes

matron

supercollider

script clear

script load: /home/we/dust/code/initenere/initenere.lua

SCRIPT ERROR: load fail

/home/we/dust/code/initenere/initenere.lua:53: module ‘polysub’ not found:

no field package.preload[‘polysub’]

no file ‘/home/we/norns/lua/polysub.lua’

no file ‘/home/we/norns/lua/core/polysub.lua’

no file ‘/home/we/norns/lua/core/params/polysub.lua’

no file ‘/home/we/norns/lua/lib/polysub.lua’

no file ‘/home/we/norns/lua/softcut/polysub.lua’

no file ‘/home/we/dust/code/polysub.lua’

no file ‘/usr/local/share/lua/5.3/polysub.lua’

no file ‘/usr/local/share/lua/5.3/polysub/init.lua’

no file ‘/usr/local/lib/lua/5.3/polysub.lua’

no file ‘/usr/local/lib/lua/5.3/polysub/init.lua’

no file ‘/usr/share/lua/5.3/polysub.lua’

no file ‘/usr/share/lua/5.3/polysub/init.lua’

no file ‘./polysub.lua’

no file ‘./polysub/init.lua’

no file ‘/usr/local/lib/lua/5.3/polysub.so’

no file ‘/usr/lib/arm-linux-gnueabihf/lua/5.3/polysub.so’

no file ‘/usr/lib/lua/5.3/polysub.so’

no file ‘/usr/local/lib/lua/5.3/loadall.so’

no file ‘./polysub.so’

stack traceback:

/home/we/norns/lua/core/norns.lua:145: in function </home/we/norns/lua/core/norns.lua:145>

[C]: in function ‘require’

/home/we/dust/code/initenere/initenere.lua:53: in main chunk

[C]: in function ‘dofile’

/home/we/norns/lua/core/script.lua:192: in function </home/we/norns/lua/core/script.lua:192>

[C]: in function ‘xpcall’

/home/we/norns/lua/core/norns.lua:146: in field ‘try’

/home/we/norns/lua/core/script.lua:192: in function ‘core/script.load’

/home/we/norns/lua/core/menu/preview.lua:23: in function ‘core/menu/preview.key’

/home/we/norns/lua/core/menu.lua:143: in function </home/we/norns/lua/core/menu.lua:120>

script clear

lua: /home/we/norns/lua/core/clock.lua:59: bad argument #1 to ‘resume’ (thread expected)

stack traceback:

[C]: in function ‘coroutine.resume’

/home/we/norns/lua/core/clock.lua:59: in function ‘core/clock.resume’

lua: /home/we/norns/lua/core/clock.lua:59: bad argument #1 to ‘resume’ (thread expected)

stack traceback:

[C]: in function ‘coroutine.resume’

/home/we/norns/lua/core/clock.lua:59: in function ‘core/clock.resume’

Luckily, this is an easy fix (I think), as I had the same issue. Follow the simple instructions posted by @dan_derks here: Missing lib folder / Polysub - #4 by dan_derks.

fwiw, @Justmat pushed a fix for this two weeks ago:

updating the script via maiden’s project manager should fix it up for you @0netwo0netwo :slight_smile:

1 Like

yes, i read that and I made sure that line #53 in the code for Initenere was updated
as well as the script itself

this is what the code looks like around the mentioned section, its correct right??
(line 50 - line 68)

local music = require(“musicutil”)

–ploysub
local polysub = require ‘polysub’
engine.name = “PolySub”

–molly the poly
–local MollyThePoly = require “molly_the_poly/lib/molly_the_poly_engine”
–engine.name = “MollyThePoly”

–uncomment below for the bangs
–thebangs = include(‘thebangs/lib/thebangs_engine’)
–local Thebangs = require “thebangs/lib/thebangs_engine”
–engine.name = ‘Thebangs’

–uncomment below for mx.samples
–mxsamples=include(“mx.samples/lib/mx.samples”)
–engine.name=“MxSamples”
–instruments = {}

huh! sorry to make you double back on what you already shared – i can test a fresh install of the script later today :slight_smile:

just to confirm, you’re on 220321 when you click K2 on the SELECT / SYSTEM / SLEEP screen?

nah, it says 220129 above the power percentage
am i in the wrong land?

ah, yeah – you’ll need to re-image your device in order to get updates moving forward. there’s a ton of additional info here: norns: new image 220306. it’s mentioned in there, but make sure you do a backup of your audio and data files :bangbang: :sparkles:
after, you’ll be able to use the standard UPDATE menu to get norns: update 220321.

once your device is on this new foundation, you should be able to run things without trouble :slight_smile:

2 Likes

Hey there, I’m having an issue switching the engine from PolySub to Molly, I’ve gone in & commented out PolySub and uncommented Molly exactly as shown, and the script loads but doesn’t play, is there something basic I’m overlooking? all the file paths seem correct.

Edit: Got it figured out! Just had to look beyond those first 10 lines of code for more instances. Rookie mistake. This is far and beyond my favorite script on Norns!

1 Like