Initial replies not properly marked (Discourse bug?)

When I click reply on a specific post, the editor panel shows that I am replying to the member of that post.

When I post it, my post does not display that it is a reply to a member or post. It’s just the next post in the thread.

If I edit that post, the reply marker shows up.

I believe this behavior is “by design” but I agree that it is confusing.

@codinghorror says:

As for in-reply-to suppression on immediate replies, we tried this both ways and it is very noisy when you don’t suppress the indicator in the following conditions:

when there is exactly 1 reply
when that reply is directly under the post it is replying to
Locality means a lot in conversations, and when one person stops talking and another starts talking, the vast, vast, vast majority of the time they are responding to what was just said.

This is now a site setting, so if you want reply indicator to show up in all cases, flip it on for your Discourse instance. Problem solved.

1 Like

Looks like there’s a setting for it at least :slight_smile: