Is it normal for ansible to freeze after a lot of arc activity?

As @Leverkusen mentioned is it worth having a “sticky’d” and “wiki’d” thread with the latest firmware versions listed.

I can get it off the ground, as I have plenty of time for one handed typing.

this was done back in june btw (EDIT: only ES was done, not the others)

perhaps i can write a little script to scrape the most recent version numbers from each repo? in the meantime i’ll do a manual list at monome.org/docs

another tricky thing is that all modules except TT give no visual indication of what version they’re on, so it’s a bit of a guess whether they’re up to date or not.

1 Like

There is also this change to libavr32 that @scanner_darkly made.

As far as I know it’s not included in any firmware yet. @scanner_darkly is that change ready to be cut into all the firmwares?

as @tehn mentions it’s included in the latest ES release, but not others yet. ideally i would prefer to make sure all known earthsea issues are resolved before we apply the change to other firmwares. if we could get more people try the latest official ES and report issues that would help a lot (see this thread: https://llllllll.co/t/earthsea-edge-lock-up)

1 Like

Ah, excellent. I’m glad there is a plan.

Yes, and the files and folders normally do not indicate this either - I have a download folder full of monome related firmware folders and single hex files just called earthsea-1, ansible-2 and so on…

Just for the ones who are less familiar with all those libraries - is it important to have all firmwares fitting to each other now? As in “Don’t install this in case you have the original Meadowphysics module connected to your i2c chain which does not have a modified firmware by now”?

no, they are all compatible. it’s really only important if you have any i2c related issues, or pushing extremes on teletype (super quick metro script / audio rate triggers etc). in this case you want to have all modules updated to the latest version.

it should be clarified there were 2 groups of changes made to the libavr32 library - there were some i2c fixes a few months ago. i believe all the official firmwares should have those now.

then there were some additional stability changes i made in june, only the official ES firmware and the beta TT version i posted a while ago have them right now. at some point these changes will likely go to TT 2.1 (along with improved keyboard and screen response), and we will update all the other firmwares as well.

hope this clarifies things! have you had a chance to try the latest ES firmware? are you experiencing any issues still?

you should be downloading a zip file named ansible-1.5.1.zip which should make a similarly named folder. i don’t see why you should both moving the individual hex files around? just leave them in the folders, if you somehow feel compelled to save old versions.

I think TT 2.0 and Ansible 1.5.1 have the timer IRQ masking fixes too (that fixed USB issues). That was done at a similar time to the i2c changes.

Okay, I see that the zip files are individually named now - they get extracted automatically and I never see them on my system.

The folder then has the first number (before the first point) from the file and then a generated number if it is not the only Ansible-1 folder in the download folder. So actually they are named ansible-1, ansible-1-2 ansible-1-3 and so on. Teletype is now named teletype-2 the next firmware versions will be named teletype-2-2, teletype-2-3 and so on. But this seems to be something my computer does (MacBook, El Capitan). Maybe it just does not bother about numbers separated by points that much.

The individual hex files is what gets posted as trial versions for bug fixes on the forum every now and then. Normally I just shift them into an existing folder and confirm the replace or keep both request with replace to upload them to the module.

I feel compelled to save old versions since it was not always clear which one actually does work or fix a bug and often it seems to be needed to go back to an older firmware to check something or show where it started to go wrong.

You are right about my download folder being a mess though. Now that everything seems to work together it could be time to erase at least all monome related firmware things…

all the old firmware versions will continue to be on github, unless you’re talking about intermediary debug version, which i wouldn’t bother keeping around because we have no idea what code is actually in them.

i can’t explain why your .zip files would automatically unzip that way. on el capitan (as i have forever) i double-click the .zip file and it makes a folder with the same name as the zip.

There’s a setting for this in Safari’s settings, and I think it defaults to “automatically unzip stuff”. :confused:

Which would be fine if does not alter the name of the file but thanks for pointing me to this. It is the same setting that autoplays downloaded audiofiles…which annoyed me as much as downloading them instead of playing them in the browser window…not anymore now. :smirk:

At the moment I have this version installed I think. Together with all latest official versions for Ansible, Teletype and Meadowphysics. So should this work or shall I get back to first group of library changes?

And yes, actually I just found an issue: the second diagonal double gesture that is going down from the root note does change the three CV outs as expected and restarts the sequence but does not change the root note as all other double gestures do.

if you’re using the latest official firmwares (including ES that was posted on june 19th: https://github.com/monome/earthsea/releases/tag/v1.9.4) there shouldn’t be any issues with freezing / lock ups with 2 exceptions:

  • i was able to get one of the TT 2.0 betas to lock using an extreme case (audio rate triggers / super fast metro script with lots of i2c commands). i didn’t try reproducing it with the official 2.0 firmware but it’ll likely produce a similar result. unless you do want to use it in such extreme manner you will be fine with the official release. i was able to fix the issue and posted a test version here: Does your teletype stop responding after an hour or two? at some point this should become the basis for official 2.1 release, before that happens i will start a new thread and ask for help with beta testing. to reiterate, if you’re not planning to use TT in extreme manner use the latest official 2.0 version.

  • lock up issues with earthsea that were reported here: Earthsea Edge lock-up should be fixed in the latest official ES version. i asked several times in the thread if people were still experiencing the issues but didn’t get any replies… then there was an issue @saintcloud reported in that thread with shape outputs becoming corrupted, i was not able to reproduce it, which makes it difficult to fix. it would help a lot if others tried the latest version and reported back.

for the issue you mention i’ll take a look but it doesn’t sound like it’s related to i2c/lock up issues.

This is the firmware I have been running for awhile now. My grid became unresponsive on it a few days ago. It has only happened once.

You are right - I just tested it and it obviously never worked before (I tried it back to earthsea firmware v1.8), just that no one had noticed it. So maybe @tehn could have a look on it?

could someone please start a new thread about the ES bug and describe it fully? or revive an old thread that describes it?

It’s there: Earthsea two finger gesture bug

…not fixed though.