Issues connecting monome 128 to mlr-v [solved for Max6, but not Max7]

Hi everyone

I have recently taken delivery of a new 128. Installed the setup package + Max 6 runtime, copied the xsample files into the relevant Max directories. Monome Sum works great. However, I must admit I am having difficulty getting anything else to activate the grid.

Focussing on mlr-v - would anyone be able to give me some help? I’ve watched the setup video and everything of relevance to my case is in the first 22" so it’s a short watch. It didn’t help.

I have searched the old forum and while there are similar issues here and there, none of the fixes have any affect.

I’m using Mac OS-X 10.9.5, Max Runtime 6, MLR-V 2.3


Tim (uk)

mlrV requires Max 5. try that and you shouldn’t have issues.

I’m afraid not. I’ve tried 5, 6, and 7. In 7 I can at least see the grid in the dropdown, but still no lights on it in apps. The test patch running in 7 is the same - shows the grid in the dropdown, but no lights. In 5 and 6 there is nothing in the dropdowns in the test path. Curiously I found an old test patch in a zipped folder of utilities and that worked under 6 - lights in duplex.

I’m now looking at the current test patch under 7 and it can see the device, but pressing buttons on the device just makes the text string in the “select your arc” box change. I’m not using an arc, it’s a 128. So weird.

The “monome_test.maxpat” of 20111 running under 7 indicates the the grid is working and communicating correctly in both directions. The new “monome_test_5.maxpat” running under 7 has the grid in the dropdown and as above, pressing buttons causes the right hand upper windows, near the select your arc text, to change the three numbers at the end, but that’s the only communictaion possible. I this is odd becuase I don’t have an arc…why is that box populated?

I’ve tried both test patches in 5 and 6 and neither work.

The unit worked correctly with the monomesum application, I should add, but I’m not thrilled with something that only works with the one thing. That’s not the idea…

I’ve been trying lots of apps. the only one I can get to work is Straw 1.04 for max 7/serialosc. it works correctly.

i’m testing out the new 7.03 right now, just saw that it’s out now. will get back to you after checking it out.

in my simple understanding, serialosc is working correctly here, but the various apps are not necessarily loading all the requisite components, and are doing so inconsistently. so straw is quite simple and gets all its parts ok. mlrv is more complex and doesn’t find everything it needs, and varies in what it does find depending on what I’ve been downloading, running, copying to directories, file paths set etc.

the current behaviour im seeing here with mlrv2.3/max7 is that there’s no sound and only the first/left column of buttons plus the function buttons light up. nothing plays.

any relevant errors in the Max window? (cmd m) I notice in your first post you installed max6 runtime. did you use the full install or the runtime install? the runtime one doesn’t have everything. this is why they went to just one install for max7

Is xsample installed?

Yes there are errors, xgroove~ is not found/loaded and I think that means xsample is not either…I’ll just check the file list…there’s neither in the file list, although I do not actually know if they should show there.

This is Max7 which has no runtime, it’s just one thing.

I have a file path set up to a folder with xsample.mxo in it, which is what you do in 7 rather than copying file around like in 5 and 6.

newobj: xgroove~: No such object
newobj: xgroove~: No such object
newobj: xgroove~: No such object
newobj: xgroove~: No such object
newobj: xgroove~: No such object
newobj: xgroove~: No such object
newobj: xgroove~: No such object
newobj: xgroove~: No such object
udpreceiver: binding to port 12006
udpreceiver: binding to port 12288
udpreceiver: binding to port 7000
Jitter Java support installed
udpreceiver: binding to port 13332
udpreceiver: binding to port 8000
internal regular list:
time 120.00
internal permanent list:
metro 0.00
internal current eventlist:
internal regular list:
time 840.00
internal permanent list:
metro 0.00
internal current eventlist:

Externals and subpatcher files for _mlrV2.3:
Abstraction +DELAY.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/tabs/+DELAY.maxpat
Abstraction +MAPPING.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/tabs/+MAPPING.maxpat
Abstraction +REVERB.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/tabs/+REVERB.maxpat
Abstraction EMPTY.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/EMPTY.maxpat
Abstraction ch.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/ch.maxpat
Abstraction dac.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/dac.maxpat
Abstraction file_poly.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/file_poly.maxpat
Abstraction grid.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/grid.maxpat
Abstraction mixer.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/mixer.maxpat
Abstraction output.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/output.maxpat
Abstraction paramap.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/paramap.maxpat
Abstraction plx.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/plx.maxpat
Abstraction preset.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/preset.maxpat
Abstraction pttrn.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/pttrn.maxpat
Abstraction return.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/return.maxpat
Abstraction serialosc.maxpat System:/Applications/
Abstraction setlist.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/setlist.maxpat
Abstraction setup.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/setup.maxpat
Abstraction tabber.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/tabber.maxpat
Abstraction time.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/time.maxpat
Abstraction yafr2.maxpat System:/Users/Shared/Max 7/Packages/mlrv2.3004/tabs/yafr2.maxpat
Max Object rminus.mxo System:/Applications/
MSP64 Object rminus~.mxo System:/Applications/
Max Object rdiv.mxo System:/Applications/
MSP64 Object modulo~.mxo System:/Applications/
MSP64 Object plus~.mxo System:/Applications/
MSP64 Object minus~.mxo System:/Applications/
MSP64 Object lessthan~.mxo System:/Applications/
MSP64 Object greaterthan~.mxo System:/Applications/
Max Object absolutepath.mxo System:/Applications/
Max Object adstatus.mxo System:/Applications/
MSP64 Object allpass~.mxo System:/Applications/
Max Object append.mxo System:/Applications/
Max Object autopattr.mxo System:/Applications/
MSP64 Object biquad~.mxo System:/Applications/
MSP64 Object buffer~.mxo System:/Applications/
Max Object button.mxo System:/Applications/
Max Object clip.mxo System:/Applications/
Max Object coll.mxo System:/Applications/
MSP64 Object comb~.mxo System:/Applications/
Max Object comment.mxo System:/Applications/
Max Object counter.mxo System:/Applications/
MSP64 Object curve~.mxo System:/Applications/
MSP64 Object dac~.mxo System:/Applications/
Max Object dbtoa.mxo System:/Applications/
Max Object defer.mxo System:/Applications/
Max Object deferlow.mxo System:/Applications/
Max Object delay.mxo System:/Applications/
Max Object dropfile.mxo System:/Applications/
MSP64 Object edge~.mxo System:/Applications/
Max Object filepath.mxo System:/Applications/
MSP64 Object filtergraph~.mxo System:/Applications/
Max Object folder.mxo System:/Applications/
Max Object fpic.mxo System:/Applications/
Max Object fromsymbol.mxo System:/Applications/
MSP64 Object gain~.mxo System:/Applications/
MSP64 Object gate~.mxo System:/Applications/
Max Object hint.mxo System:/Applications/
MSP64 Object hostsync~.mxo System:/Applications/
Max Object in.mxo System:/Applications/
Max Object info~.mxo System:/Applications/
Max Object jit.cellblock.mxo System:/Applications/
Max Object js.mxo System:/Applications/
Max Object lcd.mxo System:/Applications/
Max Object line.mxo System:/Applications/
MSP64 Object line~.mxo System:/Applications/
Max Object live.guilib.mxo System:/Applications/
Max Object loadmess.mxo System:/Applications/
MSP64 Object lores~.mxo System:/Applications/
Max Object message.mxo System:/Applications/
MSP64 Object meter~.mxo System:/Applications/
Max Object metro.mxo System:/Applications/
Max Object midiinfo.mxo System:/Applications/
Max Object modifiers.mxo System:/Applications/
Max Object multislider.mxo System:/Applications/
Max Object mxj.mxo System:/Applications/
MSP64 Object noise~.mxo System:/Applications/
Max Object number.mxo System:/Applications/
Max Object onebang.mxo System:/Applications/
MSP64 Object onepole~.mxo System:/Applications/
Max Object opendialog.mxo System:/Applications/
Max Object out.mxo System:/Applications/
Max Object pak.mxo System:/Applications/
Max Object panel.mxo System:/Applications/
Max Object pattr.mxo System:/Applications/
Max Object pattrmarker.mxo System:/Applications/
Max Object pattrstorage.mxo System:/Applications/
MSP64 Object peakamp~.mxo System:/Applications/
MSP64 Object phasor~.mxo System:/Applications/
Max Object pipe.mxo System:/Applications/
MSP64 Object poly~.mxo System:/Applications/
Max Object prepend.mxo System:/Applications/
MSP64 Object rampsmooth~.mxo System:/Applications/
MSP64 Object rate~.mxo System:/Applications/
MSP64 Object receive~.mxo System:/Applications/
Max Object regexp.mxo System:/Applications/
Max Object round.mxo System:/Applications/
Max Object rslider.mxo System:/Applications/
Max Object savedialog.mxo System:/Applications/
Max Object scale.mxo System:/Applications/
Max Object screensize.mxo System:/Applications/
MSP64 Object selector~.mxo System:/Applications/
MSP64 Object send~.mxo System:/Applications/
MSP64 Object seq~.mxo System:/Applications/
MSP64 Object sfrecord~.mxo System:/Applications/
MSP64 Object sig~.mxo System:/Applications/
MSP64 Object slide~.mxo System:/Applications/
MSP64 Object snapshot~.mxo System:/Applications/
Max Object sprintf.mxo System:/Applications/
Max Object swatch.mxo System:/Applications/
MSP64 Object sync~.mxo System:/Applications/
Max Object tab.mxo System:/Applications/
MSP64 Object tapin~.mxo System:/Applications/
MSP64 Object tapout~.mxo System:/Applications/
Max Object textbutton.mxo System:/Applications/
Max Object textedit.mxo System:/Applications/
MSP64 Object thispoly~.mxo System:/Applications/
Max Object timer.mxo System:/Applications/
MSP64 Object times~.mxo System:/Applications/
Max Object toggle.mxo System:/Applications/
Max Object tosymbol.mxo System:/Applications/
Max Object transport.mxo System:/Applications/
MSP64 Object triangle~.mxo System:/Applications/
Max Object ubutton.mxo System:/Applications/
Max Object udpreceive.mxo System:/Applications/
Max Object udpsend.mxo System:/Applications/
Max Object umenu.mxo System:/Applications/
Max Object uzi.mxo System:/Applications/
Max Object waveform~.mxo System:/Applications/
Max Object zl.mxo System:/Applications/
Max Object zmap.mxo System:/Applications/

as you can see I put the mlrv folder in Packages within the Max7 folder in Users/Shared. This seems a better place to keep it than my desktop.

Sorry if it’s bad form to post such large blocks of text. It just seemed pragmatic in terms of conveying the information.

It doesn’t seem to matter where I put the xsample folder, xgroove~ does not load. I don’t know if this is the overall problem, but it seems pretty ropey behaviour.

ok this doesn’t solve that Max7 problem, but it works:

  1. go back to Max 6.1.9 runtime (32 bit in my case, my machine is 32 bit)
  2. follow the install instructions for xsample i.e. copying the txt file into the Cycling74’/init folder and the mxo file into msp-externals folder. the help file is not important in the runtime environment.
  3. make sure there is a copy of serialosc.maxpat available to Max, mine is in Applications/Max 6.1 runtime/Cycling74/max-startup. trial and error there. it seems like a tidy place for it.
  4. make sure there is a copy of serialosc.js in …/Cycling74’/jsextensions. you get the js file from here:
    (I found that out by reading the error in the Max window, then trial and error on the location)
    in many ways this is for me the vital hard-to-find-or-know-for-newbies piece of information. installing the Monome installer and xsample is not enough, Max appears to need access to both serialosc.maxpat and serialosc.js.
  5. put your mlrv folder in Users/[you]/Documents/Max/Packages
  6. fire up Max6
  7. load mlrv
  8. check in the Max window that you have no errors or duplicate file messages
  9. check that mlrv functions correctly
  10. tidy up all the mess you made thoughout your Max and User file structures on your way to this point
  11. breathe a long, tired sign of relief.
  12. if [your age]>[personal threshold] try not to regret this day of your life that you will never get back.

right, i got it going in max7.

firstly mlrv is written in max 5. so it should really be used in max5.

you need to install xsample in max7. to do this you:
find max7 in your applications folder, right click and show package contents.

modified xgroove installing instructions.
Installing [xgroove~]

Copy ‘xsample.mxo’ to:
Max5/Cycling '74/msp-externals/

Copy ‘xsample-objectmappings.txt’ to:
Max5/Cycling '74/init/

Copy ‘’ to:
Max5/Cycling '74/msp-help/

Restart Max5 (Max7)

also the setup file needed to be modified to fix for the new serialosc.maxpat which does not have an offset (for some reason the original serialosc.maxpat had an offset).
here my modified version:

this link probably wont be up forever.
all I did was find the bpatcher with serialosc loaded and change the offsets to 0. 0.

if theres a serialosc.maxpat in the mlrv folder delete it. it’s now part of the max7 package.

i tested mlrv for all of about 30 seconds. it appears to work as it should.

1 Like

Also a heap of the UI will look wrong. C74 changed a lot of the UI stuff in 7

Well, all I can say is I have tried hard to get it to work on my Mac in Max 5, 6, and 7 within the limitations of the data, support, files and level of knowledge available to me, and the only one I could get working was 6 as described above. It’s great to have it working :O)

The easiest way to use mlrv is the standalone application version. It has all of the necessary files built into requiring zero additions / modifications in your file structure. Plus, you don’t even have to think about which version of max it uses, rather just treat it like a normal piece of audio software:

Personally I don’t think it makes sense to try and run mlrv in Max 7 unless you really want to modify or add elements to the program.

That being said, we’re trying to improve the docs to avoid these issues, and focussing our energy solely on Max 7 as the platform to run software for the grids. It has the necessary serialosc files already included in the distribution which greatly simplifies the setup. It’s not quite 100% there yet, but I think we’re getting close!

1 Like