Issues connecting new Grid. USB ports seem deep (December batch)

Hi All.
I’ve just received one of the new USB C Grids from the December batch.
I was super excited to start exploring with it.

I fired it up straight away on my music iMac. (A high sierra model that I can’t update any further)

Everything worked fine, I was playing with Mark Eats Sequencer to orientate myself a little.
I ended up having to go out for a while, and when I came home I left my computer on overnight.

In the morning I restarted the mac and couldn’t get the Grid to connect, no matter how hard I tried.

I checked through all the troubleshooting steps

  1. Yes I was getting the lightburst when connecting the USB
  2. Yes, both processes for serial osc are running in Activity Monitor
  3. Initially the grid was showing up when I typed ls -lrt /dev/tty.usb*
    but later it vanished completely and I can’t get it back.
  4. I checked ls /System/Library/Extensions | grep FTDI and yes, only the Apple driver is showing.

I was kind of at my wits end
so I decided to try it out on my work laptop a 2018 macbook pro with USB C ports and Big Sur running.

I initially tried to use the grid with the USB C to USB A cable that it ships with.
Via the Apple USB-C Digital AV Multiport Adapter which is how I usually plug older USB A devices into the macbook with no problems.

However, when using this adaptor I can’t get the grid to connect either.
It shows a light burst when it plugs in, but nothing appears in the USB bus in System information, and nothing is found in terminal when running the aforementioned commands.

So I removed the USB C Multiport Adaptor from the equation and grabbed the regular white USB C to USB C cable that goes from my Macbook into the mains charger, and it doesn’t even plug into the grid properly.
It kinda goes in, but there’s no click that feels like it’s connected and just falls out afterwards, or if the grid is moved. It also doesn’t show the light burst, so I feel it’s not even making a connection.

It’s almost like there’s too much aluminium between where the outside of the grid starts and the usb c port on the inside of the grid begins.

I tried a different (non apple) usb c cable and the same thing happened. HOWEVER, this time I was able to get the grid to do the light burst and connect to my Macbook, and appear as a device in System information / mark eats sequencer etc. but the connection via USB was very iffy.

If I moved my grid slightly, it will disconnect and then I have problems getting it to reconnect.

The only cable that fits well, is the one the grid ships with, but i’m unable to connect that cable to my older mac, it just doesnt detect it anymore, (even though it did the very first time)

and I can’t use the shipped cable with the newer macbook because it wont connect through the USB C Multiport adaptor.

I find myself in a bit of dilemma.

Is it:
A) the fault lies with the grid, and nothing is making a good enough connection to the USB C port to get the grid to reliably connect to any cables and hence any computers?
or
B) the fault lies with the cable itself?
I find this second option hard to believe as the apple USB C cables dont even stay in the port,
C) a combination of both?
D) something else entirely?

I’m wondering if anyone else with one of the new USB C Grids can chime in and let me know if this is usual, or if I have a dud unit, or something else.

Sorry for the moan, but I was so excited to finally have one in my hands, it’s been a total anticlimax to find I can’t connect it reliably.

1 Like

i apologize for the very complicated first experience. to get right to it, i believe the USB port on your grid is defective (mis-mounted) and we can take care of it right away— email help@monome.org


when designing this grid edition i wanted a tight fit on the usb cable, as it provides extra mechanical support. i surveyed a large number of consumer USB C cables to establish the measurement— I commonly use a USB-C-C that came with my android phone, for example. however, since we released the grid we have stumbled across a few USB C cables which have an unexpected short connector (ie, too much plastic on them). so the issue is that the grid’s depth is pushing the threshold, and if you get a cable that is pushing this threshold, they won’t match well.

that said, i believe the reason your grid isn’t working is a bad USB C port, which must’ve (as you said, momentarily) worked fine during our testing.

1 Like

I’m unfortunately experiencing something similar with my mid-dec 2021 grid. It worked just fine for the first couple days ( glorious days they were!) but now I’m getting no power to the grid, tried 3 usb cables. I think it blipped on once on my PC, but won’t connect to norns or my Macbook. Already messaged help@monome.org but replying here as well in case its useful to other folks :slight_smile:

I’ll chime back in here to say that tehn and the monome team were incredibly fast at sending out a replacement board for me, it came from the USA to Australia faster than I was able to send my friend a postcard who lives in the same city.

Amazing service.

5 Likes

I just got a Grid 2 weeks ago and i’m having a similar issue, I see some lights when Norns Shield power up, and I sometimes see it in the devices menu, but it disappears from the device list in I click on it and I can’t get it to respond to any apps. I’ve already email Monome, but just curious if there is anything I can check to rule out a USB port issue.

we’ve seen a few units which have exhibited problems with the USB port: it’s an easy fix for us here, but not so DIY friendly. basically the symptom you said: powers (burst pattern) but doesn’t detect.

we can certainly sort this out via email, i’m sorry for the trouble.

2 Likes

Hey, I may be experiencing a similar issue right now. I have a mid-December grid and it’s actually worked flawlessly for the past several months. All of a sudden it’s not showing up under the Norns device menu. It is however, always connecting to my PC fine so I’m wondering if this is a different issue.

By coincidence, this actually happened after trying out the Colorwheel script, but now after removing that script and resetting its still not working so that might be a red herring.

@tehn do you think I should try flashing my Norns, or is there any command I could run via ssh that might help? I did run ls -lrt /dev/ | grep usb and no devices were detected.

sorry to hear about the trouble!

connecting to your PC is a good sign! a hardware failure wouldn’t be selective about connectivity, so sounds like something else. just to confirm, a single script wouldn’t cause your grid to stop connecting on norns. i know you’ve already done SYSTEM > RESET, which should clear out the devices and allow connection to occur. if you’ve already swapped cables, could you try running it once more, attempt connection to your grid, then please export logs and post them here or email help@monome.org?

1 Like

Can do! Thanks for the super fast response time also haha, best support :smiley:

Update:
Hey @dan_derks, just had a chance to export the logs. Definitely see something weird happening at the bottom, a tracebook around a nil value for adding devices, and mainly looks like the matron.service is failing to start due to a supercollider issue “### SCRIPT ERROR: SUPERCOLLIDER FAIL####”

Going to take a look at if Maiden’s giving more info on the supercollider issue.

norns-grid-connection-issue-log.txt (95.8 KB)

UPDATE 2:
I ran ;restart for both supercollider and matron from maiden, then replugged in the grid. It is now being detected. However the issue seems to be frequently reoccuring and I’ve had to restart those two things several times. Investigating further

1 Like

throwing my 2cents here, I’ve encountered similar misbehavior on raspberries on other projects (drivers loading spotly, failure to initialize wlan connectivity and so on) and the problem was always the microSD that was corrupted to a point where a complete swap was necessary.
So try flashing the norns image in a new one and see if it gets better!

1 Like