"Just Type" Beta Testers

teletype

#183

Yes it will work. It’s also totally fine to have the TIME cv (set to 0V) attached when you begin. The docs were written very quickly and are just a sketch. But yes, that should accurately calibrate the module.


#184

Ok great, i just wanted to double check


#185

Ok all working with this beta! Huge thankyou for this :slight_smile:

heres more Plume mode


#186

Lucky me learned about the release candidate tonight from @mlogger after playing the last few days with one of the betas. @Galapagoose you’ll enchant everyone who owns a JF and entice others after they become aurally transfixed by what’s coming out of these jacks. I listened to Floom for 15 minutes before switching to Plume that’s been evolving for the past 30 minutes via some LFO into Maths, a Mangrove into JF FM, Eloquencer into Run and Pamela’s New Workout pushing trigger duty. Out of a mere two modes I cannot report any issues but I can lay witness to the fact that Just Friends is pushing new boundaries of where social contours gather.


#187

I have to say, those demos sound wonderful.

Amazing work @Galapagoose


#188

Is it possible to use JF.TUNE custom tuning in synthesis mode? I have to assign a note every time I enable a channel for triggering, right ?
I tried using JI to assign ratios but the values seem off, but I havent really done the math


#189

Here’s a pre-release for all you loyal beta-testers. 3.0 in all it’s version-skipping glory.

Of course bug-fixes are welcome, but I won’t even be thinking about feature-requests for a few weeks. I’m trying to get it prepared for open-source alongside the docs, though it might lag a little.


#190

If we already calibrated our unit do we need to again after installing the update?


#191

No you don’t have to. The settings are not-overwritten.


#192

Hi. My two cents here, because I think I have an issue not mentioned yet tested with the last two releases (v2f-RC1 and v3.0)

I’m updating my JF and it’s going through all the steps : 6N blinking slowly then 5N flashing, 4N periodically flashing, (ID lit solidly during all the procedure), during the last second of the update the 3N 4N are lit together and then at the end of the audio file all the LEDs turn off. No calibration mode is engaged, when rebooting nothing more happen. The module does not respond to any triggers, no sound is present at the outputs.

I have a hardware version 1.

I can downgrade to software v1.0 without any issues fortunately, so I think it’not the soundsource that is causing this.


#193

I actually just had the same problem when updating to V3.0, though I never had it on any previous versions including v2f.

I rebooted (did not work immediately) and then plugged a jack into and out of run and changed the settings a bit (sorry I don’t remember the specifics) and then it started to work.


#194

I had the same problem. I downgraded to v1


#195

When you rebooted and it didn’t work immediately it’s because you were setup for “Bootloader” mode. I too have had to power down the rig, restart it, and either change a knob value or plug something in to move it out of its update mode.


#196

That was my initial thought but it wasn’t behaving as the bootloader mode. No LEDs were lit and no LEDs changed when switching between Shape and sound. Also I understand that access to bootloader mode is now different and shouldn’t be accessed after update.


#197

I don’t have a clear picture of what you’re describing. It sounds like the module needs to be manually power-cycled to begin working normally. Of course, if you leave the controls in the same position w/ RUN jack attached it will boot into the bootloader again.

Are you saying the new firmware doesn’t work at all?


#198

I’m not quite clear what happened but it seems a few people have described a similar thing (see muffwiggler JF thread also).

When I updated this version (V3.0), at the end of the update no LEDs were on and switching to shape and then back to sound had no effect. No modes would function at all. Manual power cycle did not fix it. I then tried plugging a cable into run and then unplugged it. I also moved the transient/sustain/cycle switch. One of those 2 things got it working. Now it seems to be fine.


#199

Ok. Confirmed this. The only thing that’s not working is the auto-restart after flashing finishes. Tracking down the cause, but the firmware itself seems to be running perfectly fine after power cycling the case.

edit: Or not? I just had the weird no-boot behaviour. Will update.


#200

auto restart didn’t happen to me as well. I was looking for calibration mode at first but then saw what @ghost said and power cycled, moving a knob before turning it back on per @unity2k , and it seems to be working fine now but I haven’t played with it yet


#201

This update has finally convinced me to get a JF… When will the new units go up on the store @Galapagoose?

:slight_smile:


#202

Six hours later, having not done any of the documentation work I had planned, I solved the first-boot problem. For any developers out there, remember that malloc doesn’t give you zeroed out memory!

Updated link on the JT webpage