"Just Type" Beta Testers

teletype

#203

Sadly, I remain unable to reboot using this latest update. There was no change in behavior between this version and the last.


#204

Actually, after calibrating, it appears to be working.


#205

Yes I think for those who tried the previous version (3.0h not quite), it will have zeroed out the tuning settings. I believe for those that didn’t try that version, this will work without a hitch.

If not, please let me know!


#206

I tried again twice and it still doesn’t appear to reboot at the end of the os update. It goes black. Calibration doesn’t appear to help.


#207

Does the calibration appear to work correctly? Can you see the lights when doing that procedure?


#208

I just re-ran the update and calibration and once again it all works fine. I’ve previously updated to two of the betas, the release candidate and both final releases.


#209

For me the v2f-RC1 was the first solid release were i had no issuses and all modes worked. I have not updated to V3 yet. With v2f-RC1 all the lights flash at the end. No calibration mode is engaged when finished - this is normal. Calibration is run as a separate step, after power down. The calibration notes are also out of date on the JF site.

Heres what i did for calibration of firmware v2f-RC1

For calibration - Turn off power, Set all knobs at maximum full clockwise

Select Mode Cycle / Sound and have a cable in the run jack

  1. Turn on the power & you will be in calibration mode.

  2. The IDENTITY led should light signalling you’re in calibration mode.

  3. The module is currently reading the CV input values, so make sure you don’t have any cables plugged in, except the RUN jack which should remain (but no signal going to it).

  4. Attach an accurate voltage source providing 0V to TIME cv input

  5. Switch to shape mode.

  6. Turn the voltage to 2v.

  7. Switch to sustain mode (The TIME cv input is now being read).

  8. Switch back to cycle mode (The captured 0v and 2v will be written to flash).

  9. Switch to sound mode - JF will work as normal


#210

What are you using as an accurate voltage source? (I don’t have a teletype (yet))


#211

i use an o’tool and attenuator


#212

For voltage source I’m using the Arturia Keystep and a Mordax DATA


#213

been using a cold mac and a multimeter to get 2V :sweat_smile: gonna try out latest update in a sec


#214

haha, thanks all, I think I’m gonna use the Qunexus (A2 should be 2v, IIRC) and a multimeter then.


#215

Thanks a lot @mlogger and @Galapagoose, it works now.

However it still the same problem with the new new V3 after the update (module not responding at all), but I’ve calibrated following the steps mlogger has given and it’s working.


#216

I posted a 3.0.1 which hopefully detects incorrectly initialized flash (though I’ve been unable to reproduce your situation here). This should fix the new bug where it doesn’t seem to restart properly after flash (read: it does restart, but is running at speed=0 thus silence)

///
A small note: you don’t have to calibrate unless you find the tracking is inaccurate in your system. if you do run into the “oh no my calibration is off” mess, you can ‘factory reset’ to the default tuning values.

I’m not going to be doing any more code updates for a few days unless there’s totally breaking problems, as I desperately need to rewrite the documentation.


#217

I’m traveling until Sunday. I’ll try the new update then, thanks


#218

finally had some time to update everything last night! update and calibration seemed to go well.

getting some strange behavior with JF in synth mode - but also not sure if i’m doing it right!

as i understand i need to set the module into cycle/sound mode.

then i should just enter JF.MODE 1 in TT for synth mode to kick in, yeah? that seems to work half the time and sometimes the module just freezes up. note: teletype does not freeze up.

when it didn’t freeze i made a little script that pings JF.NOTE (p.s. what is the upper limit for velocity? 5?)

that should just cycle thru the voices yeah? sometimes it will make one cycle thru all the voices and then freeze. other times it will not freeze. but - it seems that the voices are pinging based on the “time” knob value. i thought that putting JF.NOTE on the metro script in TT would then ping the voices at regular intervals based on metro time and that the “time” knob would be used for setting envelope time.

so i assumed the problem was that JF was set to “cycle” mode. switching to transient or sustain mode just stopped voicing all together.

eh?

note: i’m using the TT i2c backpack with earthsea & meadowphysics & ansible on the same bus. none of them are active in this script. i might just test a direct connection of only JF to see it’s an i2c problem. i’ll also try installing the latest build (currently on 3.0)


#219

‘JF.MODE 1’ works regardless of the mode switches. sound modes give you the synthesizer mode. cycle mode will loop JF’s internal envelope generator at the rate set by TIME. Use transient or sustain mode for traditional synth behaviour.

‘JF.VOX’ requires you to assign the voices yourself.

You probably want ‘JF.NOTE’ which auto-allocates polyphonically.

Velocity is set with Volts. So use ‘V 10’ for full-scale output -> perhaps this is why it seemed to stop working after one cycle.

///

That’s all I’ll write bc I’m literally writing all of this out in the next tab in my browser right now.


#220

yeah i was hesitant to say anything because i had a feeling you were updating the documentation right now :slight_smile: go go go! ignore me!

also JF.VOX was a typo - i was actually using JF.NOTE.


#221

one troubleshooting consideration for the new documentation: volume too loud.

wasn’t able to get the update to kick in when going direct from my laptop to JF. i’m using a fixed gain line -> modular preamp (ladik a-520) and i find that if my laptop volume is set to anything above 50% the update will fail.


#222

Good point - the bootloader is expecting a line-level (not modular) signal - I’ll make a note.

re: the ‘freeze’- what happens if you send a JF.MODE 0 command back to JF? It should return to normal operation if it hasn’t frozen. If it has frozen, it’ll probably lock up the Teletype.