"Just Type" Beta Testers

teletype

#223

hi,

I don’t know if this was already stated, but the mix out had no signal after the update.

power cycling the module did fix it.

3.0.2


#224

I just updated to 3.0.2 and can confirm that I too did not get a signal out of Mix, but I was getting a signal out of the other outs.

Another thing, I removed the patch cable from Run and tried changing the switches to see if I could trigger the Mix out but that didn’t help so I plugged the patch cable back into Run and still the Mix out was silent. So I returned to the bottom six outs and they all work, but plugging and unplugging Run didn’t trigger a mode change.

I rebooted the rig and JF is working like a dream.


#225

Thanks for the point about the mix out. It suffered the same uninitialized memory problem as the adc smoother. Fixed it and the rest of the instances across the project. Also spent a bunch of time dialing in the adc digital filtering. Fixed a bug where leaving Plume mode into sustain/sound would leave hanging notes. v3.0.3


#226

It’s in the realm of perfect for me now.


#227

3.0.3 fixed the output bug

one more thing : the identity led will light up when I start the audio playback. I’m sure it’s not a bug, but it could be mentioned in the Firmware Update Instruction.


#228

I have just connected my teletype and jf and installed 3.0.3 and I’ve noticed an issue, although I’m not sure whether it’s an issue with the firmware at all or just something about the connection of the two modules.

I’m just using the metronome script, cycling through a simple pattern in the metronome script and shifting jf to the note in the pattern as well as sending randomized jf.vtr commands to all channels. It seems like every few steps, the commands just aren’t received by just friends, i.e. although the read head of the teletypes pattern advances, the played note doesn’t change and the channels don’t get new vtr values. Could this just be a connectivity issue with the i2c cable? I’d have assumed that if the connection is good enough to get some commands across, it’s unlikely to break down in between, but I’m not sure.


#229

J u s t f r i e n d s w h e n


#230

Available to order now.


#231

Thank you so much for creating these wonderful instruments


#232

Just ordered. Very excited for this to arrive, thanks for all the hard work involved in making this into what it is @Galapagoose


#233

Placing my order now @Galapagoose !!!


#234

Can you provide the scripts you’re running? I’ve definitely seen JF drop i2c packets when there is 4+ JF.x commands fired at once. I’ve tracked down where it happens in the i2c slave driver, but the only solution i found was to add a seemingly arbitrary delay time in this case. I’ve avoided that as it can compromise the dsp calculaton & cause clicks in the audio. Will certainly work to improve this, though can’t promise anything immediately.


#235

Here’s the minimal version I need to reproduce the behavior. I set up a short pattern in TT, set JF to Sound/Sustain, JF.RMODE 1 and JF.RUN V -2 and then do this in M:

L 1 6 : JF.VTR I V RAND 6
JF.SHIFT P.NEXT

Most of the time it works, but sometimes it clearly messes up and doesn’t advance through the sequence. It’s definitely more than 4+ JF.x commands through that loop alone. If I drop the loop, JF moves through the sequence without issues. If that’s a problem for now, that’s not a big deal for me at all - it was just the first thing that I tried to learn the new commands. Although I can imagine many scenarios in which iterating over all channels with JF.VTR could be interesting.


#236

Looking for some insight to what to make of the most recent JF firmware before I get my hands on a TT. Floom is accessed how, for example? Any exploratory patches to try out to listen for differences? Thank you.


#237

You access Floom using the switches on the JF module. I don’t have my JF in front of me, but I am pretty sure that Floom is under Sound/Cycle now, and Plume has been moved to Sound/Sustain.


#238

Ok, what does a Run dummy cable achieve? I noticed something different sound wise. Apologies for another series of dumb questions, trying to catch up with the semantics while of course doing a lot of exploring. I know there’s still a lot happening documentation wise.

I feel I’m not ready to kick my Frames out for a Teletype just yet.


#239

Putting a cable in the Run jack sets the JF to Run mode. All Run modes, Floom included, need a cable patched to Run.


#240

Run mode is already documented here


#241

Just Friends demos from Martin Doudoroff are incredibly helpful @accountboy - take a look:


#242

Amazingly enough just what I needed. Love these.

So viewing these and re-reading the v3 update notes should cover it.